Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Atheros ar8152 e kernel 3.7 > non funziona
#1
ho installato mint 15 ma la connessione non funziona tramite ethernet se non x poichi minuti

ho scritto anche sul forum di ubuntu:
http://forum.ubuntu-it.org/viewtopic.php?f=49&t=556489
ho fatto numerosi tentetivi provato a instllare nuovi driver (compact-wireless) aggiornato bios ..... ma tutto niente da fare sembra connesso ma non naviga Piange
consigli?
grazie
Cita messaggio
#2
mi sembra di aver fatto un passo avanti :
tra vari sistemi che ho provato solo questo ha dato soluzioni soddisfacenti:

prima di tutto scaricare e installare wicd e disinstallare networkmanager (cosi' non si rischia di connettere ethernet e wifi contemporaneamente )

1)- andare qui :
https://bugzilla.redhat.com/show_bug.cgi?id=928220

e scaricare l'ultima pach x reset adapter.......

2)poi andare a scaricare :
https://www.kernel.org/pub/linux/kernel ... -u.tar.bz2
e scaricare i compat driver

3)applicare la patch in:
/home/giorgio/Scaricati/dor/compat-drivers-2013-03-28-5-u/drivers/net/ethernet/atheros/atl1c/atl1c_main.c

4) installare i drive con :
./scripts/driver-select atl1c
make
sudo make install
poi riavviare e dl'ethernet dovrebbe funzionare (piu o meno)
questo metodo e' stato sperimentato con ubuntu e majaro (arch) e kernel 3.9....

vi sarei grato se chi ha la mia stessa scheda ethernet (ar8152) mi sappia dire se anche a lui funziona e le sue impressioni grazie
e consigli x fare qualche miglioramento Idea
non mi sembra che vada tutto perfettamente :a volte la connessione ha qualche incertezza quindi vi sarei grato se qualcuno piu' esperto di me mi possa dare qualche consiglio

ancora non ci siamo...ma
mi sembra che se da wicd si disabilita la scheda wifi (tanto quando si e' connessi via ethernet il wifi non serve Smile ) la situazione migliora sensibilmente....
Cita messaggio
#3
(22-06-2013, 02:13 )giorgio.01 Ha scritto: mi sembra di aver fatto un passo avanti :
tra vari sistemi che ho provato solo questo ha dato soluzioni soddisfacenti:

prima di tutto scaricare e installare wicd e disinstallare networkmanager (cosi' non si rischia di connettere ethernet e wifi contemporaneamente )

1)- andare qui :
https://bugzilla.redhat.com/show_bug.cgi?id=928220

e scaricare l'ultima pach x reset adapter.......

2)poi andare a scaricare :
https://www.kernel.org/pub/linux/kernel ... -u.tar.bz2
e scaricare i compat driver

3)applicare la patch in:
/home/giorgio/Scaricati/dor/compat-drivers-2013-03-28-5-u/drivers/net/ethernet/atheros/atl1c/atl1c_main.c

4) installare i drive con :
./scripts/driver-select atl1c
make
sudo make install
poi riavviare e dl'ethernet dovrebbe funzionare (piu o meno)
questo metodo e' stato sperimentato con ubuntu e majaro (arch) e kernel 3.9....

vi sarei grato se chi ha la mia stessa scheda ethernet (ar8152) mi sappia dire se anche a lui funziona e le sue impressioni grazie
e consigli x fare qualche miglioramento Idea
non mi sembra che vada tutto perfettamente :a volte la connessione ha qualche incertezza quindi vi sarei grato se qualcuno piu' esperto di me mi possa dare qualche consiglio

ancora non ci siamo...ma
mi sembra che se da wicd si disabilita la scheda wifi (tanto quando si e' connessi via ethernet il wifi non serve Smile ) la situazione migliora sensibilmente....
aggiungendo la patch ai driver atl1c,abilitando wicd al posto di network manager ,disabilitando da wicd il wifi ,connettendomi con ip fisso tutto mi sembra che funzioni

vorrei sapere le vostre prove?

confermo che l'ultima configurazione fino ad esso sembra funzionare perfettamente e anche i dowload di file consistenti sembrano veloci e stabili Sad
Cita messaggio
#4
mmmh, se nessuno risponde forse nessuno ha la tua stessa scheda di rete in congiunzione con la stessa distribuzione (temo)
Il mio blog: http://zerozerocent.blogspot.it/
Legge di Murphy: SE QUALCOSA PUO' ANDAR MALE, LO FARA'
Cita messaggio
#5
(22-06-2013, 22:15 )BAT Ha scritto: mmmh, se nessuno risponde forse nessuno ha la tua stessa scheda di rete in congiunzione con la stessa distribuzione (temo)

questa scheda di rete la ar8152 era molto popolarere nei notbook di 2 o 3 anni fa e questo "procedimento" si puo' applicare a tutte le distro in pratica tutti i notbook che montano questa scheda x ethernet presentano queso problema con i nuovi kernelAt
Cita messaggio
#6
altro modo per installare stabilmente i compat-wireless: http://www.istitutomajorana.it/forum/Thr...#pid158166
 Trasferito sul Nuovo Forum [img]images/smilies/blush.gif[/img]
Cita messaggio
#7
(29-06-2013, 09:22 )GiuS Ha scritto: altro modo per installare stabilmente i compat-wireless: http://www.istitutomajorana.it/forum/Thr...#pid158166

mi sembra di poter dire ke forse il problema e' stato risolto:

installato il nuovo kernel 3.11 rc4
guida qui:
http://linuxg.net/kernel-3-11-rc4-has-b ... inux-mint/
con wifi e ethernet attivi tutto funziona Big Grin

anche con kernel 3.4.56 long term tutto ok
http://linuxg.net/how-to-install-kernel ... derivates/

mentre con kernel 10.5 stable ancora ethernet con wifi abilitato instabile

questo sperimentato con mint 15 e quindi anche con ubuntu 13.04 :lol:

ditemi se cosi risolvete :ciao:
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)