Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[Disc. divisa] synce problemi fra pacchetti con diversi aggiornamenti
#1
Questa discussione prosegue da questo post: http://www.istitutomajorana.it/forum/Thr...gere-synce

Ciao, sono nuovo del Forum, prima di tutto grazie per questo post che mi sta aiutando a risolvere il mio problema.
Io ho synce che funziona bene su Lucid, ora vorrei passare a Oneiric e sto provando a configurarlo su una macchina di test su cui è installato Oneiric.
Ho seguito le istruzioni di token, ma quando installo synce-connector salta fuori:
Codice:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
Alcuni pacchetti non possono essere installati. Questo può voler dire
che è stata richiesta una situazione impossibile oppure, se si sta
usando una distribuzione in sviluppo, che alcuni pacchetti richiesti
non sono ancora stati creati o sono stati rimossi da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:

I seguenti pacchetti hanno dipendenze non soddisfatte:
synce-connector : Dipende: libsynce0 (= 0.16~20111228-0ubuntu0~ppa1~oneiric1) ma la versione 0.16~20111230-0ubuntu0~ppa1~oneiric1 sta per essere installata
E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.

Qualcuno può darmi una mano?
Grazie mille!
Ciao
A.
Cita messaggio
#2
ciao angus, divido la discussione e ne creo solo una per il tuo problema.
io non uso synce e non posso aiutarti, speriamo in qualche altro membro del forum.

ciao
 Trasferito sul Nuovo Forum [img]images/smilies/blush.gif[/img]
Cita messaggio
#3
(07-04-2012, 21:55 )Angus73 Ha scritto: Ciao, sono nuovo del Forum, prima di tutto grazie per questo post che mi sta aiutando a risolvere il mio problema.
Io ho synce che funziona bene su Lucid, ora vorrei passare a Oneiric e sto provando a configurarlo su una macchina di test su cui è installato Oneiric.
...
Qualcuno può darmi una mano?
Grazie mille!
Ciao
A.

Su una installazione pulita di Oneiric ho installato synce nel seguente modo.
Aggiunto repository
deb http://ppa.launchpad.net/synce/synce-head/ubuntu oneiric main
Installato synce-gvfs (versione 0.5~20111119-0ubuntu0~ppa1~oneiric1)
[e relative dipendenze
hal (versione 0.5.14-6)
hal-info (versione 20091130-1)
libdynamite0 (versione 0.1.1-2)
libgnet2.0-0 (versione 2.0.8-2build1)
libhal-storage1 (versione 0.5.14-6)
libhal1 (versione 0.5.14-6)
libmimedir0 (versione 0.5.1-3)
liborange0 (versione 0.4-2)
librra0 (versione 0.16~20111116-0ubuntu0~ppa1~oneiric1)
libsynce0 (versione 0.16~20111230-0ubuntu0~ppa1~oneiric1)
libunshield0 (versione 0.6-2)]
Installato synce-trayicon (versione 0.16~20111119-0ubuntu0~ppa1~oneiric2)
[e relative dipendenze
synce-dccm (versione 0.16~20111230-0ubuntu0~ppa1~oneiric1)]
Installato synce-tools (versione 0.16~20111230-0ubuntu0~ppa1~oneiric1)(questo non dovrebbe essere essenziale, se non per i tool a linea di comando).
Copiata ~/.synce da backup (per tenermi i partner che mi servono).
Fatto partire synce-trayicon, collegato ipaq: icona nel pannello, status ipaq visibile, quindi messo synce-trayicon in applicazioni d'avvio.
Al riavvio del sistema, ipaq anche navigabile con nautilus.
Consiglio di installare (o perlomeno selezionare) i pacchetti nell'ordine indicato (incredibile, ma vero, cosa succede se inverti i primi due).

Synce pare abbastanza problematico da installare, visto che bisogna usare repo esterni (ppa) e che cambiano i pacchetti necessari secondo da quale situazione si parte (cosa per me inspiegabile senza dover stramaledire qualcuno).
Nota per esempio che qui non ho installato synce-connector, cosa invece necessaria da una Oneiric derivata da una precedente Maverick.

Bye
Token
Cita messaggio
#4
Grazie per aver creato il nuovo thread, e grazie mille a Token per le informazioni... Io nel frattempo sono riuscito ad avere synce funzionante (ma senza sincronizzazione con Evolution, di cui per ora non mi sono occupato). Purtroppo non ho ben capito come ho fatto, tra installazioni e disinstallazioni varie mi è venuto fuori un bel mucchio di passaggi di cui non sono riuscito a tenere traccia. In ogni caso io non sono un esperto, ma da quello che ho visto installare synce è davvero complicato. Per questo mi piacerebbe capire un po' di cose, almeno per togliermi qualche dubbio da profano:

- che differenza c'è tra il repo con .../synce/ubuntu/... e quello con .../synce/synce-head/ubuntu/... ? Entrambi sembrano funzionanti da quel che posso capire, o sbaglio?

- un po' di volte (ahimè, posso solo percepirlo come un comportamento random) quando connetto il palmare si attiva correttamente la trayicon; altre volte non compare e se lo scollego e lo ricollego più volte continua a non comparire, finchè a volte a un certo punto compare, altre volte compare solo se riavvio il sistema... ovviamente tutto ciò senza toccare alcun file di configurazione. Da cosa può dipendere?

- Quando si sincronizzano i dati del palmare, i files vengono automaticamente aggiornati nella ~/PDAFiles, che però viene prima completamente svuotata e poi riempita di nuovo, con la conseguenza che cambia la data di modifica di tutti i files sul PDA Undecided Qualcuno sa se c'è un modo di disabilitare l'aggiornamento dei file in questa directory PDAFiles? Inoltre, ho ravvisato alcuni strani comportamenti che per brevità non riporto qui e se interessano potete leggere su

http://forum.ubuntu-it.org/index.php?PHP...msg3163547

Qualcuno può aiutarmi a capire come mai, oppure può semplicemente dirgli che gli/le funziona?

Grazie mille, ciao ciao
A.
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)