Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


//Removed by EUCookieLaw Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Driver proprietari ed fglrx-updates danno problemi l'unica soluzione sono gli open
#1
Ho verificato che i fglrx-updates danno problemi quello della plymount ed anche il fatto che non si riesce a vedere se ci siano errori di avvio essendo lo schermo nero, poi aprendosi Ubuntu, Gimp non si avvia tale ultimo fatto espresso succede anche con i Driver Ati/Amd 13.04, altro problema con i proprietari quando sposto ad esempio la finestra del terminale si muove strano a scatti nello schermo la soluzione sta nel mettere gli Open, il problema ora sorge che ho seguito questa guida:

http://www.yourownlinux.com/2013/05/inst...phics.html

Ho riavviato, nella speranza di risolvere i problemi testé citati dando il comando:

Codice:
sudo aticonfig --initial -f

Operazione andata in vano, mi sono dunque recato sul terminale per operare alla rimozione dei proprietari con:

Codice:
sudo sh /usr/share/ati/fglrx-uninstall.sh
[sudo] password:
sh: 0: Can't open /usr/share/ati/fglrx-uninstall.sh
:~$ sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev* xorg-driver-fglrx

Ma il risultato è il medesimo:

Codice:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
Pacchetti virtuali come "xorg-driver-fglrx" non possono essere rimossi
E: Impossibile trovare il pacchetto fglrx_12.104-0ubuntu1_amd64.deb
E: Impossibile trovare alcun pacchetto tramite l'espressione regolare "fglrx_12.104-0ubuntu1_amd64.deb"
E: Impossibile trovare il pacchetto fglrx-amdcccle_12.104-0ubuntu1_amd64.deb
E: Impossibile trovare alcun pacchetto tramite l'espressione regolare "fglrx-amdcccle_12.104-0ubuntu1_amd64.deb"
E: Impossibile trovare il pacchetto fglrx-dev_12.104-0ubuntu1_amd64.deb
E: Impossibile trovare alcun pacchetto tramite l'espressione regolare "fglrx-dev_12.104-0ubuntu1_amd64.deb"

Quindi che devo fare? Che ora mi trovo i proprietari che non vanno e non si eliminano e non posso dunque mettere gli open?

In ultima analisi leggo spesso che si dice che gli Open scaldano o non funzionano ad hoc etc, io ho notato che gli Open non scaldano più dei proprietari ed anzi le pagine internet si vedono meglio ed il sistema è più performante...
«Quanta strada ha fatto il tuo pensiero per giungere alla sapienza, e quanta dovrà ancora farne per giungere alla verità?» (G. A. Rol) Idea 

Ubuntu 12.04 Plus Remix - 64 bit
Cita messaggio
#2
se gli open non ti danno problemi usali tranquillamente, ma il problema sorgerà se devi farci girare applicazioni 3D complesse come i videogames, o alcuni video 1080p a schermo intero

se vai in jockey (driver aggiuntivi) ti riporta i driver proprietari che hai attivato, basta che li disattivi e avrai gli open

tuttavia forse ci sono altri spippolamenti da fare, ed è meglio che aspetti il parere di Matteo o di qualcun altro più esperto, perché sanno tutto sulla faccenda
ogni buon maestro che si fa, invisibile

http://www.virtualinn.it
Cita messaggio
#3
Non gioco con il computer ergo penso che posso ovviare... lo uso per studiare per lavoro, per giocare ho sempre preferito le consolle che sono nate per i giochi; comunque i problemi degli fglrx-updates e dei proprietari non li riesco a comprendere... ho provato sia con il kernel 3.11.xxx che con il 3.2.xxx sempre medesimi problemi, il fatto è che ora non riesco a rimuovere il proprietario e se vado su driver aggiuntivi non è nulla di attivo ma quelli lì che si vedono che sono mancanti dovrebbero riferirsi agli fglrx-update e non ai driver Ati/Amd proprietari,

   
«Quanta strada ha fatto il tuo pensiero per giungere alla sapienza, e quanta dovrà ancora farne per giungere alla verità?» (G. A. Rol) Idea 

Ubuntu 12.04 Plus Remix - 64 bit
Cita messaggio
#4
Lascia perdere Jockey che ha sempre fatto casini (a me ve lo assicuro ... a qualcuno l'ho letto).
Tu gli hai installati da binari quindi da qualche parte devi avere l'uninstall ... il fatto che ti dia errore con questo comando sudo sh /usr/share/ati/fglrx-uninstall.sh potrebbe dipendere dal fatto che non si chiama così il file ... entra con nautilus (o quello che usi) nella cartella /usr/share/ati e vedi se c'è un unistall che si riferisce a fglx ... in tal caso ridai il primo comando mettendo il nome esatto.

Che il secondo comando ti risponda errore .... bhe ... non mi stupisco ... è per gli open Wink
Cita messaggio
#5
Non vedo nulla per disinstallare...

   
«Quanta strada ha fatto il tuo pensiero per giungere alla sapienza, e quanta dovrà ancora farne per giungere alla verità?» (G. A. Rol) Idea 

Ubuntu 12.04 Plus Remix - 64 bit
Cita messaggio
#6
Fai alla vecchia maniera:
Codice:
sudo apt-get --purge autoremove fglrx*.deb
e riavvia.

Se riparte sei con gli open ... per controllare sai come fare
Cita messaggio
#7
Appena termina di scaricarsi la .iso 13.10 plus provo a fare il comando indicatomi
«Quanta strada ha fatto il tuo pensiero per giungere alla sapienza, e quanta dovrà ancora farne per giungere alla verità?» (G. A. Rol) Idea 

Ubuntu 12.04 Plus Remix - 64 bit
Cita messaggio
#8
Nemmeno così va...

Codice:
:~$ sudo apt-get --purge autoremove fglrx*.deb
[sudo] password for davidelex84:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze        
Lettura informazioni sullo stato... Fatto
W: Duplicate sources.list entry http://dl.google.com/linux/chrome/deb/ stable/main amd64 Packages (/var/lib/apt/lists/dl.google.com_linux_chrome_deb_dists_stable_main_binary-amd64_Packages)
W: Duplicate sources.list entry http://dl.google.com/linux/chrome/deb/ stable/main i386 Packages (/var/lib/apt/lists/dl.google.com_linux_chrome_deb_dists_stable_main_binary-i386_Packages)
W: È consigliato eseguire "apt-get update" per correggere questi problemi
E: Impossibile trovare il pacchetto fglrx_12.104-0ubuntu1_amd64.deb
E: Impossibile trovare alcun pacchetto tramite l'espressione regolare "fglrx_12.104-0ubuntu1_amd64.deb"
E: Impossibile trovare il pacchetto fglrx-amdcccle_12.104-0ubuntu1_amd64.deb
E: Impossibile trovare alcun pacchetto tramite l'espressione regolare "fglrx-amdcccle_12.104-0ubuntu1_amd64.deb"
E: Impossibile trovare il pacchetto fglrx-dev_12.104-0ubuntu1_amd64.deb
E: Impossibile trovare alcun pacchetto tramite l'espressione regolare "fglrx-dev_12.104-0ubuntu1_amd64.deb"

Io per installare i driver Ati ho fatto questo:

Codice:
wget http://www2.ati.com/drivers/linux/amd-catalyst-13.4-linux-x86.x86_64.zip


unzip amd-catalyst-13.4-linux-x86.x86_64.zip


chmod +x amd-catalyst-13.4-linux-x86.x86_64.run


sudo dpkg -i fglrx*.deb

Come si tolgono? La guida a cui ho attinto come citavo prima è questa... http://www.yourownlinux.com/2013/05/inst...phics.html

Senti se andassi ad eliminare la cartella ATI tasto destro elimina? Smile At che ne dici? Ho eliminato non c'è più ma si avvia ancora con la ATI...
«Quanta strada ha fatto il tuo pensiero per giungere alla sapienza, e quanta dovrà ancora farne per giungere alla verità?» (G. A. Rol) Idea 

Ubuntu 12.04 Plus Remix - 64 bit
Cita messaggio
#9
Ho provato anche con:

Codice:
Disinstallare i driver proprietari e tornare a quelli Open
Se avete installato i driver tramite pacchetto deb

Digitate per prima cosa:

sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*
Rimuovete il vostro xorg.conf:

sudo rm /etc/X11/xorg.conf
Reinstallate xorg:

Per i sistemi a 32 bit:

sudo apt-get install --reinstall xserver-xorg-core libgl1-mesa-glx libgl1-mesa-dri
Per i sistemi a 64 bit:

sudo apt-get install --reinstall libgl1-mesa-glx:i386 libgl1-mesa-glx:amd64 libgl1-mesa-dri:i386 libgl1-mesa-dri:amd64 xserver-xorg-core
Ora configurate Xorg:

sudo dpkg-reconfigure xserver-xorg
E riavviate:

sudo reboot
Se avete installato i driver dai binari

Digitate:

sudo sh /usr/share/ati/fglrx-uninstall.sh
Rimuovete il file xorg.conf:

sudo rm /etc/X11/xorg.conf
Reinstallate xorg:

Per i sistemi a 32 bit:

sudo apt-get install --reinstall xserver-xorg-core libgl1-mesa-glx libgl1-mesa-dri
Per i sistemi a 64 bit:

sudo apt-get install --reinstall libgl1-mesa-glx:i386 libgl1-mesa-glx:amd64 libgl1-mesa-dri:i386 libgl1-mesa-dri:amd64 xserver-xorg-core
Configurate Xorg:

sudo dpkg-reconfigure xserver-xorg
Riavviate:

sudo reboot

Ma non va... ho provato con entrambi i due metodi citati per binari e non binari
«Quanta strada ha fatto il tuo pensiero per giungere alla sapienza, e quanta dovrà ancora farne per giungere alla verità?» (G. A. Rol) Idea 

Ubuntu 12.04 Plus Remix - 64 bit
Cita messaggio
#10
Se cancelli la cartella ati non disinstalli nulla... hai un problema di apt ... se nn po risolvi sei bloccato con pa distro... apri synaptic e cerca e cancella tutti i file che richiamano fglrx
Cita messaggio


Vai al forum: