Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


//Removed by EUCookieLaw Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Dual boot Win / Ubuntu impossibile / problema uefi
#1
Salve a tutti.
Da circa un mese sto inutilmente tentando di mettere in dual boot Windows 8 preinstallato con ubuntu 12.10. Il sistema ha un architettura per me insolita, vale a dire 64 bit, uefi e secure boot.
L ultima volta che ho installato ubuntu con win xp risale ai tempi di Lucid Linx. Per me uefi euna materia del tutto nuova. All inizio, ho provato ad installare ubuntu 12.10 su un Dell XLS 8500 cominciando da cio che sapevo fare.
Parizionamento effettuato, il problema nasce con il boot loader.
Per motivi che non capisco non riesce a vedere entrambe i s.o. come faceva finora benissimo. I problemi saltano agli occhi dalla stranissima schermata del grub 2 contente voci a me incomprensibili.
1. Ubuntu
2. Advanced options for ubuntu
3. Windows UEFI Loader
4,Windows UEFI Loader sda1
5.Windows boot uefi bkpbootx64.efi
6.Windows boot uefi bootx64.efi.bkp
7.System setup
Di questi soltanto la 1,2 e 7 sono funzionanti e solo per ubuntu. Niente da fare per Windows. Sfortunatamente per alcuni applicativi ho bisogno di Windows e se non riesco a capire che fare, con grosso rammarico dovro tornare alla configurazione di partenza. Venendo al punto, tra i vari forum aperti sul problema ho conosciuto boot-repair e sto facendo una serie di tentativi non certo coronati dal successo.
Al primo tentativo ho seguito la Riparazione semplice raccomandata per risolvere i problemi piu comuni. Ne risulta lo strano menu che ho riportato.
Quindi ho provato a scegliere opzione 3. Windows 8 si avvia e funziona correttamente. Al riavvio mi appare uno schermo nero con il messaggio <no bootable device avalaible!!!...>. Pazientemente inserisco la live usb e riavvio il tutto.
Uso Boot-repair passando stavolta alle opzioni avanzate. Su main options lascio tutto invariato, vale a dire:
Reinstall grub
Backup and rename efi files
Unhide boot menu: 10 sec.
Su Grub location trovo:
ubuntu su sda8 come dovrebbe dato il partizionamento.
Grub location: sda1.
Faccio notare che istallando grub la destinzione indicata dal sistema era /dev/sda, che almeno una volta era il mbr. Non capisco da dove venga fuori sda1.
Noto solo che esiste una partizione preimpostata da DELL sda1 fat 32 di 500 mb, che potrebbe contenere istruzioni di avvio multiplo. Ho chiesto delucidazioni a dell ma finora non ho avuto risposta. Non vorrei aver commesso il banalissimo errore di non correggere /dev/sda con /dev/sda1 in installazione.
Applico le variazioni effettuate con boot-repair e riavvio. mi compare lo stesso menu di cui sopra.
Provo l opzione 4 (Windows UEFI Loader sda1). Niente. Mi rimanda al menu senza alcun effetto percepibile. Quindi passo all opzione 5, e astavolta in modo simile alla 3 Windows 8 parte ma si perde nel nulla al reboot. No bootable device avalaible.
A questo punto non so piu cosa inventare. Spero che possiate darmi un aiuto. Nel frattempo vi invio i bootlog creati da boot-repair nella speranza che possano essere di aiuto.
http://paste.ubuntu.com/1632765/
http://paste.ubuntu.com/1632800/

Cordiali saluti,
Enrico dini
Cita messaggio
#2
ciao, non so se è vero Huh ma ho sentito che sui pc con preistallato win8 hanno molti problemi quando si installa ubuntu 12.10 in giu, per risolvere serve il disco di ripristino di windows in modo che ripristinando l'MBR funzioni correttamente. Qui un video che spiega come fare:

http://www.youtube.com/watch?v=ya-TsBSc4z8

L'ISO di windows se non ce l'hai puoi trovare la versione enterprise sul sito ufficiale microsoft (ti devi registrare). Una volta creato il cd segui il video di prima. se poi vuoi installare ubuntu ti suggerirei Wubi.
Spero di esserti stato d'aiuto.
Cita messaggio
#3
si puo disabilitare secure boot?e credo che avresti dovuto disabilitare anche la tabella gpt (in una discussione postata da me mi si diceva che dopo non sarebbe partito win ma di questo io non ne sono sicuro)

quando e come hai creato la partizione in cui hai installato ubuntu?
Cita messaggio
#4
(11-02-2013, 19:55 )wiktor Ha scritto: si puo disabilitare secure boot?e credo che avresti dovuto disabilitare anche la tabella gpt (in una discussione postata da me mi si diceva che dopo non sarebbe partito win ma di questo io non ne sono sicuro)

quando e come hai creato la partizione in cui hai installato ubuntu?

Dal momento che l'opzione system setup funziona ed apre quello che almeno una volta era l'ambiente bios, sembra possibile disabilitare secure boot. Sembra l'uovo di Colombo, e in effetti dato che il dual boot non funziona potrei tentare. Preferirei una linea più prudente per il momento, non so bene cosa tocco e non vorrei trovarmi con entrambe i s.o. inservibili. Comunque sono aperto a consigli.
Con rif. alla seconda domanda, francamente non ricordo bene quando ho installato ubuntu sul nuovo pc. Per il come, la cosa è più complessa.
In un primo tempo ho tentato di installare Precise dal momento che una LTS è più stabile e duratura.
I primi tentativi si sono scontrati con un'apparente incompatibilità tra Grub 1.9 e i nuovi sistemi di tipo UEFI con secure boot. Quindi ho tentato con ubuntu 12.10 sapendo che si basa su Grub2. Così pensavo ma evidentemente mi sbagliavo. Cfr. Menu di Grub inconcludente prima citato.
Per quanto riguarda il partizionamento, ho proceduto come ero abituato dai tempi di partition magic. Da usb bootable ho creato e modificato le 5 o 6 partizioni preimpostate da DELL. Per ubuntu ho creato sda8 con file system ext4 vuota. Poi ho proceduto all'installazione con Grub 2 impostato per puntare al sda e ubuntu su sda8 punto di mount= / come sempre.
Installato Gdisk. Sperando che sia utile vi posto il risultato:
------------------------------------------------------------------------------------------
enrico@WOPR-2013:~$ sudo gdisk
GPT fdisk (gdisk) version 0.8.5

Type device filename, or press <Enter> to exit: sda
Problem opening sda for reading! Error is 2.
The specified file does not exist!
enrico@WOPR-2013:~$ gdisk -l /dev/sda
GPT fdisk (gdisk) version 0.8.5

Problem opening /dev/sda for reading! Error is 13.
You must run this program as root or use sudo!
enrico@WOPR-2013:~$ sudo gdisk -l /dev/sda
GPT fdisk (gdisk) version 0.8.5

Partition table scan:
MBR: protective
BSD: not present
APM: not present
GPT: present

Found valid GPT with protective MBR; using GPT.
Disk /dev/sda: 3907029168 sectors, 1.8 TiB
Logical sector size: 512 bytes
Disk identifier (GUID): 0FF7F015-4185-4E5A-8BBC-98945CDB443E
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 3907029134
Partitions will be aligned on 2048-sector boundaries
Total free space is 14694 sectors (7.2 MiB)

Number Start (sector) End (sector) Size Code Name
1 2048 1026047 500.0 MiB EF00 EFI system partition
2 1032192 1114111 40.0 MiB FFFF Basic data partition
3 1114112 1376255 128.0 MiB 0C01 Microsoft reserved part
4 1376256 2400255 500.0 MiB 2700 Basic data partition
5 2400256 388349951 184.0 GiB 0700 Basic data partition
6 3892652032 3907022598 6.9 GiB 2700 Microsoft recovery part
7 1804087296 3838349311 970.0 GiB 0700
8 388349952 1804087295 675.1 GiB 0700
9 3838349312 3892652031 25.9 GiB 8200
enrico@WOPR-2013:~$
----------------------------------------------------------------------allego inoltre quello che ved gparted su sda
Saluti a tutti.


Allegati Anteprime
   
Cita messaggio
#5
ciao, prima di tutto un poco di chiarezza: uefi è un tipo di partizionamento del disco dove l'avvio non viene più fatto da mbr ma da una partizione dedicata ( da quello che si vede dovrebbe essere dev/sda1 )
securebott è una protezione che impedisce il boot di programmi che non contengano al loro interno una "firma" che sia riconosciuta. se dici che tu parti con programmi bootabili oppure con disco di installazione buntu vuol dire che tu il secureboot non lo hai attivo. a questo punto se riesci ad installare alla schermata di selezione del loder scegliendo dev/sda1 dovresti risolvere.
quello che mi preoccupa è che bootrepair non abbia risolto, non vorrei che tu abbia complicato il tutto.
http://wiki.ubuntu-it.org/Installazione/UEFI
Cita messaggio
#6
(12-02-2013, 21:38 )dxgiusti Ha scritto: ciao, prima di tutto un poco di chiarezza: uefi è un tipo di partizionamento del disco dove l'avvio non viene più fatto da mbr ma da una partizione dedicata ( da quello che si vede dovrebbe essere dev/sda1 )
securebott è una protezione che impedisce il boot di programmi che non contengano al loro interno una "firma" che sia riconosciuta. se dici che tu parti con programmi bootabili oppure con disco di installazione buntu vuol dire che tu il secureboot non lo hai attivo. a questo punto se riesci ad installare alla schermata di selezione del loder scegliendo dev/sda1 dovresti risolvere.
quello che mi preoccupa è che bootrepair non abbia risolto, non vorrei che tu abbia complicato il tutto.
http://wiki.ubuntu-it.org/Installazione/UEFI
Possibilissimo.
Dopo aver installato/riformattato/reinstallato senza esito fausto, è comprensibile che il pc stia soffrendo. Prima di effettuare l'ennesima eliminazione di ubuntu se possibile vorrei sapere di preciso cosa inserire nel campo di installazione del boot loader.
/dev/sda1
capisco che può sembrare banalissimo ma se ubuntu mi imposta come default /dev/sda, nella mia poca chiarezza di idee tendo a lasciare la cosa lì. Mi confermi che devo inserire /dev/sda1?
Ora chiaro, non amo fare domande schematiche. Se posso fornire dei test oltre a quelli inviati, ditemi quali. Comunque assicuro che secure boot è abilitato.
Intanto provo con una vecchia conoscenza: fdisk.
-----------------------------------------------------------------------------------------------
enrico@WOPR-2013:~$ sudo fdisk -l
[sudo] password for enrico:

WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted.


Disk /dev/sda: 2000.4 GB, 2000398934016 bytes
255 testine, 63 settori/tracce, 243201 cilindri, totale 3907029168 settori
Unità = settori di 1 * 512 = 512 byte
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Identificativo disco: 0x6dd7d934

Dispositivo Boot Start End Blocks Id System
/dev/sda1 1 3907029167 1953514583+ ee GPT
Partition 1 does not start on physical sector boundary.

Disk /dev/sdb: 32.0 GB, 32017047552 bytes
255 testine, 63 settori/tracce, 3892 cilindri, totale 62533296 settori
Unità = settori di 1 * 512 = 512 byte
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Identificativo disco: 0xba000000

Il disco /dev/sdb non contiene una tabella delle partizioni valida
Nota: la dimensione del settore è 4096 (non 512)

Disk /dev/sdc: 3000.6 GB, 3000590401536 bytes
255 testine, 63 settori/tracce, 45600 cilindri, totale 732566016 settori
Unità = settori di 1 * 4096 = 4096 byte
Sector size (logical/physical): 4096 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Identificativo disco: 0x000346cb

Dispositivo Boot Start End Blocks Id System
/dev/sdc1 256 732566015 2930263040 7 HPFS/NTFS/exFAT

Disk /dev/sdd: 1000.2 GB, 1000204886016 bytes
255 testine, 63 settori/tracce, 121601 cilindri, totale 1953525168 settori
Unità = settori di 1 * 512 = 512 byte
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Identificativo disco: 0x538dca80

Dispositivo Boot Start End Blocks Id System
/dev/sdd1 63 1953520064 976760001 c W95 FAT32 (LBA)
Grazie.
Cita messaggio
#7
si se guardo il tuo postato la partizione che "parla" con uefi è dev/sda1 quindi il grub su dev/sda1
Cita messaggio
#8
Comunque assicuro che secure boot è abilitato

se è vero quanto affermi è impossibile installare ubu e usare programmi bootabili, qualche cosa non torna.....
Cita messaggio
#9
(12-02-2013, 23:43 )dxgiusti Ha scritto: se è vero quanto affermi è impossibile installare ubu e usare programmi bootabili, qualche cosa non torna.....
Non ho seguito tutto ma magari sta cercando di installare una distro che è stata certificata??? At
Cita messaggio
#10
possibile qualsiasi cosa visto che sembra abbia installato grub su mbr. esistono già ubu certificate?
io se fosse mio usando il ripristino riporteerei tutto allo stato di fabbrica e poi dopo inizierei ex novo con l'installazione di ubu con uefi.
Cita messaggio


Vai al forum: