Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Errore aggiornamento procps
#1
Dopo gli ultimi aggiornamenti, da terminale apt-get update e poi apt-get upgrade,
ho il seguente errore
Codice:
Configurazione di procps (1:3.2.8-11ubuntu6.1)...
start: Job failed to start
invoke-rc.d: initscript procps, action "start" failed.
dpkg: errore nell'elaborare procps (--configure):
il sottoprocesso vecchio script di post-installation ha restituito lo stato di errore 1
Si sono verificati degli errori nell'elaborazione:
procps
E: Sub-process /usr/bin/dpkg returned an error code (1)
Qualche idea su come risolvere ?
Grazie
Cita messaggio
#2
specifica anche la versione che usi. hai aggiornato, dai anche:
sudo apt-get dist-upgrade
se non si risolve prova a reinstallare:
https://launchpad.net/ubuntu/+source/procps
Cita messaggio
#3
(18-10-2013, 20:32 )dxgiusti Ha scritto: specifica anche la versione che usi. hai aggiornato, dai anche:
sudo apt-get dist-upgrade
se non si risolve prova a reinstallare:
https://launchpad.net/ubuntu/+source/procps
Ciao,
uso la 12.04 purtroppo anche con sudo apt-get dist-upgrade l'errore è identico.
Purtroppo non so come reinstallare:
https://launchpad.net/ubuntu/+source/procps
quando sono in https://launchpad.net/ubuntu/+source/procps non so come andare avanti
Grazie
Cita messaggio
#4
ho provato a controllare dal gestore pacchetti:
   
l'ho trovato con un punto esclamativo, click su quello e scelto aggiorna si è sistemato. prova
   
Cita messaggio
#5
(18-10-2013, 21:58 )dxgiusti Ha scritto: ho provato a controllare dal gestore pacchetti:

l'ho trovato con un punto esclamativo, click su quello e scelto aggiorna si è sistemato. prova
Provato, ma non va nei diversi tentativi mi dice pacchetto scaricato ma non installato.
Ma questo pacchetto è necessario o almeno importante ?
Chiedo perchè non l'ho capito, anche se ho cercato.
Se l'elimino ? da synaptic con rimuovi ?
Che problemi può creare ?
Grazie
Cita messaggio
#6
Ciao il problema rimane ed è di difficile soluzione.
Dovrebbe essere un problema del "processo ptrace"
Se modifico i files della cartella /etc/sysctl.d come 10-kernel-hardening.conf a quale vulnerabilità espongo il mio pc ?
Grazie
Cita messaggio
#7
Vedi se riesci a modificare il file come indicato nella discussione bug
https://bugs.launchpad.net/ubuntu/+sourc...ug/1241562
oppure commentare solo la riga # kernel.yama.ptrace_scope = 1

Cita messaggio
#8
(24-10-2013, 23:02 )brunik Ha scritto: Vedi se riesci a modificare il file come indicato nella discussione bug
https://bugs.launchpad.net/ubuntu/+sourc...ug/1241562
Quale file e come sia modificato nella suddetta discussione non lo vedoScusarsi
(24-10-2013, 23:02 )brunik Ha scritto: oppure commentare solo la riga # kernel.yama.ptrace_scope = 1
Questo invece l'ho commentato esattamente come da te indicato # kernel.yama.ptrace_scope = 1
L'ho anche cambiato così kernel.yama.ptrace_scope = 0
Ma il risultato non cambia.
Posto questo output qualcuno vede qualcosa di utile ?
Codice:
lucio@lucio-N61PA-M2S:~$ cat /etc/sysctl.d/*.conf /etc/sysctl.conf | sudo sysctl -p -
kernel.printk = 4 4 1 7
net.ipv6.conf.all.use_tempaddr = 2
net.ipv6.conf.default.use_tempaddr = 2
kernel.kptr_restrict = 1
net.ipv4.conf.default.rp_filter = 1
net.ipv4.conf.all.rp_filter = 1
net.ipv4.tcp_syncookies = 1
vm.mmap_min_addr = 65536
fs.inotify.max_user_watches = 524288
error: "Invalid argument" setting key "fs.inotify.max_user_watches"
lucio@lucio-N61PA-M2S:~$
Grazie
Cita messaggio
#9
Il file da controllare mi pare siano

/etc/sysctl.d/10-ptrace.conf

/etc/sysctl.d/*.conf /etc/sysctl.conf

/etc/sysctl.conf

Quindi poi devi provare a commentare la riga

# fs.inotify.max_user_watches = 524288

Cita messaggio
#10
(25-10-2013, 10:43 )brunik Ha scritto: Il file da controllare mi pare siano

/etc/sysctl.d/10-ptrace.conf

/etc/sysctl.d/*.conf /etc/sysctl.conf

/etc/sysctl.conf

Quindi poi devi provare a commentare la riga

# fs.inotify.max_user_watches = 524288
Grazie ma non va l'errore è sempre lo stesso

Sono tentato di rimuovere e reinstallare procps ma sembra impegnativo
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)