Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Gnome Sparito
#1
Ciao a tutti, sono un niubbo del mondo di linux.
Dopo molti tentativi andati a male ho installato ubuntu 12.04 e gnome shell. Tutto andava bene (personalizzazioni & caXXeggi vari, driver, ecc.) fino a ieri quando ho aperto il gestore aggiornamenti che mi segnalava da un pò di tempo l'esistenza di nuovi aggiornamenti e che io ero restio a fare visto le brutte esperienze passate (non so quante volte ho reinstallato l'11.10).
Vengo al dunque, scaricati e installati questi aggiornamenti (fra cui mi ha chiesto anche un'avanzamento di non so cosa) riavvio normalmente per completare l'installazione. Al chè mi si apre con Gnome-classic e non con Gnome-shell.
Vado a verificare la presenza di gnome-shell con il comando

nome-shell --version



ed il risultato è


boh@boh:~$ gnome-shell --version
Il programma "gnome-shell" non è attualmente installato. È possibile installarlo digitando:
sudo apt-get install gnome-shell




Allora provo a reinstallare gnome-shell ma il risultato è questo:


sudo apt-get install gnome-shell
[sudo] password for boh:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
Alcuni pacchetti non possono essere installati. Questo può voler dire
che è stata richiesta una situazione impossibile oppure, se si sta
usando una distribuzione in sviluppo, che alcuni pacchetti richiesti
non sono ancora stati creati o sono stati rimossi da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:

I seguenti pacchetti hanno dipendenze non soddisfatte:
gnome-shell : Dipende: libgcr-3-1 (>= 3.4.0) ma la versione 3.2.2-2ubuntu4 sta per essere installata
Dipende: gir1.2-gcr-3 ma non è installabile
Raccomanda: gnome-contacts ma non sta per essere installato
E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.




Che fare? come posso risolvere questi problemi? Come elimino i pacchetti danneggiati bloccati? Come ripristino tutto a prima degli aggiornamenti? Un grazie in anticipo a tutti! Smile
Cita messaggio
#2
prova    
Cita messaggio
#3
Un'altra alternativa sarebbe riparare i pacchetti selezionando all'avvio la modalità recovery.
Cita messaggio
#4
(01-06-2012, 20:12 )Bamboccino Ha scritto: Ciao a tutti, sono un niubbo del mondo di linux.
Dopo molti tentativi andati a male ho installato ubuntu 12.04 e gnome shell. Tutto andava bene (personalizzazioni & caXXeggi vari, driver, ecc.) fino a ieri quando ho aperto il gestore aggiornamenti che mi segnalava da un pò di tempo l'esistenza di nuovi aggiornamenti e che io ero restio a fare visto le brutte esperienze passate (non so quante volte ho reinstallato l'11.10).
Vengo al dunque, scaricati e installati questi aggiornamenti (fra cui mi ha chiesto anche un'avanzamento di non so cosa) riavvio normalmente per completare l'installazione. Al chè mi si apre con Gnome-classic e non con Gnome-shell.
Vado a verificare la presenza di gnome-shell con il comando

nome-shell --version



ed il risultato è


boh@boh:~$ gnome-shell --version
Il programma "gnome-shell" non è attualmente installato. È possibile installarlo digitando:
sudo apt-get install gnome-shell




Allora provo a reinstallare gnome-shell ma il risultato è questo:


sudo apt-get install gnome-shell
[sudo] password for boh:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
Alcuni pacchetti non possono essere installati. Questo può voler dire
che è stata richiesta una situazione impossibile oppure, se si sta
usando una distribuzione in sviluppo, che alcuni pacchetti richiesti
non sono ancora stati creati o sono stati rimossi da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:

I seguenti pacchetti hanno dipendenze non soddisfatte:
gnome-shell : Dipende: libgcr-3-1 (>= 3.4.0) ma la versione 3.2.2-2ubuntu4 sta per essere installata
Dipende: gir1.2-gcr-3 ma non è installabile
Raccomanda: gnome-contacts ma non sta per essere installato
E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.




Che fare? come posso risolvere questi problemi? Come elimino i pacchetti danneggiati bloccati? Come ripristino tutto a prima degli aggiornamenti? Un grazie in anticipo a tutti! Smile

Guarda in questo post se uno dei problemi rilevati può essere anche il Tuo caso (ovverop qualche driver proprietario)
Cita messaggio
#5
fatto ma non succede nulla!
Cita messaggio
#6
(01-06-2012, 21:35 )maverick2011 Ha scritto:
(01-06-2012, 20:12 )Bamboccino Ha scritto: Ciao a tutti, sono un niubbo del mondo di linux.
Dopo molti tentativi andati a male ho installato ubuntu 12.04 e gnome shell. Tutto andava bene (personalizzazioni & caXXeggi vari, driver, ecc.) fino a ieri quando ho aperto il gestore aggiornamenti che mi segnalava da un pò di tempo l'esistenza di nuovi aggiornamenti e che io ero restio a fare visto le brutte esperienze passate (non so quante volte ho reinstallato l'11.10).
Vengo al dunque, scaricati e installati questi aggiornamenti (fra cui mi ha chiesto anche un'avanzamento di non so cosa) riavvio normalmente per completare l'installazione. Al chè mi si apre con Gnome-classic e non con Gnome-shell.
Vado a verificare la presenza di gnome-shell con il comando

nome-shell --version



ed il risultato è


boh@boh:~$ gnome-shell --version
Il programma "gnome-shell" non è attualmente installato. È possibile installarlo digitando:
sudo apt-get install gnome-shell




Allora provo a reinstallare gnome-shell ma il risultato è questo:


sudo apt-get install gnome-shell
[sudo] password for boh:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
Alcuni pacchetti non possono essere installati. Questo può voler dire
che è stata richiesta una situazione impossibile oppure, se si sta
usando una distribuzione in sviluppo, che alcuni pacchetti richiesti
non sono ancora stati creati o sono stati rimossi da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:

I seguenti pacchetti hanno dipendenze non soddisfatte:
gnome-shell : Dipende: libgcr-3-1 (>= 3.4.0) ma la versione 3.2.2-2ubuntu4 sta per essere installata
Dipende: gir1.2-gcr-3 ma non è installabile
Raccomanda: gnome-contacts ma non sta per essere installato
E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.




Che fare? come posso risolvere questi problemi? Come elimino i pacchetti danneggiati bloccati? Come ripristino tutto a prima degli aggiornamenti? Un grazie in anticipo a tutti! Smile

Guarda in questo post se uno dei problemi rilevati può essere anche il Tuo caso (ovverop qualche driver proprietario)

si l'avevo visto, anche se non proprio lo stesso problema ho seguito le indicazioni indicate reinstallando ndivia current, ma non va, il problema resta!Sad
Cita messaggio
#7
aggiornamento:

ho provato con aptitude a lanciare l'installazione di gnome-shell


sudo apt-get install aptitude




sudo aptitude install gnome-shell


con quest'ultimo comando sono risuscito a reinstallare gnome-shell. Mi ha disinstallato i pacchetti danneggiati (ma anche altri secondo me, sono passati molti secondi) e poi ha installato gnome-shell.
Felice di esserci riuscito riavvio il pc (magari per completare l'installazione) ed al primo avvio mi ritrovo in ubuntu unity (era quello che stavo utilizzando al momento). Sembra tutto perfetto, così riavvio la sessione per passare a Gnome-shell, che compare finalemente nel menu a tendina.
Purtroppo dopo avermi loggato l'ambiente gnome parte ma è tutto vuoto, tranne l'immagine dello sfondo;
riavvio di nuovo sistema e provo tutti gli altri ambienti grafici (ubuntu, ubuntu 2D, gnome classic, gnome classic (no effect)): il desktop è sempre vuoto.

Mi sa che ho peggiorato la situazione!

Help!!!! Sad
Cita messaggio
#8
(02-06-2012, 09:01 )Bamboccino Ha scritto: aggiornamento:

ho provato con aptitude a lanciare l'installazione di gnome-shell


sudo apt-get install aptitude




sudo aptitude install gnome-shell


con quest'ultimo comando sono risuscito a reinstallare gnome-shell. Mi ha disinstallato i pacchetti danneggiati (ma anche altri secondo me, sono passati molti secondi) e poi ha installato gnome-shell.
Felice di esserci riuscito riavvio il pc (magari per completare l'installazione) ed al primo avvio mi ritrovo in ubuntu unity (era quello che stavo utilizzando al momento). Sembra tutto perfetto, così riavvio la sessione per passare a Gnome-shell, che compare finalemente nel menu a tendina.
Purtroppo dopo avermi loggato l'ambiente gnome parte ma è tutto vuoto, tranne l'immagine dello sfondo;
riavvio di nuovo sistema e provo tutti gli altri ambienti grafici (ubuntu, ubuntu 2D, gnome classic, gnome classic (no effect)): il desktop è sempre vuoto.

Mi sa che ho peggiorato la situazione!

Help!!!! Sad

Hai salvato i dati? (In caso prima di qualsiasi altra manovra provvedi: puoi utilizzare la live di ubuntu)

Poi vedi le soluzioni di questo forum
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)