Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Icona connessione Sakis nel pannello
#1
...ma ciao!
   sto usando sakis3g per far funzionare una chiavetta internet (non so perchè Network manager sembra vederla ma nn riesce a farla connettere)
Morale della favola, per evitare mille selezioni e l'inserimento della password di amministratore ogni volta ho creato uno script per la connessione e uno per la disconnessione.
Il problema è che una volta connesso non c'e' niente che mi indichi che sono connesso...NM non rileva che sono connesso e non c'e' nessuna icona,.
C'e' un modo per avere un icona nel pannello o qualcosa che mi indichi che sono connesso?
Ecco lo script di connessione che utilizzo:


Codice:
#!/bin/bash
#
# Avvia la connessione ad Internet
TERM=x-terminal-emulator

function run_like_a_root() {
sudo -S $@ << EOF
PASSWORD DI AMMINISTRATORE
EOF
}

run_like_a_root /home/UTENTE/Documenti/sakis3g connect OTHER="USBMODEM" USBMODEM="2020:1005" USBINTERFACE="6" APN="web.omnitel.it"
E qui lo script di disconnessione:


Codice:
#!/bin/bash
#
# Chiude la connessione ad Internet
TERM=x-terminal-emulator

function run_like_a_root() {
sudo -S $@ << EOF
sc14m4n0
EOF
}

run_like_a_root /home/geppo/Documenti/sakis3g disconnect

L'ideale sarebbe avere un applet che mi permetta di connettermi e disconnettermi..mi piacerebbe realizzarla con livecode ma non saprei da dove partire.

grazie per l'aiuto.

P.S.  credo ci sia un problema nell'editor dei post. Andando sul pulsante "code" o "php" mi compaiono i tooltip e il popup tutto in arabo inteso proprio come caratteri arabi o qualcosa del genere.
Cita messaggio
#2
Salve a tutti,
io uso lo script sakis3g per connettermi a internet. La mia distribuzione è xubuntu e oggi volevo dopo tanto tempo modificare l'avviatore dello script sakis3g creandomi uno script per automatizzare l'inserimento della password e del pin. Ho seguito le istruzioni che si trovano sul forum di ubuntu. Il risultato è che se lancio lo script da terminale con ./connessione tutto funziona. Se provo a lanciare l'icona non ottengo alcun risultato.
Grazie,
Davide
Cita messaggio
#3
Salve a tutti,
ho inserito questo messaggio in un altro thread e mi dispiace, perchè è un errore dovuto alla inesperienza.
Ora vorrei chiedere aiuto per questo problema.
Ho utilizzato anch'io lo stesso script. La mia distribuzione è xubuntu 14.04 e oggi volevo dopo tanto tempo modificare l'avviatore dello script sakis3g creandomi uno script per automatizzare l'inserimento della password e del pin. Ho seguito le istruzioni che si trovano sul forum di ubuntu ( lo script che tu hai riportato sopra). Il risultato è che se lancio lo script da terminale con ./connessione tutto funziona. Se provo a lanciare dall'icona non ottengo alcun risultato.
Grazie,
Davide
Cita messaggio
#4
ciao. questo forum diventerà a breve un'archivio.
da alcuni giorni è funzionante FORUM2
se posterete la le vostre richieste, avrete sicuramente meggiore visibilità.
dovrete registrarvi di nuovo. cordialità
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)