Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Impossibilità aggiornamento
#1
Salve, probabilmente commetterò degli errori, ma è la prima volta che scrivo un messaggio.
Ho un problema nell'aggiornamento. Ho la versione 12.04 e scarico dal server principale.
Nella schermata dettagli compare questo elenco:
W:Failed to fetch http://ppa.launchpad.net/c-korn/vlc/ubun...ce/Sources 404 Not Found
, W:Failed to fetch http://ppa.launchpad.net/c-korn/vlc/ubun...6/Packages 404 Not Found
, W:Failed to fetch http://ppa.launchpad.net/michael-gruz/ca...ce/Sources 404 Not Found
, W:Failed to fetch http://ppa.launchpad.net/michael-gruz/ca...6/Packages 404 Not Found
, W:Failed to fetch http://archive.ubuntu.com/ubuntu/dists/m...ce/Sources 404 Not Found [IP: 91.189.88.153 80]
, W:Failed to fetch http://archive.ubuntu.com/ubuntu/dists/m...ce/Sources 404 Not Found [IP: 91.189.88.153 80]
, W:Failed to fetch http://archive.ubuntu.com/ubuntu/dists/m...ce/Sources 404 Not Found [IP: 91.189.88.153 80]
, W:Failed to fetch http://archive.ubuntu.com/ubuntu/dists/m...ce/Sources 404 Not Found [IP: 91.189.88.153 80]
, W:Failed to fetch http://archive.ubuntu.com/ubuntu/dists/m...6/Packages 404 Not Found [IP: 91.189.88.153 80]
, W:Failed to fetch http://archive.ubuntu.com/ubuntu/dists/m...6/Packages 404 Not Found [IP: 91.189.88.153 80]
, W:Failed to fetch http://archive.ubuntu.com/ubuntu/dists/m...6/Packages 404 Not Found [IP: 91.189.88.153 80]
, W:Failed to fetch http://archive.ubuntu.com/ubuntu/dists/m...6/Packages 404 Not Found [IP: 91.189.88.153 80]
, E:Some index files failed to download. They have been ignored, or old ones used instead.

Potreste aiutarmi? Grazie
Cita messaggio
#2
ciao, posta per cortesia il risultato dal terminale di:
ls -1 /etc/apt/sources.list.d/
selezionalo e fai un copia/incolla. posta anche il contenuto di:
sudo gedit /etc/apt/sources.list
e per ultimo il risultato di:
lsb_release -a
Cita messaggio
#3
Prova a cambiare server. Se ti da ancora errore riporta il risultato allegandolo in un file di testo, così come l'hai postato ora non si capisce molto.
mandi...Eugenio
Ubuntu 12.04 Unity, Ubuntu 14.04 Unity, Pclinuxos Mate, Mint17 Cinnamon, PcLinuxOS KDE
Cita messaggio
#4
Ciao,
Innanzitutto grazie per la pronta risposta !
Risposta del 1° comando:
[EDIT esabatad]: ho aggiunto il file di testo allegato

Risposta del 2° comando:
[EDIT esabatad]: ho aggiunto il file di testo allegato

Risposta del 3° comando:
[EDIT esabatad]: ho aggiunto il file di testo allegato


Allegati
.txt   risultato ls -1 etcaptsources.list.d.txt (Dimensione: 1,26 KB / Download: 14)
.txt   risultato sudo gedit etcaptsources.list.txt (Dimensione: 2,76 KB / Download: 10)
.txt   risultato lsb_release -a.txt (Dimensione: 254 byte / Download: 5)
Cita messaggio
#5
ad un primo esame sembrerebbe che ci sono alcuni repo.. morti
in particolare
medibuntu.list
michael-gruz-canon-precise.list
e il repo di vlc
per quanto riguarda medibuntu è un problema conosciuto e di cui si è parlato già nel forum... la soluzione la trovi cliccando su
http://www.istitutomajorana.it/index.php...&Itemid=33

mentre per quanto riguarda michael-gruz
QUI
per quanto riguarda vlc... non ho trovato traccia negli allegati (forse ho guardato male...)
in alternativa puoi andare su synaptic e togliere la spunta nelle righe relative ai repo in questione, quindi aggiorni.
Cita messaggio
#6
direi di procedere per gradi. vedo che hai una 12.04 frutto di un avanzamento di versione. hai dei collegamenti non più attivi. apri il terminale e digita:
sudo gedit /etc/apt/sources.list
si aprirà la tua lista ( ossia gli indirizzi dove il sistema si collega per aggiornare ). cancella completamente il contenuto ed al suo posto incolla:
[spoiler=sources.list12.04]
deb http://it.archive.ubuntu.com/ubuntu/ precise main universe restricted multiverse
deb-src http://it.archive.ubuntu.com/ubuntu/ precise main universe restricted multiverse

deb http://security.ubuntu.com/ubuntu precise-security main universe restricted multiverse
deb-src http://security.ubuntu.com/ubuntu precise-security main universe restricted multiverse

deb http://it.archive.ubuntu.com/ubuntu/ precise-updates main universe restricted multiverse
deb-src http://it.archive.ubuntu.com/ubuntu/ precise-updates main universe restricted multiverse

deb http://it.archive.ubuntu.com/ubuntu precise-backports main restricted universe multiverse
deb-src http://it.archive.ubuntu.com/ubuntu precise-backports main restricted universe multiverse

deb http://archive.canonical.com/ubuntu precise partner
deb-src http://archive.canonical.com/ubuntu precise partner
[/spoiler]
fonte:  
http://wiki.ubuntu-it.org/Repository/SourcesList
salva prima di uscire.
ora dovremmo controllare in sorgenti software come sei impostato per ricevere gli aggiornamenti. va bene server principale, metti mai su avvisa per nuove versioni. controlla di non avere il flag su:
   
ed un passaggio è fatto. ora bisogna sistemare i ppa esterni, i famosi collegamenti. io non li conosco tutti comunque ve ne sono diversi da eliminare. dammi qualche minuto che provo a fare una lista.

eccomi qui. anche nei ppa c'è qualche problema. qualcuno doppio, qualcuno non più attivo ed un paio quelli relativi a cinnamon che in passato hanno creato qualche problema. io eliminerei questi:
[spoiler=ppa da eliminare][table][tr][td]google.list[/td][/tr][tr][td]google.list.save[/td][/tr][tr][td]gwendal-lebihan-dev-cinnamon-stable-precise.list[/td][/tr][tr][td]gwendal-lebihan-dev-cinnamon-stable-precise.list.save[/td][/tr][tr][td]medibuntu.list[/td][/tr][tr][td]ubuntu-extras.list[/td][/tr][tr][td]ubuntu-extras.list.save[/td][/tr][tr][td]virtualbox.list[/td][/tr][tr][td]virtualbox.list.save[/td][/tr][tr][td]michael-gruz-canon-precise.list[/td][/tr][tr][td]michael-gruz-canon-precise.list.save[/td][/tr][/table] [/spoiler]
per eliminarli, apri sorgenti software/altro software, evidenzia la riga interessata ed eliminala. verifica bene il nome specialmente per quelli che possono sembrare doppi ( esempio chrome da eliminare, chrome-stable da tenere ). una volta terminato questo, chiudi tutto e dal terminale:
sudo apt-get update
se tutto si conclude senza errori / segnalazioni, continua con:
sudo apt-get dist-upgrade
in caso di errori o segnalazioni, fermati e posta.
Cita messaggio
#7
Ciao DXGiusti,
ho seguito il tuo consiglio: " digita:
sudo gedit /etc/apt/sources.list
si aprirà la tua lista ( ossia gli indirizzi dove il sistema si collega per aggiornare ). cancella completamente il contenuto ed al suo posto incolla:
Spoiler: sources.list12.04 "
Ho cancellato tutto, ma ho incollato solo: "sources.list12.04 ", omettendo:
"Spoiler: ".
Quando sono andato al passaggio successivo, e cioè Gestione aggiornamenti, x vedere che non ci fossero i flag di cui parlavi, mi è comparso questo messaggio:
" Impossibile inizializzare le informazioni del pacchetto
Si è verificato un problema irrisolvibile durante l'inizializzazione delle informazioni del pacchetto.

Segnalare questo bug per il pacchetto «update-manager» e includere il seguente messaggio d'errore:

'E:Tipo "sources.list12.04" non riconosciuto alla riga 1 nel file /etc/apt/sources.list' "
e adesso non posso più andare su Gestore aggiornamenti perchè compare sempre questo messaggio. Quando lo chiudo si chiude anche Gestore aggiornamenti, e amen.
Ho combinato un casino? o si può in qualche modo risolvere.
In ogni caso, grazie x le tue risposte fino ad ora.
Ciao
Cita messaggio
#8
scusa una domanda, ma cosa hai incollato dentro la sources.list ? immagino il contenuto di spoiler che si visualizza con il tasto mostra.
Cita messaggio
#9
No nella sourcer list, dopo aver cancellato tutto ho incollato: "Spoiler: sources.list12.04", perchè ho capito che era questo che avrei dovuto incollare. Ora però, come ti ho scritto, non riesco più ad accedere a Getore aggiornamenti perchè mi compare quel messaggio di errore. Ho anche sperato che riavviando il pc sarebbe cambiato qualcosa, ma niente. Ora nella barra in alto mi è anche comparso un simbolo tipo divieto di accesso che mi indica : " Si è verificato un problema durante la verifica degli aggiornamenti". Insomma non posso più accedere agli aggiornamenti
Ho fatto un vero casino!
Cita messaggio
#10
Ecco il messaggio che mi compare quando tento di verificare gli aggiornamenti:
Caricamento dell'elenco di pacchetti non riuscito
Questo è un problema grave. Provare di nuovo in un secondo momento. Se il problema compare ancora, segnalare l'errore agli sviluppatori.
Dettagli:
E:Type 'SpoilerConfusedources.list12.04' is not known on line 1 in source list /etc/apt/sources.list.
Scusa, ma da solo non riesco ad andare avanti!
Grazie
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)