Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 1 voto(i) - 5 media
  • 1
  • 2
  • 3
  • 4
  • 5
[Kali Linux] Doppio Kernel
#1
Ciao a tutti ragazzi !
Smile

Mi è successa una cosa molto strana.
Vi spiego.

Uso Kali Linux (distro Debian per pentesting) in dualboot con Windows 7.
E fino a qui ci siamo, windows nell hhd interno e Kali Linux in hhd esterno.
(File del grub in hhd esterno)


All avvio, nel grub mi è sempre uscito, quanto segue:



Codice:
Debian GNU/Linux, whit Linux 3.7-trunk-686 pae
Debian GNU/Linux, whit Linux 3.7-trunk-686 pae (recovery mode)
Windows Vista (loader)
Windows Vista (loader)


Ieri, ho dato il comdando:
(Comando mai usato fino a ieri. Ho sempre dato apt-get update/upgrade)



Codice:
apt-get dist-upgrade


E ora all avvio, mi esce un altro Kernel di Kali con cui avviare!
Nome del kernel:



Codice:
Debian GNU/Linux, whit Linux 3.12-kali1-686 pae
Debian GNU/Linux, whit Linux 3.12-kali1-686 pae (recovery mode)



Screen: http://i.hizliresim.com/zRazZO.jpg

(Il kernel evidenziato, è quello che ho sempre usato e funziona bene, le altre due voci di sopra, sono quelle apparse ora)




Il problema è , che se avvio con quest ultimo kernel, l OS non funziona bene!!!

La scheda di rete, mi segna la percentuale di ricezione del wifi a 60% , mentre con l altro kernel (quello che ho sempre usato) mi segna 100% , i programmi ci mettono una vita ad avviarsi, ecc...
Insomma, se avvio con quello che ho sempre usato invece, và tutto normale. Però allo stesso tempo, sembra sia aggiornato, perchè è leggermente diverso.

Dopo aver usato quel comando, ho anche usato il tool "Bleachbit" per fare pulizia e mi ha fatto un "wipe ecc.." di 2 ore al termine...quindi non so se possa essere dipeso da quello ma non credo.
Perchè solo dopo che l ho riavviato mi sono reso conto di quello che era successo.


Ragà mi potete aiurtare?
Non voglio fare pasticci.

Grazie

 

 
Cita messaggio
#2
Non è un problema ... semplicemente hai installato un nuovo kernel e devi rimuoverne uno per avere un Grub piu pulito.

P.S. il codice etico dei linuxiani prevede che ci sia installato almeno un kernel di scorta nel malaugurato caso il più recente si imballasse.

Nel tuo caso ... prova ad avviare il kernel che ti funziona bene ed eliminare l'altro seguende questa guida http://www.istitutomajorana.it/forum/Thr...-da-Ubuntu

Alla fine della fiera aggiorna grub


Codice:
sudo update-grub

 
Cita messaggio
#3
(08-05-2014, 13:18 )'tumbler' Ha scritto: Non è un problema ... semplicemente hai installato un nuovo kernel e devi rimuoverne uno per avere un Grub piu pulito.

P.S. il codice etico dei linuxiani prevede che ci sia installato almeno un kernel di scorta nel malaugurato caso il più recente si imballasse.

Nel tuo caso ... prova ad avviare il kernel che ti funziona bene ed eliminare l'altro seguende questa guida http://www.istitutomajorana.it/forum/Thr...-da-Ubuntu

Alla fine della fiera aggiorna grub



Codice:
sudo update-grub

 

 

Ohh grazie amico!
Mi hai chiarito molte cose [img]images/smilies/lightbulb.gif[/img]


Ma non capisco una cosa...sulla guida dice che l ultimo kernel è quello più recente...
Guarda il mio screen:

[Immagine: http://i.hizliresim.com/59grOz.png]

Nel mio caso l ultimo è il 3.7 , e in effetti è quello che funziona meglio e che runna bene.
Ma il più recente non dovrebbe essere il 3.12 ? Strano....

Sai delucidarmi ?
Cita messaggio
#4
Ciao, elimineari infatti il 3.12, dato che non và d'accordo con il tuo hardwareSmile
I Heart GNU\Linux and PC-BSD too !!!
Il fine NON giustifica i mezzi !!
Cita messaggio
#5
Ottimo grazie 1000 problema risolto.

Un ultima cosa.
Quindi il comando : apt-get dist-upgrade , non lo devo piu dare?
Perchè mi aggiorna anche cose utili.....
Cita messaggio
#6
Io non conosco bene la tua distro ma faccio due riflessioni generali ... se il kernel rimane lo stesso ma viene patchato devi aggiornare ... se cambia completamente release (come nel tuo caso) allora credo proprio che stai utilizzando un rolling-release (oppure hai abilitato qualche repo strano).
Resto dell'idea che lasciare indietro un kernel (in una rolling) alla lunga combina guai.
Se stabilisci che l'ultimo kernel adatto al tuo hardware è il 3.7 devi scaricarti un stable che utilizza (ed aggiorna con le patch di sicurezza) solo ed esclusivamente quel kernel.
Più probabile che su quel kernel (3.12) tu abbia caricato qualche modulo di troppo o lo abbia modificato (anche inconsapevolmente) ... non ho sottocchio il changelog ma non credo si sia potuto stravolgere l'hardware supportato in così poco tempo.
Cita messaggio
#7
(08-05-2014, 17:05 )'tumbler' Ha scritto: Io non conosco bene la tua distro ma faccio due riflessioni generali ... se il kernel rimane lo stesso ma viene patchato devi aggiornare ... se cambia completamente release (come nel tuo caso) allora credo proprio che stai utilizzando un rolling-release (oppure hai abilitato qualche repo strano).
Resto dell'idea che lasciare indietro un kernel (in una rolling) alla lunga combina guai.
Se stabilisci che l'ultimo kernel adatto al tuo hardware è il 3.7 devi scaricarti un stable che utilizza (ed aggiorna con le patch di sicurezza) solo ed esclusivamente quel kernel.
Più probabile che su quel kernel (3.12) tu abbia caricato qualche modulo di troppo o lo abbia modificato (anche inconsapevolmente) ... non ho sottocchio il changelog ma non credo si sia potuto stravolgere l'hardware supportato in così poco tempo.

 



Potresti dirmi in modo "pratico" cosa fare?
Vorrei risolvere questa situazione.

Perchè a sto punto, ogni volta che darò il comando "apt-get dist-upgrade" mi installerà sempre quel kernel.

Grazie
Cita messaggio
#8
Ciao, non devi dare " dist-upgrade " ma semplicemente :

sudo apt-get update

sudo apt-get upgrade

Dando il comando " dist-upgrade " dici al terminale ti aggiornare la tua distro portandola in modo " indolore " ad un passo dall' ultima versione rilasciata. Se dai per es. " dist-upgrade " su Ubuntu 12.04.4 LTS non rimarrà più Ubuntu 12.04.4 ma si aggiornerà avvicinandosi quanto più alla versione successiva, è per questo motivo vhe il tuo kernel è balzato di colpo dal 3.7 al 3.12 creandoti dei problemi. Evidentemente il 3.12 non va bene x il tuo hardware. Così come io, il 3.13 di Ubuntu 14.04 lo posso utilizzare su un solo PC e non sull' altro E' più chiaro ?

upgrade = Ti aggiorna il sistema

dist-upgrade = E' il primo passo per cambiare la versione della distro
I Heart GNU\Linux and PC-BSD too !!!
Il fine NON giustifica i mezzi !!
Cita messaggio
#9
Ummm teo non è proprio cosi ... Upgrade aggiorna i pacchetti semplici e ritenuti sicuri ... Dist-upgrade anche quelli di sistema tipo kernel xorg driver video etc ... Che sono ritenuti sensibili.che io sappia il kernel non aumenta ma di verisone (solo nella 12.04 l ho visto) ma riceve solo le patch.se il kernel è 3.2.0-16 al massimo diventa 3.2.0-17 ... Ovvero installa la patch 17 del kernel 3.2.0. L avanzamento costante del kernel è solo sulle rolling o half rolling.sul da farsi ho gia risposto ... Se quel kernel t da fastidio devi scegliere una distro che lo supporta nativamente e non lo aggiorna ... Tipo una debian stable ... Oppure blocchi il pacchetto da apt ma non m pare una buona idea.
Cita messaggio
#10
(09-05-2014, 19:37 )tumbler Ha scritto: Ummm teo non è proprio cosi ... Upgrade aggiorna i pacchetti semplici e ritenuti sicuri ... Dist-upgrade anche quelli di sistema tipo kernel xorg driver video etc ... Che sono ritenuti sensibili.che io sappia il kernel non aumenta ma di verisone (solo nella 12.04 l ho visto) ma riceve solo le patch.se il kernel è 3.2.0-16 al massimo diventa 3.2.0-17 ... Ovvero installa la patch 17 del kernel 3.2.0. L avanzamento costante del kernel è solo sulle rolling o half rolling.sul da farsi ho gia risposto ... Se quel kernel t da fastidio devi scegliere una distro che lo supporta nativamente e non lo aggiorna ... Tipo una debian stable ... Oppure blocchi il pacchetto da apt ma non m pare una buona idea.

Per dist-upgrade: ( non ti cambia versione ma è il primo passo per un successivo passaggio " indolore " )
http://forum.ubuntu-it.org/viewtopic.php?t=503498
http://help.ubuntu-it.org/6.06/ubuntu/se...t-get.html

Per i kernel, ci sono kernel LTS mantenuti da Canonical...Tra l'altro Kali non è rolling e mi sembra sia basata su Debian, non Ubuntu.
I Heart GNU\Linux and PC-BSD too !!!
Il fine NON giustifica i mezzi !!
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)