Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
L'installazione di Ubuntu non trova Windows 8
#1
Salve a tutti,
spero possiate aiutarmi.... da poco ho tentato di installare ubuntu (sia 12.10 che 13.04, 64bit) in dual boot con windows 8 preinstallato su un pc con UEFI.
Dopo aver disattivato il secure boot ho fatto partire il livecd di ubuntu, e fin qui tutto a posto, infatti l'installazione parte correttamente dal grub, come specificato dalla guida per l'istallazione su UEFI sul sito di ubuntu. Quindi arrivo nella schermata dove mi chiede cosa voglio fare(se partizionare il disco o formattarlo, ecc.) ,la quale dovrebbe dirmi che è presente un altro SO. Purtroppo però mi dice che non è presente nessun altro SO. Il problema non credo che sia dovuto al tipo di formattazione dell'HD, ne da incompattibiltà hardware, infatti eseguendo il sistema da livecd fuziona tutto perfettamente e posso esplorare tranquillamente tutte le partizioni, compresa quella di Win. Ho provato anche a continuare l'installazione sulla partizione creata apposta per Ubuntu, sperando che grub trovasse Win, ma è successo che alla fine potevo solo avviare Ubuntu. Così ho formattato la partizone di Ubuntu e ripristinato l'MBR di win ma il problema persiste.
Non vorrei formattare e reinstallare Windows... non è che c'è qualche opzione che non conosco da modificare con programmi tipo easyBCD?
Grazie in anticipo per l'aiuto! Smile
Cita messaggio
#2
ciao, credo che dovresti leggere bene come installare su uefi, mbr lo devi dimenticare. dai uno sguardo con calma:
http://wiki.ubuntu-it.org/Installazione/UEFI
credo che con la 13.04 non ci sia nemmeno il bisogno di disinstallare il secureboot. magari posta una tua schermata da ubuntu in live del disco con gparted, individueremo la partizione dove installare il grub.
Cita messaggio
#3
(03-09-2013, 19:51 )dxgiusti Ha scritto: ciao, credo che dovresti leggere bene come installare su uefi, mbr lo devi dimenticare. dai uno sguardo con calma:
http://wiki.ubuntu-it.org/Installazione/UEFI
credo che con la 13.04 non ci sia nemmeno il bisogno di disinstallare il secureboot. magari posta una tua schermata da ubuntu in live del disco con gparted, individueremo la partizione dove installare il grub.

Grazie per la risposta. Smile
Quindi non c'è bisogno che l'installer veda Windows 8? Appena posso faccio uno screen e lo posto!
Cita messaggio
#4
Ecco gli screenshot.
   
La partizione non allocata da 25GB è quella che vorrei dedicare ad Ubuntu. Le restanti sono partizioni di Windows, che sono perfettamente visualizzate da Linux. Tuttavia (seconda immagine) non viene visto windows, nonostante funzioni perfettamente e sia riconosciuto dalla scheda madre.
   
Cita messaggio
#5
alla seconda immagine, scegli "altro" posizionati sulla partizione che vuoi, doppio click, formatta ext4, metti il mount " / " e tutto si installerà. il grub per l'avvio da quanto vedo dovrebbe andare in dev/sda2 ma per essere sicuri di questo, posta anche il risultato di :
sudo fdisk -l
tutto intero, specialmente la prima parte. ( copia/incolla )
Cita messaggio
#6
(04-09-2013, 17:19 )dxgiusti Ha scritto: alla seconda immagine, scegli "altro" posizionati sulla partizione che vuoi, doppio click, formatta ext4, metti il mount " / " e tutto si installerà. il grub per l'avvio da quanto vedo dovrebbe andare in dev/sda2 ma per essere sicuri di questo, posta anche il risultato di :
sudo fdisk -l
tutto intero, specialmente la prima parte. ( copia/incolla )

Ok, ma facendo così poi il boot loader di windows non viene sostituito dal grub? E' questo che è successo la prima volta, quando non potevo piu avviare windows.....
Ho la certezza che grub capisca che Ubuntu non è l'unico SO installato oppure mi ritroverò nella situazione descritta sopra?
Grazie ancora per l'aiuto Smile
Cita messaggio
#7
dobbiamo sapere quale è la partizione che uefi individua per l'avvio. di solito è una partizione in far 32. il comando "fdisk -l" dovrebbe evidenziarlo. mi raccomando, segui bene le indicazioni di come installare con uefi.
Cita messaggio
#8
(04-09-2013, 17:42 )dxgiusti Ha scritto: dobbiamo sapere quale è la partizione che uefi individua per l'avvio. di solito è una partizione in far 32. il comando "fdisk -l" dovrebbe evidenziarlo. mi raccomando, segui bene le indicazioni di come installare con uefi.

ok questo è l'output di fdisk -l...



WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted.


Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x00000000

Device Boot Start End Blocks Id System
/dev/sda1 1 976773167 488386583+ ee GPT
Partition 1 does not start on physical sector boundary.

Disk /dev/sdb: 8004 MB, 8004304896 bytes
35 heads, 21 sectors/track, 21269 cylinders, total 15633408 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

Device Boot Start End Blocks Id System
/dev/sdb1 * 32 15633407 7816688 b W95 FAT32
Cita messaggio
#9
stai usando gparted da ubuntu 13.04? non legge le partizioni. ora con quanto abbiamo la certezza non c'è. se ti sovrascrive il boot di win, poi riesci a ripristinarlo? altrimenti seguiamo un'altra strada ossia installiamo volutamente l'avvio di ubuntu dove non dovrebbe essere ( nella partizione di ubuntu ) poi con bootrepair dal disco live lo facciamo ripristinare da lui.
Cita messaggio
#10
(04-09-2013, 18:06 )dxgiusti Ha scritto: stai usando gparted da ubuntu 13.04? non legge le partizioni. ora con quanto abbiamo la certezza non c'è. se ti sovrascrive il boot di win, poi riesci a ripristinarlo? altrimenti seguiamo un'altra strada ossia installiamo volutamente l'avvio di ubuntu dove non dovrebbe essere ( nella partizione di ubuntu ) poi con bootrepair dal disco live lo facciamo ripristinare da lui.

Dunque tra il 12.10 e il 13.04 ho deciso di installare il 12.10 poichè l'altro mi da problemi all'avvio, ed è prorpio il 12.10 che ho utilizzato per gli screenshot.

Per quanto riguarda il boot di win, potrei anche riuscire a rimetterlo a posto avviando lo stesso Win dalla scheda madre(come ho fatto la prima volta) però preferirei non rischiare perchè non ho il dvd di installazione di Win 8 in quanto non mi è stato dato al momento dell'acquisto del pc Undecided
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)