Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Minecraft non si apre
#1
Ciao a tutti. Ho un problema con Minecraft. E' un gioco che richiede java. Io ho installato questa versione:

Codice:
rita@rita-Aspire-5930:~$ java -version
java version "1.7.0_51"
Java(TM) SE Runtime Environment (build 1.7.0_51-b13)
Java HotSpot(TM) 64-Bit Server VM (build 24.51-b03, mixed mode)
rita@rita-Aspire-5930:~$


Fino a ieri funzionava tutto. Dopo qualche aggiornamento mi ritrovo in questa situazione:

Codice:
rita@rita-Aspire-5930:~/Scrivania/Enrico/MINECRAFT/Minecraft forge 1.4.7 funzionante$ java -jar MinecraftSP.jar Hello!
URL: file:/home/rita/.minecraft/bin/lwjgl.jar
URL: file:/home/rita/.minecraft/bin/jinput.jar
URL: file:/home/rita/.minecraft/bin/lwjgl_util.jar
URL: file:/home/rita/.minecraft/bin/minecraft.jar
URL: file:/home/rita/.minecraft/bin/linux_natives.jar
Java HotSpot(TM) 64-Bit Server VM warning: You have loaded library /home/rita/.minecraft/bin/natives/liblwjgl.so which might have disabled stack guard. The VM will try to fix the stack guard now.
It's highly recommended that you fix the library with 'execstack -c <libfile>', or link it with '-z noexecstack'.
Exception in thread "Thread-1" java.lang.UnsatisfiedLinkError: /home/rita/.minecraft/bin/natives/liblwjgl.so: /home/rita/.minecraft/bin/natives/liblwjgl.so: classe ELF errata: ELFCLASS32 (Possible cause: architecture word width mismatch)
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary1(ClassLoader.java:1965)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1890)
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1851)
at java.lang.Runtime.load0(Runtime.java:795)
at java.lang.System.load(System.java:1062)
at org.lwjgl.Sys$1.run(Sys.java:69)
at java.security.AccessController.doPrivileged(Native Method)
at org.lwjgl.Sys.doLoadLibrary(Sys.java:65)
at org.lwjgl.Sys.loadLibrary(Sys.java:81)
at org.lwjgl.Sys.<clinit>(Sys.java:98)
at net.minecraft.client.Minecraft.G(SourceFile:1985)
at awe.<init>(SourceFile:20)
at net.minecraft.client.Minecraft.<init>(SourceFile:76)
at avv.<init>(SourceFile:38)
at net.minecraft.client.MinecraftApplet.init(SourceFile:38)
at net.minecraft.Launcher.replace(Launcher.java:153)
at net.minecraft.Launcher$1.run(Launcher.java:94)


 

Distribuzione in uso Xubuntu 14.04 
Cita messaggio
#2
Alla fine in un modo o nell'altro il pacchetto liblwjgl sono riuscito a installarlo ma ancora non va.


Codice:
Java HotSpot(TM) 64-Bit Server VM warning: You have loaded library /home/rita/.minecraft/bin/natives/liblwjgl.so which might have disabled stack guard. The VM will try to fix the stack guard now.
It's highly recommended that you fix the library with 'execstack -c <libfile>', or link it with '-z noexecstack'.

Sembra che devo dargli un comando......devo fixare un file.  Ho provato a dargli exestack -c liblwjgl.so ma evidentemente sbaglio qualcosa.
 

 

Distribuzione in uso Xubuntu 14.04 
Cita messaggio
#3
Nessuna idea?

Distribuzione in uso Xubuntu 14.04 
Cita messaggio
#4
Come faccio a sapere se un antivirus mi crea questo problema?  In teoria non ho installato nessun antivirus.  C'è qualche impostazione di base di Xubuntu che potrebbe creare problemi da questo punto di vista?

Distribuzione in uso Xubuntu 14.04 
Cita messaggio
#5
Sempre niente?
 

Distribuzione in uso Xubuntu 14.04 
Cita messaggio
#6
Se fai una ricerca in rete minecraft  per ubuntu dispone di un proprio metacchetto installazione completa
sudo add-apt-repository ppa:minecraft-installer-peeps/minecraft-installer
sudo apt-get update && sudo apt-get install minecraft-installer
Cita messaggio
#7
(21-01-2014, 09:07 )'francofait' Ha scritto: Se fai una ricerca in rete minecraft  per ubuntu dispone di un proprio metacchetto installazione completa
sudo add-apt-repository ppa:minecraft-installer-peeps/minecraft-installer
sudo apt-get update && sudo apt-get install minecraft-installer


 

Si ma da quel repository si scarica solo la versione demo senza pagare.

 

 

Distribuzione in uso Xubuntu 14.04 
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)