Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Non riesco a far funzionare tp-link wifi adapter
#1
Salve. Uso Chakra e nel forum apposito non riusciamo a cavar piede da questo problema. Ho pensato di scrivere anche qui per aumentare il bacino di utenti esperti, quale io non sono.
Spero riusciate ad aiutarmi.

Ho acquistato un adattatore wifi-usb della tp-lnk, modello TL-wn725n

Ora vi elenco quello che ho fatto e il problema.

- Ho installato i driver appositi dai repository ccr
- Ho dato il comando
Codice:
depmod -a
e il risultato è stato
Codice:
depmod: ERROR: openat(/lib/modules/3.10.10-1-CHAKRA, modules.dep.tmp, 1101, 644): Permission denied
depmod: ERROR: openat(/lib/modules/3.10.10-1-CHAKRA, modules.dep.bin.tmp, 1101, 644): Permission denied
depmod: ERROR: openat(/lib/modules/3.10.10-1-CHAKRA, modules.alias.tmp, 1101, 644): Permission denied
depmod: ERROR: openat(/lib/modules/3.10.10-1-CHAKRA, modules.alias.bin.tmp, 1101, 644): Permission denied
depmod: ERROR: openat(/lib/modules/3.10.10-1-CHAKRA, modules.softdep.tmp, 1101, 644): Permission denied
depmod: ERROR: openat(/lib/modules/3.10.10-1-CHAKRA, modules.symbols.tmp, 1101, 644): Permission denied
depmod: ERROR: openat(/lib/modules/3.10.10-1-CHAKRA, modules.symbols.bin.tmp, 1101, 644): Permission denied
depmod: ERROR: openat(/lib/modules/3.10.10-1-CHAKRA, modules.builtin.bin.tmp, 1101, 644): Permission denied
depmod: ERROR: openat(/lib/modules/3.10.10-1-CHAKRA, modules.devname.tmp, 1101, 644): Permission denied

ho dato
Citazione:modprobe 8188eu

Codice:
sudo ip link set wlp0s29f7u6 up
perché la scheda viene riconosciuta con quella sigla
il risultato è
Codice:
RTNETLINK answers: Operation not permitted

se do
Codice:
sudo ifconfig wlp0s29f7u6 up

ricevo
Codice:
SIOCSIFFLAGS: Operation not permitted

se do
Codice:
iwconfig

risultato
Codice:
wlp0s29f7u6  unassociated  Nickname:"<WIFI@REALTEK>"
          Mode:Auto  Frequency=2.412 GHz  Access Point: Not-Associated  
          Sensitivity:0/0  
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

lo        no wireless extensions.

enp2s0    no wireless extensions.

Qualcuno ha idea di come risolvere?
Cita messaggio
#2
Eh eh eh di informazioni ne hai avute già tante di la ... qui ad usare chakra non siamo in tanti (credo sia solo io e neanche così scafato) ... forse qualcuno usa archlinux ma questo forum è più a sfondo Ubuntu ... tuttavia non mi è chiaro come hai installato il driver (proprietario) ... lo hai compilato tu o lo hai installato direttamente da ccr???
Ti ha dato errori nella compilazione? lo hai caricato correttamente con modprobe???

iwconfig te la chiama wlp0s29f7u6 ma non capisco perchè ip link set non la carichi.

O c'è qualche driver in conflitto ... ma mi pare di aver capito che se usi un adapter non hai la scheda wifi integrata ... o non lavora bene il driver ... il kernel che usi è quello di default???

Non mi sembri proprio inesperto per essere a pochi mesi in Linux Smile Smile
Cita messaggio
#3
Sono inesperto in relazione al tipico utente linuxiano Smile

Ho installato il driver per la chiavetta da ccr.
Il driver viene installato senza errori.
Caricato con modprobe.
Non ho driver in conflitto perché non ho wifi nel pc e per questo ho acquistato questa chiavetta.
Kernel di default

Ogni comando che tento per portarla in up mi dice non permesso, come scritto sopra.

L'ultimo consiglio nell'altro forum era di postare l'output seguente:
Codice:
[ronny@chakra-pc ~]$ hwinfo --wlan
24: USB 00.0: 0282 WLAN controller                              
  [Created at usb.122]
  Unique ID: aCV0.M1BlfozBLm7
  Parent ID: zPk0.9T1GDCLyFd9
  SysFS ID: /devices/pci0000:00/0000:00:1d.7/usb4/4-6/4-6:1.0
  SysFS BusID: 4-6:1.0
  Hardware Class: network
  Model: "Realtek 802.11n NIC"
  Hotplug: USB
  Vendor: usb 0x0bda "Realtek Semiconductor Corp."
  Device: usb 0x8179 "802.11n NIC"
  Serial ID: "00E04C0001"
  Driver: "r8188eu"
  Driver Modules: "8188eu"
  Device File: wlp0s29f7u6
  Features: WLAN
  Speed: 480 Mbps
  HW Address: f8:1a:67:26:ea:23
  Link detected: no
  WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13
  WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472
  WLAN bitrates: 1 2 5.5 11
  WLAN encryption modes: TKIP CCMP
  WLAN authentication modes: open wpa-psk wpa-eap
  Module Alias: "usb:v0BDAp8179d0000dc00dsc00dp00icFFiscFFipFFin00"
  Driver Info #0:
    Driver Status: 8188eu is active
    Driver Activation Cmd: "modprobe 8188eu"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #23 (Hub)

So che non è bello fare cross posting ma ho davvero necessità di risolvere perché sto per traslocare Smile
Intel e6400 - 2gb di ram - Radeon HD 6450 - Distro_Chakra Linux
Virtualizzate_Manjaro/Lubuntu
Cita messaggio
#4
Il cross posting a me non infastidisce e ne abbiamo discusso lasciando libero l'utente di decidere quando e dove postare.
In CCR era l'unica soluzione? c'era anche un pacchetto con estensione finale -git? In tal caso installa quello li (rimuovi o blacklista il precedente) ... secondo me chi ha caricato il pacchetto potrebbe non averlo compilato correttamente ... il sito del produttore cosa riporta in merito ... prova a vedere che il pacchetto non sia segnalato come obsoleto!

Io una prova ... leggendo problemi legati ai permessi ... la farei: crea un nuovo utente (anche con kuser) e vedi se ti fa operare ... eventualmente lo cancelli!
Cita messaggio
#5
(14-11-2013, 15:15 )tumbler Ha scritto: Il cross posting a me non infastidisce e ne abbiamo discusso lasciando libero l'utente di decidere quando e dove postare.
In CCR era l'unica soluzione? c'era anche un pacchetto con estensione finale -git? In tal caso installa quello li (rimuovi o blacklista il precedente) ... secondo me chi ha caricato il pacchetto potrebbe non averlo compilato correttamente ... il sito del produttore cosa riporta in merito ... prova a vedere che il pacchetto non sia segnalato come obsoleto!

Io una prova ... leggendo problemi legati ai permessi ... la farei: crea un nuovo utente (anche con kuser) e vedi se ti fa operare ... eventualmente lo cancelli!
La stessa chiavetta l'ha usata e consigliata un utente del forum. A lui funziona tutto perfettamente, senza fare tutte ste cose.
Il driver è solo quello, e il manteiner è proprio l'utente che usa la chiavetta e che me l'ha consigliata.
Intel e6400 - 2gb di ram - Radeon HD 6450 - Distro_Chakra Linux
Virtualizzate_Manjaro/Lubuntu
Cita messaggio
#6
premetto che non non sono un utente di chakra, e forse dico una castroneria, ma non è che per fare le operazioni, visto che ti nega i permessi, devi acquisire i permessi di root come primo comando con su, sudo -s o sudo su o quel che vuole chakra?
mandi...Eugenio
Ubuntu 12.04 Unity, Ubuntu 14.04 Unity, Pclinuxos Mate, Mint17 Cinnamon, PcLinuxOS KDE
Cita messaggio
#7
Di solito son comandi riferiti agli utenti ... io proverei a crearne un altro in modo da partire con una configurazione utente pulita
Cita messaggio
#8
(14-11-2013, 15:23 )tumbler Ha scritto: Di solito son comandi riferiti agli utenti ... io proverei a crearne un altro in modo da partire con una configurazione utente pulita

Ho creato un altro utente ma le risposte sono sempre le stesse. Ovviamente agendo da root, perché il nuovo utente non è in sudoers.

@eu66
Sì, per molti comandi ovviamente uso sudo Wink
Intel e6400 - 2gb di ram - Radeon HD 6450 - Distro_Chakra Linux
Virtualizzate_Manjaro/Lubuntu
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)