Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Nuovo Bumblebee 3.1, Nvidia Optimus
#1
In attesa che vengano al più presto rilasciati dei driver dalla Nvidia (cosa che succederà molto presto dopo il rilascio del kernel 3.9) il progetto Bumblebee va avanti, ed è stato rilasciata la versione 3.1 che, oltre ad utilizzare la librerie VirtualGL per "emulare" la funzionalità di Optimus e utilizzare la scheda, ha aggiunto il modulo Primus, che permette un aumento delle prestazioni considerevole e un risparmio dei consumi e della "fatica" della nostra scheda, oltre ad essere sensibilmente più stabile. Basta solo sapere che Nvidia stessa utilizzerà Primus per portare i loro driver ufficiali su Linux.

Per installare il nuovo Bumblebee, se avete aggiunto già il ppa ufficiale, dovete prima rimuovere il vecchio con tutti i file di configurazione, e se avevate installato il vecchio Primus, dovrete rimuovere anche quello.

Per rimuovere il vecchio Primus, da terminale, date:

Codice:
sudo apt-get purge primus primus-lib:i386

sudo ppa-purge ppa:zhurikhin/primus

sudo apt-get autoremove
Poi, per disinstallare il vecchio Bumblebee:

Codice:
sudo apt-get purge bumblebee bumblebee-nvidia nvidia-current
Dopodiché riavviare, riaprire il terminale e dare i seguenti comandi:

Codice:
sudo apt-get update

sudo apt-get install bumblebee bumblebee-nvidia nvidia-current
Fate termina sessione, rientrate, riaprite il terminale e digitate:

Codice:
sudo apt-get install primus
e se avete un sistema a 64 bit installate anche:

Codice:
sudo apt-get install primus-libs-ia32:i386
Adesso il più è fatto. Per poter utilizzare il nostro Primus direttamente quando apriamo un programma con optirun, dobbiamo fare un piccolo edit su un file di configurazione. Aprite il terminale e date:

Codice:
sudo gedit /etc/bumblebee/bumblebee.conf
e, alla riga 28, dove vi è scritto:

Codice:
Bridge=auto
modificatelo così:

Codice:
Bridge=primus

Salvate e chiudete tutto. Adesso vedrete che utilizzando un programma con optirun esso funzionerà molto ma molto meglio, e non preoccupatevi se con il comando optirun glxspheres i fps sono più o meno coincidenti con la vostra scheda integrata, Primus riconosce la frequenza di aggiornamento del vostro schermo e si adegua di conseguenza, io ho provato Bumblebee con Steam e un gioco, Team Fortress 2, che con il vecchio Bumblebee non ne voleva sapere di funzionare mentre la grafica, rispetto all'utilizzo della scheda Intel integrata, è migliorata moltissimo, tanto che il gioco setta automaticamente tutti i parametri al massimo.
M1rr0r92 Idea

Se i tempi non chiedono la tua parte migliore, inventa altri tempi.
Cita messaggio
#2
Ciao ha me la riga 28 non corrisponde bridge non c'e proprio ecco il mio file di configurazione http://ubuntuone.com/1I04nfa5nfGKuwz9UIzdWB
http://maclinuxlovers.wordpress.com/ per chi ama il computer
Cita messaggio
#3
(27-02-2013, 23:50 )zifino Ha scritto: Ciao ha me la riga 28 non corrisponde bridge non c'e proprio ecco il mio file di configurazione http://ubuntuone.com/1I04nfa5nfGKuwz9UIzdWB

Ciao, hai seguito la mia guida punto per punto oppure stavi già usando Bumblebee? Perché quello è il vecchio file di configurazione, della versione 3.0. Ti consiglio di disinstallare Bumblebee come ho scritto nel mio vecchio post e poi reinstallarlo.
M1rr0r92 Idea

Se i tempi non chiedono la tua parte migliore, inventa altri tempi.
Cita messaggio
#4
si,grazie ho dovuto cancellare la versione 3.0 ed installare la versione 3.1 ora tutto funzionante,grazie
http://maclinuxlovers.wordpress.com/ per chi ama il computer
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)