Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Partizioni eliminate per errore, ripristinate, ma Windows 7 non fa più il boot.
#1
Ho da poco fatto il passaggio da XP a Windows 7, e contestualmente ho effettuato l'upgrade del mio PC fisso. Non sapendo che l'UEFI e il GPT potessero essere un problema, mi sono avventurato nell'installazione del sistema operativo Ubuntu, e nel cercare di far visualizzare le partizioni già esistenti a software di partizionamento dell'installer di Ubuntu 12,04, cercando di effettuare l'installazione come ho sempre fatto, mi sono ritrovato col sistema non più avviabile. Non è la prima volta che installo distribuzioni linux sul mio PC, quindi ho cercato di fare attenzione sapendo i rischi, e non mi pare di aver fatto alcunché per eliminare le partizioni di Windows. Fatto sta che, dopo aver rilevato che per Ubuntu e Gparted il mio disco non aveva alcuna partizione (fin da principio), lo spazio era tutto unallocated, ho sospeso la fase di installazione, e al riavvio mi sono trovato col PC fermo a subito dopo il bios, con un messaggio indicante che non era presente alcun sistema operativo. Ho smontato l'hard disk e l'ho montato su un altro PC constatando che le partizioni erano state eliminate, ho successivamente scoperto, anche grazie a questo forum, che ad oggi esistono per fortuna dei software che ripristinano le partizioni. Quindi in sintesi, il problema di vitale importanza, ovvero la perdita dei dati in quanto tali è scampato. Purtroppo però rimontando l'hard disk sul PC in panne il problema è rimasto ugualmente, stesso messaggio. Nel frattempo ho già montato un altro hard disk e reinstallato tutto per tornare operativo in breve tempo. Ma essendo un tipo curioso, mi domandavo se fosse possibile ripristinare le partizioni in modo da tornare a far fare il boot all'hard disk originario, semplicemente per comodità, in quella installazione ho già tutto pronto per lavorare e tutto è già organizzato al meglio. Credo sia rimasto un problema di flag, ma non saprei con quale software effettuare tale operazione e come effettuarla. Penso che il problema sia questo in quanto anche da Windows 7 è visibile la differenza tra i due dischi (disco nuovo e originario), le partizioni hanno flag differenti. Inoltre mi domandavo se potesse essere efficace copiare la partizione di 100 MB di Windows 7 con software di clonazione dal disco nuovo a quello originario? Il disco di Windows 7 purtroppo non mi è stato di nessun aiuto in questo senso, in quanto la versione installata nel disco è la Ultimate 64 bit con service pack, e il DVD purtroppo non la riconosce come versione valida, e anche usando l'altro computer o il nuovo disco la console di ripristino o non vedeva le partizioni o non riteneva il sistema compatibile. Aspetto qualcuno che possa aiutarmi a capire se ciò che vorrei fare sia possibile. Grazie.

PS: ho scoperto anche dell'esistenza di testdisk, che probabilmente mi avrebbe risolto il problema, ma il software in questione mi rileva anche altre partizioni oltre a quelle effettivamente presenti al momento, precedenti ad esse, o le stesse modificate, il che mi rende difficile capire quali siano quelle da salvare e quelle da dichiarare cancellate.
Cita messaggio
#2
testdisk è il software che ti permette di recuperare le partizioni cancellate/formattate. dato che sul disco non si cancella mai nulla anche formattando, lui vedrà tutto quanto hai. ora dovrai tu a dirgli quale ripristinare.
all'inizio parli di uefi e gpt, ma tu sei messo cosi?
il dvd di win è ultimate? tu dici di aver installato quello.
http://www.internauta37.altervista.org/s...4-italiano#
Cita messaggio
#3
Ciao e grazie per la risposta. Il dvd è lo stesso con il quale ho effettuato l'installazione, e da quanto ho visto sul web ho trovato che anche altri hanno avuto lo stesso problema, e sembrerebbe un problema attribuibile all'assenza di service pack nel dvd, mentre nel sistema installato è già stato fatto l'aggiornamento. Purtroppo, non essendo la prima volta che effettuo tali operazioni (dual boot Windows Linux) ed essendo la prima volta che avevo la combinazione di sistema operativo Windows 7 + motherboard nuova con UEFI, ed avendo avuto pochi problemi in passato, sono andato sul tranquillo. Quindi nel bios ho lasciato tutto impostato in default a parte la configurazione della ram, il boot, e poco altro. Per cui Windows ha partizionato, ovviamente senza darmi possibilità di scegliere altrimenti mi sarei informato prima, utilizzando il partizionamento GPT, che per ovvie ragioni ignoravo. Purtroppo ho dato per scontato che avendo effettuato il mio upgrade hardware dopo molti anni, nel frattempo le procedure fossero già tutte oob: scarichi, metti il cd/dvd o fai la pennetta usb con Ubuntu e installi in pochi minuti... Non so se effettivamente le procedure siano già del tutto automatizzate e sono stato semplicemente sfortunato o distratto. Fatto sta che se l'unica soluzione è testdisk, dovrò verificare la possibilità di definire con certezza quali siano tra quelle rilevate da tale software le partizioni corrispondenti a quelle che attualmente sia Ubuntu che Windows mi lasciano vedere. Considerato questo fatto, cioè che le partizioni sono attualmente visualizzabili senza l'ausilio di altro software, mi domandavo se ci fosse qualche altro software o qualche comando con cui assegnare le flag alle partizioni e se questa fosse una strada possibile e percorribile.
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)