Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Problema con scheda wireless TP-Link TL-WDN4800
#1
Ciao a tutti.
Spero sia la sezione giusta.
Come da titolo, ho montato sul mio computer fisso con dual boot (Windows 7 e ubuntu 14.04) la scheda wireless dual band TP-Link TL-WDN4800, che ho letto essere compatibile con linux (in particolare vorrei utilizzare la connessione 5 GHz).
Il problema è questo: in effetti riesco a connettermi sia in 2.4 che in 5 GHz, ma il segnale con ubuntu è piuttosto basso (45 Mb/s) contro i 300 Mb/s di windows e poi talvolta la connessione cade.
Mi chedo allora se non ho sbagliato qualcosa io e se si può fare qualcosa, oppure se devo tenere tutto così, anche se la navigazione spesso è decisamente lenta.
Qualcuno mi può aiutare? Grazie infinite.

Forse questo può servire...
Citazione:
Codice:
marco@marco-fisso:~$ lspci -k
07:00.0 Network controller: Qualcomm Atheros AR93xx Wireless Network Adapter (rev 01)
   Subsystem: Qualcomm Atheros Device 3112
   Kernel driver in use: ath9k
marco@marco-fisso:~$ uname -r
3.13.0-37-generic

In più, girando in rete ho trovato questo comando, ma prima di provare vorrei qualche consiglio, giusto per non incasinare tutto...
Citazione:
In terminal, type:
sudo -s gksu gedit /etc/modprobe.d/ath9k.conf
Then in the text file that opens, add the following line:
options ath9k nohwcrypt=1
Save the file, close it, and reboot. Connection speeds should be good now.
vi posto anche il link
http://ubuntuforums.org/showthread.php?t=1970955

Qualcuno mi può aiutare????
Grazie. 

 
Cita messaggio
#2
Nessuno sa come aiutarmi?
 
Cita messaggio
#3
se leggi in giro quella che hai trovato è la soluzione più frequentemente suggerita, poi nei diversi thread trovi diversi modi per metterla in pratica, anche usando in comando echo insieme al comando tee: echo "options ath9k nohwcrypt=1" | sudo tee /etc/modprobe.d/ath9k.conf
il risultato finale è lo stesso, dici ai driver ath9k di non usare la criptazione hardware e per farlo è necessario creare (se non c'è) o aggiungere (se c'è) al file di configurazione dei driver (ath9k.conf) l'opzione nohwcrypt=1.
io andrei diretto:
sudo gedit /etc/modprobe.d/ath9k.conf
dopo l'inserimento della password (digitala tutta e premi invio anche se sembra che non la scrive) si apre l'editor di testo, aggiungi la frasetta suggerita (options ath9k nohwcrypt=1), salva, chiudi, riavvia.
ciao
 Trasferito sul Nuovo Forum [img]images/smilies/blush.gif[/img]
Cita messaggio
#4
Prima di tutto grazie della tua risposta e scusa il ritardo della mia.
Ho provato a fare quanto detto sopra, ma a dire il vero poco cambia.
Mentre windows continua a stare su 300 Mb/s, con un speedtest intorno agli 11500 in download, ubuntu viaggia intorno ai 70-100 Mb/s con uno speed test intorno ai 3500/4000...
Hai altri suggerimenti o altre strategie?
Grazie ancora.
 
Cita messaggio
#5
allora meglio vedere tutta la situazione. apri il terminale e digita:
sudo lshw -c network > lshw.txt
dopo troverai sulla tua /home il file lshw.txt da allegare al tuo prossimo post.
ciao
 Trasferito sul Nuovo Forum [img]images/smilies/blush.gif[/img]
Cita messaggio
#6
Ecco qui il file allegato seguendo le tue istruzioni...
 

 


Allegati
.txt   lshw.txt (Dimensione: 1,47 KB / Download: 3)
Cita messaggio
#7
proviamo con quest'altra modifica. apri il terminale e digita:
sudo gedit /etc/rc.local
prima di exit0 aggiungi la riga con cui obblighiamo la scheda a lavorare ad una banda prestabilita:
iwconfig wlan0 rate 5.5M
salva, chiudi e riavvia. funziona?
per eliminare la modifica, basta ridare sudo gedit... e cancellare la riga che hai inserito (salva, chiudi, riavvia).

fammi sapere
 Trasferito sul Nuovo Forum [img]images/smilies/blush.gif[/img]
Cita messaggio
#8
ciao e scusa se le mie risposte arrivano un po' tardi ma sono spesso fuori per lavoro...
Ho provato la modifica che mi hai scritto, ma purtroppo non cambia nulla.
Hai altre idee? Potrebbe essere una questione di driver? Esistono driver open che funzionino meglio di quelli ath9k?
Intanto grazie ancora!!
 
Cita messaggio
#9
i driver sono giusti, sono open e sono gli unici che esistono (almeno che io sappia). peraltro li uso anch'io sul mio notebook (atheros ar9462) e vanno benissimo.
facciamo una ricerca per id vendor/product; apri il terminale e digita il comando:
lspci -nn
ti risponderà con la lista delle pci, copia/incolla la parte relativa alla tua scheda, mi interessa particolarmente il codice alfanumerico  fra le parentesi quadre che individua il produttore e il modello; nel mio caso per esempio è [168c:0034], il tuo dovrebbe essere simile, ovvero [168c:xxxx], dove le ultime quattro cifre individuano il modello che hai montato.
poi dai anche questo comando:
iwconfig > wlan.txt
e come per l'altra volta troverai un file sulla tua /home da allegare al tuo prossimo post.
ciao
 Trasferito sul Nuovo Forum [img]images/smilies/blush.gif[/img]
Cita messaggio
#10
Prima di tutto ancora grazie per l'aiuto!
Allora, questo è quello che mi dà con lspci -nn

07:00.0 Network controller [0280]: Qualcomm Atheros AR93xx Wireless Network Adapter [168c:0030] (rev 01)

e poi ti allego il file...


Allegati
.txt   wlan.txt (Dimensione: 462 byte / Download: 3)
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)