Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Problema di compilazione dell pacchetto gcc per debian lenny
#1
Salve, ho scaricato il pacchetto tar.gz gcc-4.2 dalla mia ubuntu 12.04
nel sito ufficiale dato che dai repo della debian non si trova la
versione del c ANSI.
Decomprimo il tarball e metto la cartella nella debian una
volta entrato do ./configure e mi risponde:

Citazione:loading cache ./config.cache
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking build system type... i686-pc-linux-gnu
checking for a BSD compatible install... /usr/bin/install -c
checking whether ln works... yes
checking whether ln -s works... yes
checking for gcc... noin $PATH
checking for cc... no
configure: error: no acceptable cc found in $PATH

invio pure il config.log

Citazione:This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

configure:630: checking host system type
configure:651: checking target system type
configure:669: checking build system type
configure:724: checking for a BSD compatible install
configure:777: checking whether ln works
configure:801: checking whether ln -s works
configure:1866: checking for gcc
configure:1896: checking for cc

Nessuno mi puo' aiutare a capire dove puo' essere il problema?
Non capisco Arrendersi
Cita messaggio
#2
Non sono un'esperto,perciò prendi le mie considerazioni con il beneficio del dubbio, e in attesa di risposte da utenti sicuramente più ferrati ti faccio due ipotesi:
Lenny come Sqeeze sono versioni stabili di Debian, tra l'altro mi pare che Lenny non sia più supportata, per cui puoi installare solo pacchetti ritenuti stabili.Per tanto quel pacchetto gcc-4.2 che dici aver scaricato da ubuntu 12.04 probabilmente non è compatibile con Lenny(forse lo è con Debian 7 testing) in quanto ritenuto instabile.
C'è poi la possibilità che quel pacchetto non sia proprio compatibile con Debian in quanto, mentre i pacchetti per Debian di solito sono sempre compatibili con Ubuntu, non è sempre vero il contrario.
mandi...Eugenio
Ubuntu 12.04 Unity, Ubuntu 14.04 Unity, Pclinuxos Mate, Mint17 Cinnamon, PcLinuxOS KDE
Cita messaggio
#3
da sofweare center vedo che il pacchetto gcc è gia installato alla versione 4:4.6.3

       
Cita messaggio
#4
(27-07-2012, 13:39 )dxgiusti Ha scritto: da sofweare center vedo che il pacchetto gcc è gia installato alla versione 4:4.6.3

Se non ho capito male io, alien75 cerca di installare quel pacchetto in Debian Lenny scaricandolo, però, da Ubuntu 12.04.
mandi...Eugenio
Ubuntu 12.04 Unity, Ubuntu 14.04 Unity, Pclinuxos Mate, Mint17 Cinnamon, PcLinuxOS KDE
Cita messaggio
#5
Il pacchetto build-essential di lenny potrebbe contenere il necessario per la compilazione dei sorgenti, quindi anche gcc.

Non c'è da stupirsi che l'idea di prenderlo da un ubuntu di 3 anni posteriore al rilascio di lenny (14 Febbraio 2009) non funzioni...
Peccato perché era simpatica ma, veramente, avventurosa.
[Immagine: http://pclinuxos.com/forum/avatars/Pengu...guitux.png] Parole !
Mai che se ne trovino due uguali !
Cita messaggio
#6
(27-07-2012, 15:15 )eu66 Ha scritto:
(27-07-2012, 13:39 )dxgiusti Ha scritto: da sofweare center vedo che il pacchetto gcc è gia installato alla versione 4:4.6.3

Se non ho capito male io, alien75 cerca di installare quel pacchetto in Debian Lenny scaricandolo, però, da Ubuntu 12.04.

Si infatti esatto !!
Cita messaggio
#7
(27-07-2012, 16:56 )zafran Ha scritto: Il pacchetto build-essential di lenny potrebbe contenere il necessario per la compilazione dei sorgenti, quindi anche gcc.

Non c'è da stupirsi che l'idea di prenderlo da un ubuntu di 3 anni posteriore al rilascio di lenny (14 Febbraio 2009) non funzioni...
Peccato perché era simpatica ma, veramente, avventurosa.

Vedo che te ne intendi di Debian quindi ti chiedo dove posso
trovare gcc per debian lenny 5.07? Ho trovato
solo il sito ufficiale nel quale c'e' la versione in tar.gz da compilare
ma se cerco di compilarla mi da delle noie io cerco il pacchetto
.deb di gcc per la lenny dato che la lenny mi dice che il compilatore di default non e' secondo lo standard ANSI che e' invecie quello
che serve a me per compilare nmap, tcpdump e snort.
Sto' cercando di creare una rete virtuale ed imparare un po' di amministrazione di un server fatto con Debian Lenny.
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)