Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Problema di installazione della BT5 in una macchina virtuale
#1
Salve ho installato VirtualBox sotto ubuntu 12.04.
Sotto VirtualBox ho gia' installato due debian lenny virtuali con
le seguenti caratteristiche:

Citazione:RAM 230Mbyte
HDvirtuale da 2.5 Gbyte

Ad esse ho tolto il segno di spunta sulle schede audio virtuali
dato che una dovro' utilizzarla come server http e server nfs
e nell' altra non ho installato al suo interno nessun tipo di demone
in ascolto dato che il suo solo scopo sara' di fungere da router
che mette in contatto la macchina reale (ununtu 12.04 che fungera'
da NAT, gateway e firewall perimetrale) con la sottorete fatta appunto
dalla debian usata come server ed altre eventuali future macchine virtuli.
Nella terza macchiana virtuale sto' cercando di installarci una Back Track 5. Tale VM ha le seguenti caratteristiche:

Citazione:RAM 230Mbyte
HDvirtuale da 12Gbyte ad espansione dinamica
su pennetta usb da 16Gbyte montata in /home/utente/Virtulabox/bt5

In tale disco virtuale ho creato una partizione Logica ext3 con punto di mount in /
da 10Gbyte e una partizione di swap da 230Mbyte.
Una volta create le partizioni la procedura di installazione copia i files all' interno
della chiavetta contenente l' HD virtuale.
Una volta finita l' installazione all' interno dell' HD virtuale dovrebbero esservi
quasi 8Gbyte di files ed invecie cone mia sorpresa vedo che al 96% dell' installazione
nell' HD virtuale ne vedo solo 2,5Gbyte circa.
Ad un certo punto mi appare un messaggio che mi dice che non sono stati copiati tutti
i file dal CD all' HD virtuale e che la causapotrebbe essere l' HD rovianto o difettoso
oppure le lenti delle lettore CD sporche.
Spengo quindi la MV rimuvendola completamente compresi tutti i files e l' HDvirtuale,
la ricreo con le stesse caratteristiche, pulisco il lettore CD con l' apposito kit
e ripeto l' installazione ottenendo alla fine lo stesso messaggio con lo stesso
risultato.
A questo punto mi viene da sbattere la testa contro il monitor. #-o #-o #-o ?%
Nessuno mi puo' aiutare a capire dove puo' essere il problema?
Cita messaggio
#2
Perché una partizione logica con ext3 montata in / su una penna usb?
Nel caso avessi separato la penna in più partizioni sappi che il problema potrebbe risiedere proprio lì. Ti consiglierei di dedicare l'intera pendrive con filesystem ext4.
Ogni fallimento avvicina sempre più alla meta... Arrendersi subito equivale a non provare affatto.

Il bisogno di conoscere e scoprire, è la fiamma che alimenta la fornace che è il cervello umano.
Cita messaggio
#3
(05-08-2012, 11:25 )Dukko Ha scritto: Perché una partizione logica con ext3 montata in / su una penna usb?
Nel caso avessi separato la penna in più partizioni sappi che il problema potrebbe risiedere proprio lì. Ti consiglierei di dedicare l'intera pendrive con filesystem ext4.

la pennetta e' stata formattata con un' unica partizione
di cui non ricordo se sia ext3 o ext4, mentre il file del' HD virtuale
ad espansione dinamica e' stato formattato con una ext3
ed al suo interno ho ricavato la part. / e la Swap.
Mi consigli quindi come e' ovvio di riformattare pure la pennetta con ext4
e non solo l' HD virtuale ?
Cita messaggio
#4
No no, scusa, avevo capito male io.
Comunque proverei a spostare su HD fisico il disco virtuale, far puntare la macchina virtuale alla nuova posizione e poi riavviarla.
Lo spostamento su pendrive puoi farlo in qualsiasi momento... ma come mai hai usato ext3?
Ogni fallimento avvicina sempre più alla meta... Arrendersi subito equivale a non provare affatto.

Il bisogno di conoscere e scoprire, è la fiamma che alimenta la fornace che è il cervello umano.
Cita messaggio
#5
(07-08-2012, 06:46 )Dukko Ha scritto: No no, scusa, avevo capito male io.
Comunque proverei a spostare su HD fisico il disco virtuale, far puntare la macchina virtuale alla nuova posizione e poi riavviarla.
Lo spostamento su pendrive puoi farlo in qualsiasi momento... ma come mai hai usato ext3?

Nella ubuntu reale ho sempre usato ext3 e non sapevo che
sulla BT5 bisognasse usare la ext4, comunque ho riformattato la
pennetta usando ext4.
Il problema e' che la bt5 mi prende 8Gbyte e nella / della distro reale
non ho 8Gbyte di disco disponibile.
Come mai la creazione di HD virtuali da problemi se creata su pennetta?
Uso la pennetta proprio perche' non ho abbastanza spazio su disco.
Cita messaggio
#6
Non è obbligatorio usare ext4 è solo un filesystem migliore.
Fai un'altra prova, crea la macchina con disco virtuale sul PC e poi spostalo su pendrive (anche formattata fat32).
Ogni fallimento avvicina sempre più alla meta... Arrendersi subito equivale a non provare affatto.

Il bisogno di conoscere e scoprire, è la fiamma che alimenta la fornace che è il cervello umano.
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)