Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Problema salvataggio in libreoffice 4.1
#1
Salve a tutti, ho installato, scaricandolo dal sito ufficiale, libreoffice 4.1.0.4 su ubuntu 13.04 plus 11. All'inizio nessun problema ma da ieri se provo a salvare un file con password mi compare l'errore dell'immagine allegata e non riesco ad aprire file con password creati in precedenza. La cosa strana è che su Ubuntu 12.04 plus 9 non ho nessun problema!
Intanto sono tornato alla 4.0.4
Volevo sapere anche se è possibile modificare lo script della versione plus di libreoffice scaricato da qui in modo da installare libreoffice 4.1 in versione plus.
Grazie per le risposte


Allegati Anteprime
   
Sconosco l'inglese e mi rifiuto di impararlo
Da solo avrò un'idea, in due potremmo averne tre, in tanti troveremo la soluzione migliore
Buona vita a tutti Heart
Cita messaggio
#2
ciao, per quanto ne so libreoffice viene ora aggiornato da ubuntu. effettivamente la versione 4.1 non rientra ancora tra gli aggiornamenti. curiosando sul web ha trovato:
http://www.antonioallegretti.it/?q=it/node/1628
ora faccio una prova con il mio muletto ( installo solo il ppa e vedo se me lo aggiorna, hai visto mai ) poi ti faccio sapere.
Cita messaggio
#3
allora vediamo un poco quanto ho fatto e cosa succede. ho installato il ppa presente nel link, ho aggiornato con i tre comandi canonici ( update. upgrade, dist-upgrade ) al termine ho trovato installato la 4.1. ho provato cosi semplicemente a creare una pagina di testo, un calcolo semplice e tutto funziona. ho allora salvato con psww un file di testo e tutto ok. a questo punto con una versione identica installata su altro sistema ho provato a salvare un file proteggendolo per vedere se riuscivo ad aprirlo poi ma purtroppo mi dice:

.png   LibreOffice 4.1.0.4_026.png (Dimensione: 8,29 KB / Download: 2)
conclusione: sulla 4.1 aggiornata nel modo sopra detto riesco a salvare proteggendo il file, sulla 4.1 installata standar non posso proteggere. mi manca la prova per aprire un file protetto ma non ne ho a disposizione. magari ne creerò uno con la 12.04
Cita messaggio
#4
(02-08-2013, 14:01 )dxgiusti Ha scritto: allora vediamo un poco quanto ho fatto e cosa succede. ho installato il ppa presente nel link, ho aggiornato con i tre comandi canonici ( update. upgrade, dist-upgrade ) al termine ho trovato installato la 4.1. ho provato cosi semplicemente a creare una pagina di testo, un calcolo semplice e tutto funziona. ho allora salvato con psww un file di testo e tutto ok. a questo punto con una versione identica installata su altro sistema ho provato a salvare un file proteggendolo per vedere se riuscivo ad aprirlo poi ma purtroppo mi dice:

conclusione: sulla 4.1 aggiornata nel modo sopra detto riesco a salvare proteggendo il file, sulla 4.1 installata standar non posso proteggere. mi manca la prova per aprire un file protetto ma non ne ho a disposizione. magari ne creerò uno con la 12.04
Non ho ben capito come hai installato - credo che a quest'ora e con questo caldo sia normale non capire - mai io praticamente ho scaricato dal sito ufficiale e poi tramite uno script che mi sono creato ho disinstallato libreoffice ed installato la nuova versione e non funziona su Ubuntu 13.04 plus 11.
Adesso provo ad installare la 4.0.04 e poi ad aggiornare, vediamo come va a finire
Sconosco l'inglese e mi rifiuto di impararlo
Da solo avrò un'idea, in due potremmo averne tre, in tanti troveremo la soluzione migliore
Buona vita a tutti Heart
Cita messaggio
#5
allora io sulla 13.04 avevo installato la 4.0, ho preso dal link l'indirizzo ppa e l'ho installato.
sudo add-apt-repository ppa:libreoffice/ppa
ora ho dato i tre comandi dal terminale:
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
al termine mi ritrovo la 4.1, funzionante in tutto. ho allora provato con la 4.0 installata sulla 12.04 a creare un file protetto, quindi ne ho provato l'apertura sulla 13.04 con la 4.1. tutto ok come pure creare file protetti con 4.1 ed aprirli con 4.0. ( mamma mia quanti numeri ) facendo queste prove ho però notato che su di un'altra distribuzione la pclinuxos con installato 4.1, se cerco di proteggere un file mi dice permesso negato, vedi finestra e se cerco di aprirne uno protetto con ubu (4.0) mi dice pswd sconosciuta. ma penso che questo riguardi pclinux. con i due ubu 12.04/13.04 creo e proteggo file con 4.0/4.1 e li apro senza problemi.
Cita messaggio
#6
Pare che funzioni ma non riesco ad entrare in strumenti>personalizzazioni!
Sconosco l'inglese e mi rifiuto di impararlo
Da solo avrò un'idea, in due potremmo averne tre, in tanti troveremo la soluzione migliore
Buona vita a tutti Heart
Cita messaggio
#7
Allora faccio il punto: dopo essere riuscito ad installare mi sono accorto che la cartella /nome/NOME UTENTE/.config/libreoffice contiene cartelle diverse rispetto a quelle che vedevo prima il che mi impedisce di copiare alcuni modelli personalizzati di libreoffice writer (modelli che uso come carta intestata dello studio e che ho creao io) per cui ho scaricato dal sito ufficiale e tramite uno script che mi sono creato con questo contentuo:
Codice:
#!/bin/bash

sudo apt-get remove --purge libreoffice*.*

sudo dpkg -i /home/NOME UTENTE/LibreOffice_4.1.0.4_Linux_x86-64_deb/DEBS/*.deb

sudo dpkg -i /home/NOME UTENTE/LibreOffice_4.1.0.4_Linux_x86-64_deb/DEBS/desktop-integration/*.deb

sudo dpkg -i /home/NOME UTENTE/LibreOffice_4.1.0.4_Linux_x86-64_deb_langpack_it/DEBS/*.deb

sudo dpkg -i /home/NOME UTENTE/LibreOffice_4.1.0.4_Linux_x86-64_deb_helppack_it/DEBS/*.deb

sudo apt-get clean -y

sudo apt-get autoclean -y

sudo apt-get autoremove -y

exit
ho disinstallato libre e installato dalle cartelle scompattate nella mia home.
Ha questo punto la cartella /nome/NOME UTENTE/.config/libreoffice ha ripreso ad avere il suo contenuto ma il salvataggio con password è impossibile così come non riconosce le password di file creati in precedenza.
Per risolvere ho eseguito lo stesso script di cui sopra sostituendo la versione 4.1 con la 4.0.4; per ora tutto funziona.
Ho sempre fatto gli avanzamenti attraverso lo script di cui sopra (l'idea mi è stata data tempo fa dal prof. dal quale ho copiato lo script) ed ha sempre funzionato ... aspetterò che nei repository di ubuntu 13.04 spunti la versione 4.1 per installarla ... il fatto che l'abbiano rilasciata pochi giorni dopo la precedente mi fa credere che ci siano dei bug nella versione 4.0.4, ma può darsi che mi sbagli!
Attendo qualche altra risposta e poi metto [RISOLTO]
Grazie a tutti
Sconosco l'inglese e mi rifiuto di impararlo
Da solo avrò un'idea, in due potremmo averne tre, in tanti troveremo la soluzione migliore
Buona vita a tutti Heart
Cita messaggio
#8
si forse aspettare è la scelta giusta. per quanto mi riguarda con pclinux e lo4.1 è stato appurato un bug ( problema che non posso salvare con pswd ). seraficamente aspetto che risolvano. ciao
Cita messaggio
#9
Quindi se ho capito bene installare dai repository è ben diverso che scaricare ed installare dalla pagina ufficiale? Addirittura cambiano le cartelle in cui l'applicazione va ad installarsi!
Aspetto conferma e poi mi dite come devo mettere: [RISLTO] [NON RISOLTO] [BUG]!?
Sconosco l'inglese e mi rifiuto di impararlo
Da solo avrò un'idea, in due potremmo averne tre, in tanti troveremo la soluzione migliore
Buona vita a tutti Heart
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)