Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Problemi con Linux
#1
Ciao a tutti, sto utilizzando la versione di Linux 10.04 - Lucyd Linx - rilasciata nell'aprile 2010 e supportata fino all'aprile 2013. Negli ultimi tempi sto avendo dei problemi nel senso che, dopo aver aperto alcuni programmi (ad es. Eqonomize oppure Cabina per webcam Cheese), la finestra scompare e si chiudono improvvisamente. Ho pensato, visto che so che Linux non può essere contagiato da virus, che potesse dipendere dalla versione troppo vecchia; allora ho provato ad eseguire l'avanzamento, ma questo si blocca sempre dicendo : «Si è verificato un problema durante l'aggiornamento. Solitamente si tratta di problemi di rete, controllare la connessione di rete e riprovare.».
Vi domando: sto facendo bene ad eseguire l'avanzamento? I problemi del pc possono dipendere dal fatto che ho una versione vecchia. Grazie mille a tutti.

 
Cita messaggio
#2
(29-04-2014, 19:29 )vindicio Ha scritto: Ciao a tutti, sto utilizzando la versione di Linux 10.04 - Lucyd Linx - rilasciata nell'aprile 2010 e supportata fino all'aprile 2013. Negli ultimi tempi sto avendo dei problemi nel senso che, dopo aver aperto alcuni programmi (ad es. Eqonomize oppure Cabina per webcam Cheese), la finestra scompare e si chiudono improvvisamente. Ho pensato, visto che so che Linux non può essere contagiato da virus, che potesse dipendere dalla versione troppo vecchia; allora ho provato ad eseguire l'avanzamento, ma questo si blocca sempre dicendo : «Si è verificato un problema durante l'aggiornamento. Solitamente si tratta di problemi di rete, controllare la connessione di rete e riprovare.».
Vi domando: sto facendo bene ad eseguire l'avanzamento? I problemi del pc possono dipendere dal fatto che ho una versione vecchia. Grazie mille a tutti.

 

Il supporto di Lucid Linx come tu hai detto e terminato l'hanno scorso.
Meglio passare ad una nuova lts, Ubuntu 12.04.4 o la nuova Ubuntu 14.04 (hardware permettendo) o a una loro derivata.
Il passaggio di versione conviene farlo con una prova in sessione live e se tutto funziona con una installazione pulita exnovo.
mandi...Eugenio
Ubuntu 12.04 Unity, Ubuntu 14.04 Unity, Pclinuxos Mate, Mint17 Cinnamon, PcLinuxOS KDE
Cita messaggio
#3
Secondo me i problemi non dipendono dal fatto che la distribuzione non sia più supportata, per l'avanzamento dovresti postare i dati dell'hardware per controllare se può andare con le versioni successive.
Nel frattempo prova a cambiare i repository e dopo a reinstallare i programmi
[spoiler=repository]Individuare la propria versione
 
  • Digitare il seguente comando in una finestra di terminale:
    Codice PHP:
    lsb_release -dc 
     
    • Il risultato sarà simile a quanto segue:
      Codice PHP:
      Description:    Ubuntu 9.10
      Codename
      :       karmic 
       Il dato fondamentale da ricavare lo si ha alla voce Codename che dovrà essere sostituito nel file /etc/apt/sources.list come mostrato di seguito.
      In questo esempio risulta essere karmic, nome in codice della versione 9.10 di Ubuntu. Sostituire i repositoryAprire con i privilegi di amministrazione e con un editor di testo il file /etc/apt/sources.list e cancellare l'intero contenuto.Occorre inserire i repository desiderati come da esempio, avendo cura di sostituire il termine CODENAME con il nome in codice della versione di Ubuntu ricavato nel passaggio precedente: deb http://old-releases.ubuntu.com/ubuntu/ CODENAME main universe restricted multiverse
      deb-src http://old-releases.ubuntu.com/ubuntu/ CODENAME main universe restricted multiverse

      deb http://old-releases.ubuntu.com/ubuntu/ CODENAME-security main universe restricted multiverse
      deb-src http://old-releases.ubuntu.com/ubuntu/ CODENAME-security main universe restricted multiverse

      deb http://old-releases.ubuntu.com/ubuntu/ CODENAME-updates main universe restricted multiverse
      deb-src http://old-releases.ubuntu.com/ubuntu/ CODENAME-updates main universe restricted multiverse Repository aggiuntivi
       
      • Backports:
        Codice PHP:
        deb http://old-releases.ubuntu.com/ubuntu/ CODENAME-backports main restricted universe multiverse
        deb-src http://old-releases.ubuntu.com/ubuntu/ CODENAME-backports main restricted universe multiverse 
         
        • Proposed:
          Codice PHP:
          deb http://old-releases.ubuntu.com/ubuntu/ CODENAME-proposed main restricted universe multiverse
          deb-src http://old-releases.ubuntu.com/ubuntu/ CODENAME-proposed main restricted universe multiverse 
           Salvare e chiudere l'editor di testo e quindi aggiornare l'elenco dei sorgenti digitando in una finestra di terminaleConfusedudo apt-get update EsempioA titolo esemplificativo, se come nel passaggio iniziale il nome della versione in uso risultasse karmic, allora il file verrebbe così modificato: deb http://old-releases.ubuntu.com/ubuntu/ karmic main universe restricted multiverse
          deb-src http://old-releases.ubuntu.com/ubuntu/ karmic main universe restricted multiverse

          deb http://old-releases.ubuntu.com/ubuntu/ karmic-security main universe restricted multiverse
          deb-src http://old-releases.ubuntu.com/ubuntu/ karmic-security main universe restricted multiverse

          deb http://old-releases.ubuntu.com/ubuntu/ karmic-updates main universe restricted multiverse
          deb-src http://old-releases.ubuntu.com/ubuntu/ karmic-updates main universe restricted multiverse Repository aggiuntivi
           
          • Backports:
            Codice PHP:
            deb http://old-releases.ubuntu.com/ubuntu/ karmic-backports main restricted universe multiverse
            deb-src http://old-releases.ubuntu.com/ubuntu/ karmic-backports main restricted universe multiverse 
             
            • Proposed:
              Codice PHP:
              deb http://old-releases.ubuntu.com/ubuntu/ karmic-proposed main restricted universe multiverse
              deb-src http://old-releases.ubuntu.com/ubuntu/ karmic-proposed main restricted universe multiverse 
               [/spoiler]
              Giuseppe


Cita messaggio
#4
Mi pare che l'avanzamento si possa fare solo con la versione successiva, nel tuo caso eventualmente converrebbe reinstallare.
Giuseppe
Cita messaggio
#5
L'avanzamento si può fare da lts a lts. Se hai una versione intermedia devi avanzare di versione in versione. Meglio però salvare i dati con un backup e reinstallare la nuova versione.
mandi...Eugenio
Ubuntu 12.04 Unity, Ubuntu 14.04 Unity, Pclinuxos Mate, Mint17 Cinnamon, PcLinuxOS KDE
Cita messaggio
#6
ciao, mi aggiungo alla lista dei consigli:
se avanzi devi tassativamente ripristinare i driver open, devi disabilitare tutti i repo esterni i famosi ppa, devi disinstallare i programmi generati dai ppa. ad avanzamento ultimato ripristina i driver, ed uno alla vlta i ppa ed i loro programmi, dopo aver prima aggiornato. in parole semplici, salva i tuoi dati e rifai un'installazione pulita ex novo, impiegherai molto ma molto meno.
 
Cita messaggio
#7
Sono d'accordo.
Giuseppe
Cita messaggio
#8
Io non sono contrario agli avanzamenti, anzi personalmente provo sempre a fare l'avanzamento di versione prima di reinstallare, ma in questo caso ci penserei due volte: il passaggio dalla 1.04 alla 12.04 comporta il passaggio da Gnome2 a Unity, e come è noto, quante più cose cambiano da una distro all'altra, più alto è la probabilità che l'avanzamento fallisca. Inoltre, non so di che epoca è il tuo computer, ma il tuo hardware potrebbe non essere abbastanza potente da far girare bene Unity (se ci scrivi le caratteristiche meglie possiamo essere più precisi), e se vuoi una interfaccia grafica appena appena simile a quella che hai utilizzato finora, Unity non è quello che fa per te. Insomma, per una volta, mi associo a chi consiglia di reinstallare. Prova Ubuntu 14.04 da live per vedere se Unity di aggrada, nel caso non ti piaccia ci sono ambienti grafici molto simili a GNOME 2 (in primis MATE, ma anche XFCE).
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)