Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Bug di ubuntu errore:E:Encountered a section with no Package: header
#1
ciao a tutti,
ho provato a installare il pacchetto kit-modi-grafici.zip seguendo la vostra guida, ma l'installazione è fallita e in seguito ad ogni avvio di ubuntu mi compare un segnale col seguente errore:

Impossibile inizializzare le informazioni del pacchetto

Si è verificato un problema irrisolvibile durante l'inizializzazione delle informazioni del pacchetto.

Segnalare questo bug per il pacchetto «update-manager» e includere il seguente messaggio d'errore:

'E:Encountered a section with no Package: header, ETongueroblem with MergeList /var/lib/apt/lists/it.archive.ubuntu.com_ubuntu_dists_oneiric-updates_universe_i18n_Translation-en, E:L'elenco dei pacchetti o il file di stato non può essere letto o aperto.'


tra l'altro non riesco più a far partire l'ubuntu software center(volevo provare a disinstallare il pacchetto da lì).
la mia versione di ubuntu è la 11.10.

qualcuno potrebbe gentilmente darmi qualche suggerimento?
(premetto che sono abbastanza nuovo con ubuntu)
Cita messaggio
#2
Prova: da terminale, digita (uno alla volta):

sudo apt-get install -f

e poi

sudo apt-get update

e poi

sudo apt-get upgrade
Cita messaggio
#3
ho provato ma niente, mi dà sempre questo errore:


Lettura elenco dei pacchetti... Errore
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/it.archive.ubuntu.com_ubuntu_dists_oneiric-updates_universe_i18n_Translation-en
E: L'elenco dei pacchetti o il file di stato non può essere letto o aperto.
Cita messaggio
#4
Pare si tratti di un bug di Ubuntu:

https://bugs.launchpad.net/ubuntu/+sourc...bug/911211

Apri il terminale ed incolla (uno alla volta):

sudo rm /var/lib/apt/lists/*Packages

sudo apt-get update
Cita messaggio
#5
in effetti la descrizione che danno al link dice che questo bug si verifica quando si installano dei pacchetti da una rete non completamente aperta(In the event that one is connected to a network with a proxy server that returns html pages (like a web page requesting you to login) and not package list files).
io l'ho fatto dalla rete della biblioteca comunale del mio paese.
per ora con quei 2 comandi non si risolve il problema, ora provo a leggere cosa dicono nel link...
intanto grazie per l'aiuto Smile

edit:
ho cambiato il titolo del post
Cita messaggio
#6
provo a usare queste istruzioni trovate qui: https://bugs.launchpad.net/ubuntu/+sourc...bug/346386

cd /var/lib/dpkg
sudo mv status status-bad
sudo cp status-old status

sudo apt-get update
apt-get upgrade

For others this was also needed:
sudo rm -f /var/lib/dpkg/lock

While for the rest of us nothing seems to work so far!

In other words: CONFIRMED
Cita messaggio
#7
Prova col comando:

sudo rm /var/lib/apt/lists/it.archive.ubuntu.com_ubuntu_dists_oneiric-updates_universe_i18n_Translation-en
Cita messaggio
#8


(01-03-2012, 00:10 )Antonio_Cantaro Ha scritto: Prova col comando:

sudo rm /var/lib/apt/lists/it.archive.ubuntu.com_ubuntu_dists_oneiric-updates_universe_i18n_Translation-en


questo sembra funzionare, sta scaricando i pacchetti, per ora senza problemi....incrocio le dita!

Cita messaggio
#9
risolto, sparito il messaggio di errore, ha aggiornato tutto quanto, tutto a posto insomma Smile

grazie per l'aiuto!
Cita messaggio
#10
Ne sono contento. In pratica hai cancella il file:

it.archive.ubuntu.com_ubuntu_dists_oneiric-updates_universe_i18n_Translation-en
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)