Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] - DELL latitude c810 schermo piccolo
#1
...ma ciao!
ho installato Ubuntu 11.04 sul pc in oggetto tutto funziona bene tranne la grafica.
Il display non occupa tutto il monitor. praticamente ho un immagine da 11" su un monitor da 14".
Inizialmente non riuscivo ad installare niente, dopodichè ho scoperto che dal livecd, abilitando l'opzione nomodeset oppure l'opzione acpi=off riuscivo a far artire e installare il tutto ovviamente avvio in modalità classica perchè unity non va.
La scheda grafica dando il comando lspci risulta essere una:
nVidia Corporation NV11 [GeForce2 Go]

Allora ho installato i driver nvidia current.
Abilitandoli mi dice che il driver è attivo ma non attualmente in uso.

Per vedere se magari diceva che non era i nuso ma funzionava comunque, ho provato il test glxgears ma mi dice:
Codice:
Xlib: extension "GLX" missng on display ":0.0"
Error: couldn't get an RGB, Double-buffered visual

se provo con il comando nvidia-settings mi compare un pop-up che dice:
Codice:
You do not appear to be using the NVIDIA X driver.
Please edit your X configuration file (just run 'nvidia-xconfig' as root), and restart the X server.

Allora ho provato a lanciare nvidia-xconfig che va a crearmi un file xorg.xonf in /etc/X11 che prima non esisteva.
Il file creato è cosi':
Codice:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder75)  Thu Apr 14 09:22:52 PDT 2011

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       30.0 - 110.0
    VertRefresh     50.0 - 150.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Se a questo punto faccio ripartire l'X server, non si avvia piu'.
Allora da shell elimino il file xorg.conf (a fatica perchè vedo tutti i caratteri sovrapposti nella shell) e riavviando tutto torna alla normalità (cioè con il display piccolo).

Dimenticavo di dire che se vado nelle proprietà del monitor mi dice monitor sconosciuto e mi da solo due risoluzioni possibili:
1024x768 e 800x600

Ho provato a far partire l'ultima distribuzione CentOS e quella riesco a farla partire a pieno schermo dal livecd, quindi a livello hardware il monitor è aposto.
C'e' qualcosa che posso copiare dal livecd della CentOS per far funzionare tutto in ubuntu?

Qualcuno ha del tempo da dedicarmi per risolvere questo problema?
Grazie!


Cita messaggio
#2
Se puo' essere d'aiuto Ho notato ora che se imposto la risoluzione su 800x600, anzichè diminuire solo la risoluzione, mi rimpicciolisce il display.
Cita messaggio
#3
(22-09-2011, 09:34 )gepponline Ha scritto: Se puo' essere d'aiuto Ho notato ora che se imposto la risoluzione su 800x600, anzichè diminuire solo la risoluzione, mi rimpicciolisce il display.

Se da Driver Hardware hai la possibilità di installare i driver nvidia legacy (da versione 185.18.14 in giù) forse è meglio, quella scheda non è proprio nuovissima.

Bye
Token
Cita messaggio
#4
(22-09-2011, 10:13 )token Ha scritto:
(22-09-2011, 09:34 )gepponline Ha scritto: Se puo' essere d'aiuto Ho notato ora che se imposto la risoluzione su 800x600, anzichè diminuire solo la risoluzione, mi rimpicciolisce il display.

Se da Driver Hardware hai la possibilità di installare i driver nvidia legacy (da versione 185.18.14 in giù) forse è meglio, quella scheda non è proprio nuovissima.

Bye
Token

Al momento ho reinstallato tutto da zero.
E i dirver nvidia che prima avevo installato a mano, non me li ha insallati.
QUindi in driver aggiuntivi nnc'e' niente. che faccio li installo?
Come faccio per sapere che driver sta usando attualmente visto che non è un driver nvidia?
Cita messaggio
#5
Vai sul sito nvidia (QUI) e scarica i driver per la tua scheda video, puoi far fare anche il riconoscimento automatico.
Installando quelli tutto dovrebbe funzionare.
Ogni fallimento avvicina sempre più alla meta... Arrendersi subito equivale a non provare affatto.

Il bisogno di conoscere e scoprire, è la fiamma che alimenta la fornace che è il cervello umano.
Cita messaggio
#6
(22-09-2011, 13:39 )francater Ha scritto: Vai sul sito nvidia (QUI) e scarica i driver per la tua scheda video, puoi far fare anche il riconoscimento automatico.
Installando quelli tutto dovrebbe funzionare.

Il riconoscimento automatico non supporta Linux e la mia scheda non la trovo nell'elenco Sad
Cita messaggio
#7
(22-09-2011, 13:54 )gepponline Ha scritto:
(22-09-2011, 13:39 )francater Ha scritto: Vai sul sito nvidia (QUI) e scarica i driver per la tua scheda video, puoi far fare anche il riconoscimento automatico.
Installando quelli tutto dovrebbe funzionare.

Il riconoscimento automatico non supporta Linux e la mia scheda non la trovo nell'elenco Sad

Se Driver Aggiuntivi non ti rileva nulla installa a mano.

Li trovi qui i legacy.

Attualmente saranno probabilmente usati i driver nv o i nouveau.
Per saperlo
Codice:
$ lsmod
Bye
Token
Cita messaggio
#8
(22-09-2011, 14:34 )token Ha scritto:
(22-09-2011, 13:54 )gepponline Ha scritto:
(22-09-2011, 13:39 )francater Ha scritto: Vai sul sito nvidia (QUI) e scarica i driver per la tua scheda video, puoi far fare anche il riconoscimento automatico.
Installando quelli tutto dovrebbe funzionare.

Il riconoscimento automatico non supporta Linux e la mia scheda non la trovo nell'elenco Sad

Se Driver Aggiuntivi non ti rileva nulla installa a mano.

Li trovi qui i legacy.

Attualmente saranno probabilmente usati i driver nv o i nouveau.
Per saperlo
Codice:
$ lsmod
Bye
Token


problemino... I diver scaricati vogliono che io non abbia l'ambiente grafico avviato. Cosa devo fare per avviare il pc senza l'ambiente grafico?
Cita messaggio
#9
Avvia in modalità ripristino.
E poi fai partire il server X con startx
Ogni fallimento avvicina sempre più alla meta... Arrendersi subito equivale a non provare affatto.

Il bisogno di conoscere e scoprire, è la fiamma che alimenta la fornace che è il cervello umano.
Cita messaggio
#10
oh cacchio.
Ho avviato il pc tenendo premutoshift per cercare la modalità di ripristino. Gli ho detto di avvairsi in modalità grafica ridotta e si è avviato con risoluzione 1600x1200 occupandomi tutto lo schermo....
Ho provatoa dirgli di renderla definitiva, ma al riavvio ha detto che quella risoluzione non era accettata e si è rimesso piccolino...
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)