Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO]Driver Stampante Canon i-sensys MF3010
#1
Buongiorno a tutti.
Ubuntu 10.04 Plus 5.Ho acquistato la stampante in oggetto che non è installabile direttamente su Ubuntu cioè i driver non li trova in automatico.Ho interpellato il Supporto Canon e mi hanno inviato il seguente file:"Linux_UFRII_PrinterDriver_V250_uk_EN.tar.gz".
Ho eseguito la seguente procedura:

#Installazione Pacchetti .tar.gz e .tar.bz2
Prima di tutto è fortemente consigliato eseguire i seguenti comandi dal terminale:
sudo apt-get install build-essential
sudo apt-get install checkinstall

Fatto questo bisogna scompattare i pacchetti con il comando:
sudo tar zxvf pacchetto.tar.gz"

Al posto di pacchetto ho messo il nome del file ("Linux_UFRII_PrinterDriver_V250_uk_EN.tar.gz") ma il risultato nel terminale è stato il seguente:

"tar: Linux_UFRII_PrinterDriver_V250_uk_EN.tar.gz: funzione "open" non riuscita: File o directory non esistente
tar: Errore irrimediabile: uscita immediata
tar: Child returned status 2
tar: Uscita con stato di fallimento in base agli errori precedenti"

Cortesemente potete aiutarmi a scompattare e ad installare tali driver?
Grazie.
Cita messaggio
#2
apri nautilus come root - clicca con il tasto dx sul file e premi estri qui.

Assicurati che il file sia stato scricato per intero - se vuoi prova a riscaricarlo
Cita messaggio
#3
(20-09-2012, 09:28 )tumbler Ha scritto: apri nautilus come root - clicca con il tasto dx sul file e premi estri qui.
Ciao tumbler, grazie per la risposta.
Ho operato nel modo seguente:
Ho installato "nautilus gksu", poi da terminate ho datoConfusedudo nautilus,poi da cartella home sono risalito al file messo in una cartella nella scrivania ed ho cliccato col tasto dx premendo estrai qui. E adesso?
Grazie
Cita messaggio
#4
(20-09-2012, 10:49 )antonio 13 Ha scritto: Ciao tumbler, grazie per la risposta.
Ho operato nel modo seguente:
Ho installato "nautilus gksu", poi da terminate ho datoConfusedudo nautilus,poi da cartella home sono risalito al file messo in una cartella nella scrivania ed ho cliccato col tasto dx premendo estrai qui. E adesso?
Grazie

Adesso quello che hai fatto equivale a questo:
Codice:
sudo tar zxvf pacchetto.tar.gz
che ti dava errore.

Ora:
1. segui la guida per installarlo (se ne seguivi una)
2. all'interno della cartella creata lancia install.sh (se presente)
3. leggi il file "INSTALL" (se presente)
4. compila il pacchetto se è presente un file PKGBUILD
Cita messaggio
#5
Ciao, stavo seguendo questa guida:
" Pacchetti .tar.gz e .tar.bz2
Prima di tutto è fortemente consigliato eseguire i seguenti comandi dal terminale:
sudo apt-get install build-essential
sudo apt-get install checkinstall
Fatto questo bisogna scompattare i pacchetti con il comando:
sudo tar zxvf pacchetto.tar.gz
…per i pacchetti con estensione .tar.bz2 invece:
sudo tar jxvf pacchetto.tar.bz2
Dopo aver scompattato il pacchetto, bisogna entrare nella cartella che il processo di estrazione ha creato e cercare eventuali file readme o install che vi illustreranno eventuali procedure di installazione. Se non trovate niente oppure la procedura è poco chiara, provate a seguire i classici comandi per la compilazione e l’installazione.
Spostiamoci nella cartella scompattata con il comando:
cd cartellapacchetto
E lanciamo in sequenza questi comandi:
sudo ./configure
sudo make
sudo checkinstall
L’ultimo comando (sudo checkinstall) permette di trasformare il pacchetto .tar in un pacchetto .deb, azione che facilita eventuali aggiornamenti o rimozione del software."


Ma al comando "cd cartellapacchetto" mi dà:
antonio@antonio:~$ cd linux_UFRII-printeddriver_V250_uk_en
bash: cd: linux_UFRII-printeddriver_V250_uk_en: File o directory non esistente
antonio@antonio:~$
Cita messaggio
#6
Citazione:Spostiamoci nella cartella scompattata con il comando:
cd cartellapacchetto

questo puoi farlo in due modi:

1. da terminale: cd /home/tuonome/download/cartellacreata (ovviamente sostituisci il percorso in cui la tua cartella è contenuta)

2. raggiungi la cartella con nautilus e fai apri nel terminale (non so se l'estensione per nautilus sia di default - nel caso non vi fosse segui caso 1)
Cita messaggio
#7
Ciao tumbler, ci siamo riusciti.
La cartella scompattata (Allegato 1) conteneva 4 cartelle,32 bit driver-64 bit driver-documents-sources)(Allegato 2),mentre la cartella "32 bit driver" conteneva 2 cartelle ,Debian e RPM (Allegato 3), in Debian c'erano 2 file che ho installato e la stampante funziona alla perfezione. Un'ultima domanda se riesco ad effettuare la stessa procedura in PCLinuxOS-LXDE installando i 2 file RPM dovrei ottenere lo stesso risultato.Giusto?
Grazie.
Antonio


Allegati Anteprime
           
Cita messaggio
#8
ciao,in pclinux per quanto ricordo dovresti attivare dei pacchetti. se posti nella sezione pclinuxos vedrai che monse/zafran o anche altri ti risponderanno con indicazioni risolutive.
Cita messaggio
#9
Non conosco affatto PCLinuxOS - ma il concetto non dovrebbe essere differente - al posto dei .deb installi i .rpm
Cita messaggio
#10
(20-09-2012, 14:21 )tumbler Ha scritto: Non conosco affatto PCLinuxOS - ma il concetto non dovrebbe essere differente - al posto dei .deb installi i .rpm

confermo che bisogna abilitare alcuni pacchetti. all'epoca io feci come risposta di monse:
http://www.istitutomajorana.it/forum/Thr...2#pid26712
logicamente cambiare hp con canon. poi monse se installo al di fuori di gestore pacchetti si arrabbia e mi manda le macumbe......
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)