Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[ RISOLTO ] Eepc900 e Ubuntu
#1
Salve a tutti, la mia è più una curiosità che una richiesta.Ancora nel 2009 avevo acquistato un eepc900 con Xp installato, e per due volte si è guastato l' SSD che è in parte saldato sulla scheda madre 4Giga il restante su di un modulo, dopo due sostituzioni , appena passata la garanzia si guastò per la terza volta. Dovetti comprare un Pc nuovo e l'eepc non poteva essere riparato. Io però avevo pensato una cosa, se ci sono degli antivirus che partono da chiavetta Usb, perche non far partire un programma per riparare l'ssd direttamente dall'esterno?
Insomma scoprii che potevo installare su di una chiavetta Poppy linus, che il tutto funzionava l'eepc poteva tornare a riviverere.
Non contento ho provato a installare Ubuntu sulla chiavetta , funzionava anche quello, ero proprio contento e non solo, avevo visto che si poteva installare Ubuntu direttamente sull Hard disk del computer, cosa che ho provato a fare, ma cera il problema del guasto all' hard disk, infatti l'installazione si fermava dopo un pò. A forza di tentativi ho scoperto Gparted e con quello ho capito che potevo utilizzare solo una parte dell' hard disk e installare cosi Ubuntu. Il 12 febraio del 2010 avevo fatto rivivere l'eepc (era anche il mio compleanno).
Da quel giorno ho provato a installare sistemi diversi che si adattassero alla capacità dell' eepc, Ubuntu10.4, Ubuntu10.10, Kubuntu, Xubuntu, Ububox Salentox, poi ho provato LinxMint 12 che non riesco ha installare.
In parte perche all'inzio ti chiede di scegliere un immagine o di scattare una foto per la password di accesso , ma la finestra con i tasti continua è al disotto del bordo del monitor, ho scoperto che devo girare lo schermo per poter accedere ai pulsanti di cinferma, dopo risolto questo cè il problema del Grub, mi dice che non può installarlo, errore fatale , posso completare l'installazione senza il Grub .
Questi problemi mi succedono anche con Ubuntu 11.10 plux 8 remix,
sempre il Problema del Grub , il sistema è installato e posso farlo partire con un CD con SuperGruDisk, che mi trova il sistema operativo installato e lo avvia perfettamente, ma se lo stesso l'installo su chiavetta Usb non funziona. Ho reinstallato Ubuntu 10.4 e non da problemi di Grub .
Scusate questa lunga lettera, solo se qualcuno mi sa dire perche Ubuntu10.4 non ha problemi con il Grub mente Ubuntu 10,10 ,LinxMint12 si.
Cita messaggio
#2
Per le finestre puoi risolvere col tasto Alt.

Tasto Alt premuto ti posizione un un punto qualunque della finestra e pouoi spostarla anche in alto vedendo i tasti sotto che prima erano nascosti.

Per il grub, entra in Ubuntu installaro (con Super Grub Disk) e poi da terminale dai i due comandi (uno alla volta):

sudo grub-install /dev/sda

sudo update-grub




Cita messaggio
#3
Gli antivirus non servono a riparare i dischi guasti;
e se devi usare il sistema operativo solo da chiavetta USB c'è poco da essere allegri.

Comunque a parte questo, è palesemente evidente che il tuo computer è uscito con un difetto di fabbricazione, te lo dovevano sostituire per intero, non solo l'SSD; è inverosimile che lo stesso dispositivo si guasti per 3 volte consecutivamente, quindi o ti hanno detto di averlo cambiato ma non l'hanno fatto, oppure ci potrebbe essere qualche anomalia dell'alimentazione che brucia l'SSD. O peggio, un difetto nella progettazione stessa del dispositivo.

Non so se risolvi il problema di Grub, ma sul computerino non lavorarci e non tenerci dati che ti servono.
Il mio blog: http://zerozerocent.blogspot.it/
Legge di Murphy: SE QUALCOSA PUO' ANDAR MALE, LO FARA'
Cita messaggio
#4
(27-12-2011, 18:05 )Claudio63 Ha scritto: ...
A forza di tentativi ho scoperto Gparted e con quello ho capito che potevo utilizzare solo una parte dell' hard disk e installare cosi Ubuntu. Il 12 febraio del 2010 avevo fatto rivivere l'eepc (era anche il mio compleanno).
Da quel giorno ho provato a installare sistemi diversi che si adattassero alla capacità dell' eepc, Ubuntu10.4, Ubuntu10.10, Kubuntu, Xubuntu, Ububox Salentox, poi ho provato LinxMint 12 che non riesco ha installare.
In parte perche all'inzio ti chiede di scegliere un immagine o di scattare una foto per la password di accesso , ma la finestra con i tasti continua è al disotto del bordo del monitor, ho scoperto che devo girare lo schermo per poter accedere ai pulsanti di cinferma, dopo risolto questo cè il problema del Grub, mi dice che non può installarlo, errore fatale , posso completare l'installazione senza il Grub .
Questi problemi mi succedono anche con Ubuntu 11.10 plux 8 remix,
sempre il Problema del Grub , il sistema è installato e posso farlo partire con un CD con SuperGruDisk, che mi trova il sistema operativo installato e lo avvia perfettamente, ma se lo stesso l'installo su chiavetta Usb non funziona. Ho reinstallato Ubuntu 10.4 e non da problemi di Grub .
Scusate questa lunga lettera, solo se qualcuno mi sa dire perche Ubuntu10.4 non ha problemi con il Grub mente Ubuntu 10,10 ,LinxMint12 si.

Puoi postare un'immagine di gparted, per un'occhiata alle condizioni del disco?

Per lo spostamento di finestre grandi prova a fare click+trascina (in area non attiva della finestra, cioè non su un bottone) avendo premuto il tasto Alt.

Riesci a bootare ed usare un sistema installato su SD? Ricordo che con eeepc 700 si riusciva.

Bye
Token
Cita messaggio
#5
(27-12-2011, 19:23 )token Ha scritto:
(27-12-2011, 18:05 )Claudio63 Ha scritto: ...
A forza di tentativi ho scoperto Gparted e con quello ho capito che potevo utilizzare solo una parte dell' hard disk e installare cosi Ubuntu. Il 12 febraio del 2010 avevo fatto rivivere l'eepc (era anche il mio compleanno).
Da quel giorno ho provato a installare sistemi diversi che si adattassero alla capacità dell' eepc, Ubuntu10.4, Ubuntu10.10, Kubuntu, Xubuntu, Ububox Salentox, poi ho provato LinxMint 12 che non riesco ha installare.
In parte perche all'inzio ti chiede di scegliere un immagine o di scattare una foto per la password di accesso , ma la finestra con i tasti continua è al disotto del bordo del monitor, ho scoperto che devo girare lo schermo per poter accedere ai pulsanti di cinferma, dopo risolto questo cè il problema del Grub, mi dice che non può installarlo, errore fatale , posso completare l'installazione senza il Grub .
Questi problemi mi succedono anche con Ubuntu 11.10 plux 8 remix,
sempre il Problema del Grub , il sistema è installato e posso farlo partire con un CD con SuperGruDisk, che mi trova il sistema operativo installato e lo avvia perfettamente, ma se lo stesso l'installo su chiavetta Usb non funziona. Ho reinstallato Ubuntu 10.4 e non da problemi di Grub .
Scusate questa lunga lettera, solo se qualcuno mi sa dire perche Ubuntu10.4 non ha problemi con il Grub mente Ubuntu 10,10 ,LinxMint12 si.

Puoi postare un'immagine di gparted, per un'occhiata alle condizioni del disco?

Per lo spostamento di finestre grandi prova a fare click+trascina (in area non attiva della finestra, cioè non su un bottone) avendo premuto il tasto Alt.

Riesci a bootare ed usare un sistema installato su SD? Ricordo che con eeepc 700 si riusciva.

Bye
Token

Ciao a tutti, questa è l'immagine dell'hard disk
http://img809.imageshack.us/img809/4769/...parted.png

il computerino lo uso per navigare e per far pratica su Ubuntu e vari sistemi e non tengo dati importanti, l'immagine che dovresti vedere se sono riuscito a caricarla è come lo partizionata io, dove c'è la partizione ntfs ,è la zona dell'hard disk danneggiata , e tempo addietro non riuscivo a formattarla, adesso invece non dà errori.
Sono tornato a installare Ubuntu 10.4 perchè completa l'installazione da solo senza problemi, ed è pienamente funzionante, mentre appunto le versioni 11.10 e LinuxMint12 danno errore per l'installazione del grub.
Il computerino lo faccio partire anche da chiavetta con Multisistem ed è installato:
Xubuntu,
Partitionmagic
Puppy Linux
e carico il sistema che mi serve , a parte i tempi di caricamento, tutto funziona.
Ho provato ache i comandi che ha suggerito il Prof. Cantaro e li avevo letti su un precedente post che aveva scritto , comunque non funzionando.
Comunque vi ringrazio tutti per i suggerimenti ma non perdeteci il sonno il computer è funzionante lo stesso.
Era solo per capire il perche funziona Ubuntu 10.4
invece Ubuntu 11.10 e LinuxMint12 si bloccano con il grub.
Saluti a tutti .................... Claudio63





Cita messaggio
#6
(27-12-2011, 21:55 )Claudio63 Ha scritto: Ciao a tutti, questa è l'immagine dell'hard disk
...
Sono tornato a installare Ubuntu 10.4 perchè completa l'installazione da solo senza problemi, ed è pienamente funzionante, mentre appunto le versioni 11.10 e LinuxMint12 danno errore per l'installazione del grub.
...
Era solo per capire il perche funziona Ubuntu 10.4
invece Ubuntu 11.10 e LinuxMint12 si bloccano con il grub.
Saluti a tutti .................... Claudio63

Probabilmente anche se si fosse installato grub2 (è la versione dalla Ubuntu 10.10 in poi) poi non avrebbe funzionato correttamente perchè in partizione logica.

Per contrassegnare eventuali settori danneggiati dell'HD (e fare un partizionamento un po' più "umano") potresti usare BadBlock (se funge anche con i SSD).

Bye
Token
Cita messaggio
#7
(27-12-2011, 22:04 )token Ha scritto:
(27-12-2011, 21:55 )Claudio63 Ha scritto: Ciao a tutti, questa è l'immagine dell'hard disk
...
Sono tornato a installare Ubuntu 10.4 perchè completa l'installazione da solo senza problemi, ed è pienamente funzionante, mentre appunto le versioni 11.10 e LinuxMint12 danno errore per l'installazione del grub.
...
Era solo per capire il perche funziona Ubuntu 10.4
invece Ubuntu 11.10 e LinuxMint12 si bloccano con il grub.
Saluti a tutti .................... Claudio63

Probabilmente anche se si fosse installato grub2 (è la versione dalla Ubuntu 10.10 in poi) poi non avrebbe funzionato correttamente perchè in partizione logica.

Per contrassegnare eventuali settori danneggiati dell'HD (e fare un partizionamento un po' più "umano") potresti usare BadBlock (se funge anche con i SSD).

Bye
Token

Ok tornerò a provare l' installazione e vedere se BadBlock corregge gli errori, se per piacere pui farmi un esempio dei comandi relativi a BadBlock.
Ti ringrazio per la cortesia , Claudio
Cita messaggio
#8
(28-12-2011, 10:11 )Claudio63 Ha scritto: Ok tornerò a provare l' installazione e vedere se BadBlock corregge gli errori, se per piacere pui farmi un esempio dei comandi relativi a BadBlock.
Ti ringrazio per la cortesia , Claudio

Per il controllo di un intero disco:
Codice:
$ sudo badblocks -nvs /dev/sda
dove sda è il disco in questione (ma potrebbe essere sdb, sdc, ...).

Per il controllo di una partizione:
Codice:
$ sudo badblocks -nvs /dev/sda1
dove sda1 è la specifica partizione (potrebbe essere sda2, ..., sdb7, ...).

Partizione/disco non devono essere montati durante in controllo.
Per ulteriori elementi/dettagli
Codice:
$ man badblocks

Bye
Token
Cita messaggio
#9
(28-12-2011, 15:26 )token Ha scritto:
(28-12-2011, 10:11 )Claudio63 Ha scritto: Ok tornerò a provare l' installazione e vedere se BadBlock corregge gli errori, se per piacere pui farmi un esempio dei comandi relativi a BadBlock.
Ti ringrazio per la cortesia , Claudio

Per il controllo di un intero disco:
Codice:
$ sudo badblocks -nvs /dev/sda
dove sda è il disco in questione (ma potrebbe essere sdb, sdc, ...).

Per il controllo di una partizione:
Codice:
$ sudo badblocks -nvs /dev/sda1
dove sda1 è la specifica partizione (potrebbe essere sda2, ..., sdb7, ...).

Partizione/disco non devono essere montati durante in controllo.
Per ulteriori elementi/dettagli
Codice:
$ man badblocks

Bye
Token
Buon giorno a tutti, scusate se riprendo questa discussione ma siccome ieri avevo la necessità-curiosità di installare un altro sistema operativo, avevo il problema del Grub che non viene installato. Ho provato a creare una partizione Primaria come aveva suggerito token per installare il Grub, ma non funziona. Ho fatto vari tentativi di installare Supergrub su schedina SD, riusciti ma non funzionanti per far partire Linux Mint 12. La soluzione funzionante che ho trovato alla fine è questa: quando all'inizio dell'installazione ti chiede come partizionare l'hard disk, basta scegliere come destinazione per il boot la schedina SD gia formattata in FAT32.
Come dice quel tale " rozzo ma efficace "
All'avvio del netbook basta scegliere la memoria SD e da li parte linux
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)