Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Errore permessi cartella condivisa
#1
Buongiorno a tutti, ho cercato nel forum ma non ho trovato una soluzione che si presti al mio problema.
Ho un portatile con Xubuntu 14.04 e vorrei accedere in lettura e scrittura a cartelle condivise in rete locale del NAS.
Innanzitutto ho cercato di far montare in automatico all'avvio le cartelle condivise, con questa procedura:
- creato un file nel quale salvare le credenziali di accesso alla rete:


Codice:
sudo mousepad ~/.smbcredentials
e scritto le credenziali nel file


Codice:
username=shareuser
password=sharepassword
domain=domain_or_workgroupname
- cambiato i permessi di accesso al file per sicurezza:


Codice:
chmod 0600 ~/.smbcredentials
- creato il punto di mount locale:


Codice:
mkdir /mnt/nome_locale
- aperto il file fstab:


Codice:
sudo mousepad /etc/fstab
e inserito la riga necessaria:


Codice:
//percorso_rete /mnt/nome_locale cifs credentials=/home/nome_utente/.smbcredentials 0 0

Fin qui bene, le cartelle vengono montate; se però provo a creare un file su queste cartelle condivise non mi viene permesso (Errore, operazione non permessa), mentre se provo a copiare un file questo viene copiato ma mi dà anche Errore nell'impostare i permessi. Operazione non riuscita.
Anche con aMule ad esempio, impostando come cartella di destinazione una del NAS, i file vengono creati ma vuoti (0kb), non salvando di fatto niente.

Se invece copio un file da terminale non ricevo segnali di errore ed il file viene effettivamente copiato.
Preciso che l'utente di xubuntu è diverso da quello che dà le credenziali in .smbcredentials in fase di mount all'avvio delle cartelle.

Qualche idea su come procedere?
 

 

 
Cita messaggio
#2
RISOLTO: mi rispondo da solo [img]images/smilies/blush.gif[/img]

era necessario aggiungere le seguenti opzioni alla riga di testo nel file fstab: _netdev,uid=1000,gid=users
Originario (errato):


Codice:
//percorso_rete /mnt/nome_locale cifs credentials=/home/nome_utente/.smbcredentials 0 0
Modificato:


Codice:
//percorso_rete /mnt/nome_locale cifs credentials=/home/nome_utente/.smbcredentials,_netdev,uid=1000,gid=users 0 0

Finalmente risolto  [img]images/smilies/at.gif[/img]
Grazie a tutti, ciao!
Cita messaggio
#3
Grazie per la soluzione.
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)