Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] INSTALLARE IL CATALYST ATI SU UBUNTU 12.10
#1
Come noto, con Ubuntu 12.10, IL SUPPORTO ALLE SCHEDE GRAFICHE ATI (proprio come la mia vecchia ATI HD 2600 PRO) E' STATO TOLTO.

Come fare per installare il CATALYST?

NIENTE DI PIU' SEMPLICE, BASTA DA TERMINALE DIGITARE:

sudo add-apt-repository ppa:makson96/fglrx
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install fglrx-legacy

RIAVVIARE ED IL GIOCO E' FATTO!

P.S.: è opportuno segnalare, per chi come me collega il TV al computer come doppio monitor, magari per godersi a schermo gigante lo streaming, che per non "impazzire con problemi di configurazione relativi alla risoluzione, è consigliabile utilizzare la HDMI piuttosto che il COMPOSITO. La risuluzione del catalyst è ottima: i1080.
La discarica é il mio negozio Hardware.

Motherboard: American Megatrends Inc. model P4i5G
Processor: Intel® Pentium® 4 CPU 3.00GHz 32biy H.T
RAM: DDR 2GBytes
Graphic: ATI 3650HD AGP
HDD: 250GByte ATA
WIFI: NETGER WG311v3
Cita messaggio
#2
Perchè non un semplice
Codice:
sudo apt-get install fglrx-updates
che sono i driver propritari presenti nei repo ufficiali di ubu?
Cita messaggio
#3
tumbler sai che non c'ho pensato! PROVERO'!
Cita messaggio
#4
Tumbler, ho provato come da te proposto. NEL MIO CASO (ATI HD2600 PRO) SPECIFICO, cioè nel caso in cui la propria scheda grafica NON ABBIA PIU' IL SUPPORTO ATI/AMD non funziona.
Il tuo metodo che fa riferimento ai drivers proprietari presenti nei reports ufficiali di ubuntu nel caso in oggetto, installa il CATALYST ma ovviamente non i drivers e quindi il sistema risponde con un errore.
PER CHI HA QUINDI UNA SCHEDA GRAFICA A CUI ATI/AMD HA TOLTO IL SUPPORTO, NON RESTA CHE UTILIZZARE IL METODO DA ME PROPOSTO PERCHE' RICORRE AD UN REPORT ESTERNO "ppa:makson96/fglrx".
La discarica é il mio negozio Hardware.

Motherboard: American Megatrends Inc. model P4i5G
Processor: Intel® Pentium® 4 CPU 3.00GHz 32biy H.T
RAM: DDR 2GBytes
Graphic: ATI 3650HD AGP
HDD: 250GByte ATA
WIFI: NETGER WG311v3
Cita messaggio
#5
(01-11-2012, 09:50 )cataldo72 Ha scritto: Come noto, con Ubuntu 12.10, IL SUPPORTO ALLE SCHEDE GRAFICHE ATI (proprio come la mia vecchia ATI HD 2600 PRO) E' STATO TOLTO.

Come fare per installare il CATALYST?

NIENTE DI PIU' SEMPLICE, BASTA DA TERMINALE DIGITARE:

sudo add-apt-repository ppa:makson96/fglrx
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install fglrx-legacy

RIAVVIARE ED IL GIOCO E' FATTO!

P.S.: è opportuno segnalare, per chi come me collega il TV al computer come doppio monitor, magari per godersi a schermo gigante lo streaming, che per non "impazzire con problemi di configurazione relativi alla risoluzione, è consigliabile utilizzare la HDMI piuttosto che il COMPOSITO. La risuluzione del catalyst è ottima: i1080.
ciao.io sulla mia plus9 perciò 12 04 e non 12 10 ho provato a fare quello che consigli tu,per cercare di far funzionare la mia scheda sapphire x 1950pro,che su windows vista che ho in dual boot con linux va che è una meravigliae invece sulla plus9,utilizzando giochi su zinga.com,è un vero disastro:lentissima,muovendo con il mouse lascia un sacco di linnee confuse prima di stabilizzare l'immagine,niente 3d.ma all'ultimo comando impartito da terminale mi da il messaggio impossibile trovare il pacchetto fglrx-legacy,ho comunque riavviato sperando...ma niente la scheda va come prima.cercando sul sito della amd sembrerebbe che il driver 9.3 sia quello adatto per la mia scheda ma non so come devo fare per istallarlo,sapresti aiutarmi?un po di tempo fa avevo chiesto aiuto sul forum riguardo ai problemi riscontrati con questa scheda ma la discussione si è fermata subito non avendo risposte,spero che questa volta vada meglio,altrimenti non mi resta che(aimè)utilizzare windows.salutoni.
Cita messaggio
#6
cataldo 72, dovresti informarti un po' prima di scrivere questi post. Finchè trovi nei repo di Ubuntu il pacchetto fglrx o fglrx-updates, sappi che i driver proprietari per la distro esistono ancora. Casomai puoi scaricarli tu direttamente dal sito della AMD. Così facendo scoprirai che i driver per la tua scheda esistono e sono i 12.4, anche se non ti so dire quale sarà il loro sviluppo, l'hardware è vecchiotto e quindi potrebbero non esserci ulteriori aggiornamenti. Tuttavia i 12.4 funzionano a dovere su Ubuntu 12.04, su Debian testing (tra poco stable) e su tutte le loro migliaia di derivate. Considerando che Precise Pangolin ha 5 anni di vita, direi che la tua scheda grafica può ancora aspettare per la pensione.

Inoltre l'installazione dei driver da PPA esterni mi sembra proprio una brutta idea, considerando che per vie ufficiali essi sono divulgati tranquillamente, a che da pppa esterni non si può mai essere certi della loro attendibilità o della gestione di eventuali aggiornamenti.
Cita messaggio
#7
(11-11-2012, 20:21 )Matteo Ha scritto: cataldo 72, dovresti informarti un po' prima di scrivere questi post. Finchè trovi nei repo di Ubuntu il pacchetto fglrx o fglrx-updates, sappi che i driver proprietari per la distro esistono ancora. Casomai puoi scaricarli tu direttamente dal sito della AMD. Così facendo scoprirai che i driver per la tua scheda esistono e sono i 12.4, anche se non ti so dire quale sarà il loro sviluppo, l'hardware è vecchiotto e quindi potrebbero non esserci ulteriori aggiornamenti. Tuttavia i 12.4 funzionano a dovere su Ubuntu 12.04, su Debian testing (tra poco stable) e su tutte le loro migliaia di derivate. Considerando che Precise Pangolin ha 5 anni di vita, direi che la tua scheda grafica può ancora aspettare per la pensione.

Inoltre l'installazione dei driver da PPA esterni mi sembra proprio una brutta idea, considerando che per vie ufficiali essi sono divulgati tranquillamente, a che da pppa esterni non si può mai essere certi della loro attendibilità o della gestione di eventuali aggiornamenti.
ciao.ti ringrazio per la risposta.abbi pazienza ma le mie capacità,riguardo linux,sono molto limitate,stò cercando di imparare qualcosa se riesco.dunque:da gestore pacchetti ho abilitato il pacchetto fglrx,ho avviato driver aggiuntivi e mi dice nessun driver proprietario in uso sul sistema,dal sito amd(lo avevo già visitato)seguendo le istruzioni mi manda ai driver 9.3 e non ai 12.4.ora se potessi aiutarmi te ne sarei grato come faccio ad individuare i 12.4 che dici essere quelli giusti,e quale è la procedura per istallarli una volta scaricati? di novo grazie.
Cita messaggio
#8
Dunque, per prima cosa non badare a quanto detta dal gestore Driver agguntivi, se per Driver Aggiuntivi hai qualche driver installato, allora sempre mediante Driver Aggiuntivi disattivalo. Poi, se hai installato il pacchetto fglrx rimuovilo e installa il pacchetto fglrx-updates. Riavvia avrai gli ultimi driver disponibili dai repo ufficiali per la tua scheda video.

I driver ati proprietari, per quel che ne so, supportano solo le schede della serie Radeon HD
Cita messaggio
#9
Che tradotto è quello che dicevo io ne 2° post ... la via migliore è

Codice:
sudo apt-get install fglrx-updates

Saluti
Cita messaggio
#10
(12-11-2012, 21:27 )Matteo Ha scritto: Dunque, per prima cosa non badare a quanto detta dal gestore Driver agguntivi, se per Driver Aggiuntivi hai qualche driver installato, allora sempre mediante Driver Aggiuntivi disattivalo. Poi, se hai installato il pacchetto fglrx rimuovilo e installa il pacchetto fglrx-updates. Riavvia avrai gli ultimi driver disponibili dai repo ufficiali per la tua scheda video.

I driver ati proprietari, per quel che ne so, supportano solo le schede della serie Radeon HD
ciao ho fatto come tu dici ma non ci sono stati miglioramenti.da impostazioni di sistema-dettagli-grafica mi da:driver esperienza standard,essi non dovrebbero chiamarsi con un nome contenente ati,catalist,o radeon?per sicurezza ho avviato gestore aggiornamenti ma premuto verifica mi dice di controllare la mia connessione ma essa va poichè riesco a navigare in internet anche velocemente,bo!(ho provato più volte).qualche idea?
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)