Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Installazione di Ubuntu 12.04 su BIOS UEFI
#1
Dopo molti tentennamenti ho deciso di cambiare computer perchè il vecchio Pentium 4 faticava molto a stare dietro a tre S.O. (W7, XP e Ubuntu) in dual (trial) boot.Confused
Lo studio sull'acquisto del nuovo è stato abbastanza accurato, anche perchè il computer non si cambia tutti i giorni ed io ho voluto prenderne uno che potesse reggere le continue evoluzioni tecnologiche per i prossimi 4 o 5 anni .Rolleyes
Morale ho preso una CPU Intel I5; una scheda madre ASUS P8Z77 e ho completato con un HD SSD da 128 Gb per gli SS.OO. (solo W7 e Ubuntu).At
Dopo aver messo a punto W7 con i programmi e le personalizzazioni stasera mi sono dedicato a Ubuntu.Wink Ho scaricato la Remix 9 a 64 bit (perchè prima usavo la 32 bit) ho fatto la masterizzazione su disco e poi per documentarmi un pò sono andato in giro per il Web per vedere se potevano esistere problemi al caricamento di Ubuntu.Huh Il dubbio mi era venuto perchè all'accensione del computer appare la schermata ASUS che mette in evidenza l' "UEFI BIOS" di cui ho voluto raccogliere qualche informazione e soprattutto qualche commento da parte di chi già utilizza questo innovativo strumento.arrossireLeggendo qua e la apprendo che la funzione EFI serve a salvaguardare la macchina da eventali caricamenti di S.O. non legali (questa è la versione di Microsoft che tiene a precisare che la funzione EFI non è opera sua ma dei produttori di hardware) Big Grinmentre la versione dei fautori del software libero è che EFI è l'ennesima mossa di Microsoft per arginare il diffondersi di S.O. liberi (vedi Ubuntu e altre distribuzioni)Basta. In sostanza stasera leggendo queste cose scopro un mondo nuovo di disinformazione e di battaglie che si combattono con ogni mezzo ma sempre a danno dei consumatori.Piange Mi ero abbastanza illuso leggendo che tutto sommato UEFI sarebbe stato implementato a partire dall'uscita di W8 e che probabilmente gli attuali BIOS UEFI davano ancora la possibilità di disabilitare la funzione "O.S. legacy". Mi sono perciò apprestato ad installare la 12.04 e, inizialmente come cosigliato dal Prof. Cantaro, ho avviato il CD in modalità live.Idea La grande sorpresa è stata che dopo la schermata iniziale lo schermo si è spento, il lettore di CD ha continuato a girare vorticosamente, come se stesse caricando, e alla fine ho dovuto resettare tutto e ripartire.Sfascio tutto Fortunatamente W7 è andato regolarmente e dopo una ulteriore ricerca su vari siti del settore e il controllo più accurato della mia pagina del BIOS, devo concludere che per il momento non ho speranze di poter installare Ubuntu perchè la funzione "O.S. legacy" non può essere disabilitata.Angry
Spero di aver fatto una ricostruzione abbastanza fedele e succinta della situazione e pertanto invito tutti coloro che hanno informazioni aggiornate sulla questione a farmi sapere e soprattutto a darmi qualche speranza sulla possibilità di utilizzare software libero sui computer che stanno diventando sempre più ermetici.Huh Quanto detto soprattutto alla luce del fatto che io ho anche aderito all'invito di spedire il suggerimento del software libero al governo per l'inserimento nella spending review.Arrendersi
Il post è stato molto lungo ma penso che l'argomento che tratta sia "rovente" perchè se non troverà una soluzione può mettere in discussione tutto il lavoro svolto per anni dagli sviluppatori di software libero.ArrendersiSleepy
Cita messaggio
#2
Credo che tu stia confondendo UEFI (o EFI) con SecureBoot che è una "impostazione" che troverà posto permanente negli UEFI da Windows 8 in poi.
Se SecureBoot è abilitato gli attuali sistemi operativi NON partono, nemmeno Windows 7 (forse parte Fedora 17); a proposito di Windows 7, ritengo che con il Service Pack 2 che prima o poi dovrà uscire, Microsoft incorporerà qualcosa per renderlo SecureBoot-compatibile (il SP2 di Win7 è dato in uscita per la primavera 2013, tuttavia potrebbe anche avvenire prima, bisogna vedere quante e quali "rogne" darà Windows 8 a Microsoft).

Prova a lanciare un live-CD Linux per vedere se funziona; Ubuntu 12.04 non è esattamente un sistema "legacy" (vecchio insomma!), mi sembra impossibile che non si installi; semmai vedi se nell'UEFI trovi la voce per disabilitare SecureBoot.

P.S.
potrebbe essere utile aggiornare il BIOS/EFI all'ultima versione disponibile
Il mio blog: http://zerozerocent.blogspot.it/
Legge di Murphy: SE QUALCOSA PUO' ANDAR MALE, LO FARA'
Cita messaggio
#3
se può interessare anch'io il mese scorso ho preso pc nuovo e mi sono trovato un problema simile. ho risolto entrando nel bios e nella sequenza di boot dove efi era al primo posto l'ho spostato al quarto dopo cd/dvd, hd,rete,efi. da me ha funzionato, se vuoi provare....
Cita messaggio
#4
(20-08-2012, 22:09 )BAT Ha scritto: Credo che tu stia confondendo UEFI (o EFI) con SecureBoot che è una "impostazione" che troverà posto permanente negli UEFI da Windows 8 in poi.
Se SecureBoot è abilitato gli attuali sistemi operativi NON partono, nemmeno Windows 7 (forse parte Fedora 17); a proposito di Windows 7, ritengo che con il Service Pack 2 che prima o poi dovrà uscire, Microsoft incorporerà qualcosa per renderlo SecureBoot-compatibile (il SP2 di Win7 è dato in uscita per la primavera 2013, tuttavia potrebbe anche avvenire prima, bisogna vedere quante e quali "rogne" darà Windows 8 a Microsoft).

Prova a lanciare un live-CD Linux per vedere se funziona; Ubuntu 12.04 non è esattamente un sistema "legacy" (vecchio insomma!), mi sembra impossibile che non si installi; semmai vedi se nell'UEFI trovi la voce per disabilitare SecureBoot.

P.S.
potrebbe essere utile aggiornare il BIOS/EFI all'ultima versione disponibile
Grazie Bat per avermi chiarito la differenza tra UEFI e SecureBoot.
Per seguire il tuo consiglio proverò a lanciare live una versione precedente di Ubuntu (la 11.04) considerando che l'ultima non parte. Infine proverò ad aggiornare il BIOS anche se l'acquisto risale a pochi giorni fa.Idea
Cita messaggio
#5
se segui anche il consiglio di dxgiusti non guasterebbe (modificando l'ordine di boot);

comunque mi sembra strano che la 11 parte e la 12 no... magari hai un DVD difettoso.
Il mio blog: http://zerozerocent.blogspot.it/
Legge di Murphy: SE QUALCOSA PUO' ANDAR MALE, LO FARA'
Cita messaggio
#6
(20-08-2012, 22:42 )dxgiusti Ha scritto: se può interessare anch'io il mese scorso ho preso pc nuovo e mi sono trovato un problema simile. ho risolto entrando nel bios e nella sequenza di boot dove efi era al primo posto l'ho spostato al quarto dopo cd/dvd, hd,rete,efi. da me ha funzionato, se vuoi provare....

Ringrazio anche te dxgiusti. Nella sequenza di boot nel mio BIOS esistono solo due voci: (in ordine) partenza da Lettore CD e a seguire da HD SSD. Non compaiono nè la rete nè EFI. Non hai altri suggerimenti?:confused2:
Cita messaggio
#7
(21-08-2012, 10:50 )BAT Ha scritto: se segui anche il consiglio di dxgiusti non guasterebbe (modificando l'ordine di boot);

comunque mi sembra strano che la 11 parte e la 12 no... magari hai un DVD difettoso.

Confermo quanto detto a dxgiusti sull'ordine di priorità per lancare i programmi. Inoltre il CD parte per poi bloccarsi alla prima schermata.
Ho ricontrollato il BIOS (che è aggirnato all'ultima versione 1504) e la funzione SecureBoot è presente ma non selezionabile e settata fissa su "disabled" (disabilitata); mentre la voce "O.S.type" ha due opzioni "W8 UEFI" e "other legacy e UEFI" (ovviamente settata sulla seconda).
La scelta di provare la 11.04 è perchè DVD e versione è stata già precedentemente installata su altro computer. Questo quindi esclude difetti di CD e di programma scaricato.
Mi si riaccendono le speranze di installare Ubuntu anche se per il momento sono ancora al palo.Blush In attesa di altri suggerimenti provo a scaricare la versione 12.04 che parte da USB.Fallita
Cita messaggio
#8
da quanto dici il pc è un assemblato e quindi senza nessun sistema preinstallato. hai configurato win tutto ok e funzionante a questo punto tocca ad ubu ma hai problemi. i problemi sono solo all'installazione su disco o all'avvio di ubu in modalità live?
Cita messaggio
#9
Io ho la scheda madre gigabyte con chipset Z77X e UEFI e funziona perfettamente ubuntu 12.04,aggiorna il bios della tua scheda madre al ultima versione.
Cita messaggio
#10
(21-08-2012, 13:57 )dxgiusti Ha scritto: da quanto dici il pc è un assemblato e quindi senza nessun sistema preinstallato. hai configurato win tutto ok e funzionante a questo punto tocca ad ubu ma hai problemi. i problemi sono solo all'installazione su disco o all'avvio di ubu in modalità live?

I problemi sono all'avvio in modalità live. Il monitor si spegne; il lettore CD continua a caricare ma non succede più nulla. Ieri ho atteso un'ora che finisse di caricare la versione 12.04 (sempre a monitor spento) perchè nei vari tentativi fatti sono riuscito a far partire la versione live del 11.10 (mi si erano riaccese le speranze). Sono ancora al palo perchè volevo installare l'ultima versione LST. Per quanto riguarda lo spegnimento del monitor in questo nuovo assemblato per la prima volta ho una scheda video dedicata (nel vecchio computer utilizzavo quella integrata nella scheda madre). Secondo te questo può comportare qualcosa? Sono molto confuso perchè i sintomi che registro sono in qualche modo contrastanti fra di loro inoltre sul vecchio computer tutto va alla grande.
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)