Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Installazione server lampp su ubuntu 14.04
#1
Buongiorno a tutti, spero sia questa la sezione adatta per postare il mio problema.
Utilizzo dalla sua uscita ubuntu 12.04 dove ho installato il server lampp seguendo la guida a questo link:
http://lug.uniroma2.it/2012/03/16/instal...ntu-11-10/
valida per la 11.04 ma anche per la 12.04, perché quello che mi interessa è avere la cartella www nella home senza problemi di permessi da aggiornare per velocità di lavoro (provo prima in locale e poi in rete i siti che realizzo).
Con la nuova versione 14.04 la cartella etc/apache2 (e probabilmente anche altri file) è completamente diversa e siccome non sono un drago in materia non so quale procedimento seguire e quali file di configurazione modificare per ottenere lo stesso risultato, avere cioè la cartella cui punta il locahost, www, nella home.
Qualcunoi può delucidarmi in materia?
Grazie per le eventuali risposte ed un caro saluto a tutti
Silvio
 

 

 
Cita messaggio
#2
ciao 
se puo esserti utile questa pagina, è in inglese però
http://www.enqlu.com/2014/04/how-to-inst...ux-in.html

 
Citazione: io sono quello che sono per merito di ciò che siamo tutti (Linux)
 
Cita messaggio
#3
Ti ringrazio ma è relativa a xampp mentre io vorrei installare il lampp secondo quelle caratteristiche.
Grazie per la risposta e un caro saluto
silvio
Cita messaggio
#4
Ho risolto smanettando un po'. Sicuramente per i più il problema sarà stato di facile soluzione ma per quelli come me che non sono proprio dei draghi e avessero lo stesso problema posto il procedimento che ho seguito per condividerlo perché è grazie alla condivisione che ho imparato quel poco che so.
Dunque il mio problema era di installare lampp su ubuntu 14.04 ma principalmente avere la cartella di root nella home per evitare tutti i problemi di permessi.

1- Ho installato il server Apache 2

sudo apt-get install apache2 

e verificato che tutto sia a posto con

http://localhost/

compare la pagina di presentazione!

2- Mi sono creato nella home la mia cartella di root:

mkdir /home/pippo/www

chiaramente sostituire il vostro nome utente a pippo!

3- Configuro apache per le mie esigenze:

apro con un editor di testo, ho usato pluma, il file apache2.conf:

sudo pluma /etc/apache2/apache2.conf

aperto cercare verso la fine le seguenti righe:

<Directory /var/www/>
    Options Indexes FollowSymLinks
    AllowOverride None
    Require all granted
</Directory>

sostituire <Directory /var/www/> con <Directory /home/pippo/www/>

in modo che diventi:

<Directory /home/pippo/www/>
    Options Indexes FollowSymLinks
    AllowOverride None
    Require all granted
</Directory>

4- Modifico adesso il file ports.conf

sudo pluma /etc/apache2/ports.conf

aperto modifico la riga:

Listen 80

con

Listen 127.0.0.1:80

5- Modifico adesso il file envvars

sudo pluma /etc/apache2/envvars

aperto cerco le righe:

export APACHE_RUN_USER=www-data
export APACHE_RUN_GROUP=www-data

e in ambedue al posto di www-data sostituisco il mio nome utente in modo che diventino così:

export APACHE_RUN_USER=pippo
export APACHE_RUN_GROUP=pippo

!!! Ricordare di sostituire pippo con il vostro nome utente!!!

6- Modifico ora il file 000-default.conf nella cartella sites-enabled

sudo pluma /etc/apache2/sites-enabled/000-default.conf

aperto cerco le righe:

ServerAdmin webmaster@localhost
    DocumentRoot /var/www/html

e sostituisco DocumentRoot /var/www/html con DocumentRoot /home/pippo/www im modo che diventi:

ServerAdmin webmaster@localhost
DocumentRoot /home/pippo/www

!!! Sostituire pippo!!!

7- Riavvio il server:

sudo /etc/init.d/apache2 restart

8- Installo PHP e MySQL

sudo apt-get install php5 libapache2-mod-php5 php5-gd php5-imagick php5-mcrypt php5-mysql php5-sqlite mysql-server

durante l'installazione ci verrà richiesta la password per l'utente root di MySQL

riavvio il server:

sudo /etc/init.d/apache2 restart

9- Installo PHPMyAdmin:

sudo apt-get install phpmyadmin

Durante l’installazione verrà richiesto il webserver su cui installare il programma. Scegliamo apache2 premendo Spazio e poi Invio. Rispondiamo inoltre “Sì” alla richiesta di “Configurare il database di phpmyadmin con dbconfig-common”.

PHPMyAdmin è ora accessibile puntando il browser all’indirizzo

http://localhost/phpmyadmin/

oppure direttamente dal menu ubuntu-programmazione


E' tutto, spero che sia utile per qualcuno.
Un caro saluto a tutti
Silvio

ps. per risolvere il mio problema sono partito dalla guida che ho trovato a questo link:

http://160.80.198.217/2012/03/16/install...ntu-11-10/

che chiaramente andava bene per precedenti versioni di ubuntu. (io utilizzo la fantastica versione Mint Qiana plus remix del prof Cantaro per il quale ogni ringraziamento e riconoscimento per il lavoro che fa è sempre poco!)
http://www.istitutomajorana.it/index.php...Itemid=245
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)