Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Installazione ubuntu. Windows xp riscrive grub.
#1
E' il mio primo post ed è doveroso fare i complimenti per questo bel forum.
Il mio problema è questo e si pone dopo aver concluso l'installazione di ubuntu su pc con windowx xp pro.

Viene creato il grub per il doppio avvio.
Scelgo di partire con ubuntu. Tutto OK.
Esco da ubuntu e rivvio per provare a passare a windows. Tutto OK.

Chiudo il pc o riavvio e qui arriva il problema. Sembra che windows xp abbia modificato il grub. Il pc inizia a looppare sul avvio, mostra la prima pagina del bios emette un bip e rilooppa sul bios, bip, bios, bip all'infinito. Non mostra nessun errore.

Per ripartire con gli OS ho usato i cd live Super Grub Disk e Rescatoux. I sistemi ripartono regolarmente. Al momento ho ripristinato l'MBR di windows xp con Rescatoux e windows riparte regolarmente.

Lo stesso problema si pone con utuntu 14.04, 13.10, 12.04. Da qui deduco che dipende dal PC. Provo su un altro PC, stessa storia.
Faccio le installazioni da DVD, con le versioni ufficiali, seguendo le semplici istruzioni che pone la procedura.
Qualcuno ha idea di cosa sta accadendo.

Grazie a chi mi potrà illuminare.

 

 

 
Albo Pretorio On Line per Joomla 1.5: http://valesweb.altervista.org
Cita messaggio
#2
Windows XP non riscrive l'MBR, è una cosa che fa solo durante l'installazione;
se hai il dubbio che riscriva allora c'è qualche processo che parte a sbafo, per esempio un virus o un crack di Windows stesso...

Controllare i processi che si avviano automaticamente in Windows (PARTE 1)
Controllare i processi che si avviano automaticamente in Windows (PARTE 2)

Un'altra possibilità sarebbe quella di una suite di sicurezza che rileva modifiche al MBR; in quel caso è teoricamente possibile che, una volta partito con Windows XP, parte la suite di sicurezza, verifica la modifica del MBR da parte di grub, lo interpreta erroneamente come l'azione di un virus e quindi provvede a sovrascriverlo col MBR di XP per correggere il problema.

 
Il mio blog: http://zerozerocent.blogspot.it/
Legge di Murphy: SE QUALCOSA PUO' ANDAR MALE, LO FARA'
Cita messaggio
#3
Fai quest aprova, entra in Ubuntu con Super grub disk, poi apri il Terminale e dai (uno alla volta), i due comandi:

[font]sudo grub-install /dev/sda[/font]

[font]sudo update-grub[/font]


 
Cita messaggio
#4
Ringrazio entrambi, BAT e l'Ing. Cantaro per le rapide risposte..
Per maggiori precisazioni informo che avevo eseguito una procedura di ripristino del grub con il CD Rescatoux. Il grub era stato ripristinato e funzionava, ma dopo l'esecuzione di windows il problema si è riposto come esposto nel primo post.
Attualmente ho preso qualche giorno di ferie. Appena rientro a lavoro eseguirò i controlli suggeriti da BAT e la procedura indicata dall'Ing. Cantaro.
Vi terrò informati sugli esiti.
 
Albo Pretorio On Line per Joomla 1.5: http://valesweb.altervista.org
Cita messaggio
#5
Ho eseguito le istruzioni dell'Ing. Cantaro, il grub è stato ripristinato ed ha funzionato. Ma si è riprodotto il problema, ovvero il lancio di ubuntu ha funzionato regolarmente, ma dopo il riavvio ed il lancio di windows che è partito normalmente al nuovo riavvio il computer a looppato sul bios.

Questi i messaggi apparsi durante il ripristino iniziale del grub, con le istruzioni Cantaro, e sembrano dare qualche indizio sul programma "ZISD" che viene citato:

xxxxxxxx@xxxxxxx-CELSIUS-W370:~$ sudo grub-install /dev/sda
[sudo] password for xxxxxxxx:
Installing for i386-pc platform.
grub-install: avviso: Il settore 5 è già in uso dal programma "ZISD", viene saltato. Questo software potrebbe causare problemi di avvio, o altri, nel futuro. Informare gli autori e avvisarli di non archiviare dati nell'intervallo del MBR..
Installazione completata, nessun errore segnalato.
xxxxxxxx@xxxxxxx-CELSIUS-W370:~$ sudo update-grub
Generating grub configuration file ...
Trovata immagine linux: /boot/vmlinuz-3.13.0-24-generic
Trovata immagine initrd: /boot/initrd.img-3.13.0-24-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
Trovato Microsoft Windows XP Professional su /dev/sda1
fatto
xxxxxxxx@xxxxxxx-CELSIUS-W370:~$

Ora controllerò i servizi come suggerito da BAT

 
Albo Pretorio On Line per Joomla 1.5: http://valesweb.altervista.org
Cita messaggio
#6
le macchine che ho utilizzato usano tutte novell per la rete aziendale e la causa potrebbe essere quella.

ho trovato questo articolo che porta in quella direzione

https://www.novell.com/communities/cools...-and-zisd/

 
Albo Pretorio On Line per Joomla 1.5: http://valesweb.altervista.org
Cita messaggio
#7
(28-04-2014, 08:04 )'vales' Ha scritto: grub-install: avviso: Il settore 5 è già in uso dal programma "ZISD", viene saltato. Questo software potrebbe causare problemi di avvio, o altri, nel futuro. Informare gli autori e avvisarli di non archiviare dati nell'intervallo del MBR..
 

 

Segui l'articolo per risolvere.
Giuseppe

 
Cita messaggio
#8
Ho risolto con un'altra modalità e tutto sembra funzionare magnificamente

Ho inserito in questa locazione del Registro di Sistema di windows xp
HKLM\Software\Novell\ZENworks
questo valore stringa
"ZISWIN Disabled" e gli ho assegnato il valore 1.
Avevo trovato le seguenti istruzioni per questo comando
"ZISWIN Disabled" - When this STRING VALUE is set to 1, ZISWIN will exit without doing any work.
Su questa guida
https://www.novell.com/support/kb/doc.php?id=3302285
a cui ero arrivato da qui
https://lists.ubuntu.com/archives/founda...37343.html

Grazie a tutti .

 
Albo Pretorio On Line per Joomla 1.5: http://valesweb.altervista.org
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)