Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] MySQL Query Browser
#1
salve,
nella 12.04 plus9 remix non trovo più "MySQL Query Browser" né
"MySQL Administrator".
Li ho comunque installati scaricando dalla rete
"mysql-gui-tools-5.0r12-linux-x86_64.tar.gz".

Ora, mentre "MySQL Administrator" funziona bene, "MySQL Query Browser" da questo errore:

"Could not connect to host 'localhost'.
MySQL Error Nr. 2002
Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)

Click the 'Ping' button to see if there is a networking problem."

il ping risponde bene.

qualche suggerimento?

grazie
danilo
Cita messaggio
#2
MySql server è installato e regolarmente avviato?
Ogni fallimento avvicina sempre più alla meta... Arrendersi subito equivale a non provare affatto.

Il bisogno di conoscere e scoprire, è la fiamma che alimenta la fornace che è il cervello umano.
Cita messaggio
#3
(09-05-2012, 13:24 )francater Ha scritto: MySql server è installato e regolarmente avviato?

grazie per la risposta tempestiva.

Si, MySql server è installato e regolarmente avviato:
MySQL Administrator dice che il server è attivo;
se lancio pgm che usano mysql, girano bene;
se lancio top vedo attivo mysqld dall'utente mysql.

danilo


Allegati Anteprime
   
Cita messaggio
#4
Guarda nel file di configurazione di Mysql, in /etc/mysql/my.cnf

All'interno ci dovrebbe essere una sezione tipo:

Codice:
[client]

port                     = 3306
socket                  = /var/run/mysqld/mysqld.sock

Dovrebbe essere la prima che incontri, se non c'è allora inseriscila tu.
Ogni fallimento avvicina sempre più alla meta... Arrendersi subito equivale a non provare affatto.

Il bisogno di conoscere e scoprire, è la fiamma che alimenta la fornace che è il cervello umano.
Cita messaggio
#5
(09-05-2012, 21:12 )francater Ha scritto: Guarda nel file di configurazione di Mysql, in /etc/mysql/my.cnf

All'interno ci dovrebbe essere una sezione tipo:

Codice:
[client]

port                     = 3306
socket                  = /var/run/mysqld/mysqld.sock

Dovrebbe essere la prima che incontri, se non c'è allora inseriscila tu.

OK,controllato:c'é.

riporto tutto il mio my.cnf
Citazione:#
# The MySQL database server configuration file.
#
# You can copy this to one of:
# - "/etc/mysql/my.cnf" to set global options,
# - "~/.my.cnf" to set user-specific options.
#
# One can use all long options that the program supports.
# Run program with --help to get a list of available options and with
# --print-defaults to see which it would actually understand and use.
#
# For explanations see
# http://dev.mysql.com/doc/mysql/en/server...ables.html

# This will be passed to all mysql clients
# It has been reported that passwords should be enclosed with ticks/quotes
# escpecially if they contain "#" chars...
# Remember to edit /etc/mysql/debian.cnf when changing the socket location.
[client]
port = 3306
socket = /var/run/mysqld/mysqld.sock

# Here is entries for some specific programs
# The following values assume you have at least 32M ram

# This was formally known as [safe_mysqld]. Both versions are currently parsed.
[mysqld_safe]
socket = /var/run/mysqld/mysqld.sock
nice = 0

[mysqld]
#
# * Basic Settings
#
user = mysql
pid-file = /var/run/mysqld/mysqld.pid
socket = /var/run/mysqld/mysqld.sock
port = 3306
basedir = /usr
datadir = /var/lib/mysql
tmpdir = /tmp
lc-messages-dir = /usr/share/mysql
skip-external-locking
#
# Instead of skip-networking the default is now to listen only on
# localhost which is more compatible and is not less secure.
bind-address = 127.0.0.1
#
# * Fine Tuning
#
key_buffer = 16M
max_allowed_packet = 16M
thread_stack = 192K
thread_cache_size = 8
# This replaces the startup script and checks MyISAM tables if needed
# the first time they are touched
myisam-recover = BACKUP
#max_connections = 100
#table_cache = 64
#thread_concurrency = 10
#
# * Query Cache Configuration
#
query_cache_limit = 1M
query_cache_size = 16M
#
# * Logging and Replication
#
# Both location gets rotated by the cronjob.
# Be aware that this log type is a performance killer.
# As of 5.1 you can enable the log at runtime!
#general_log_file = /var/log/mysql/mysql.log
#general_log = 1
#
# Error logging goes to syslog due to /etc/mysql/conf.d/mysqld_safe_syslog.cnf.
#
# Here you can see queries with especially long duration
#log_slow_queries = /var/log/mysql/mysql-slow.log
#long_query_time = 2
#log-queries-not-using-indexes
#
# The following can be used as easy to replay backup logs or for replication.
# note: if you are setting up a replication slave, see README.Debian about
# other settings you may need to change.
#server-id = 1
#log_bin = /var/log/mysql/mysql-bin.log
expire_logs_days = 10
max_binlog_size = 100M
#binlog_do_db = include_database_name
#binlog_ignore_db = include_database_name
#
# * InnoDB
#
# InnoDB is enabled by default with a 10MB datafile in /var/lib/mysql/.
# Read the manual for more InnoDB related options. There are many!
#
# * Security Features
#
# Read the manual, too, if you want chroot!
# chroot = /var/lib/mysql/
#
# For generating SSL certificates I recommend the OpenSSL GUI "tinyca".
#
# ssl-ca=/etc/mysql/cacert.pem
# ssl-cert=/etc/mysql/server-cert.pem
# ssl-key=/etc/mysql/server-key.pem



[mysqldump]
quick
quote-names
max_allowed_packet = 16M

[mysql]
#no-auto-rehash # faster start of mysql but no tab completition

[isamchk]
key_buffer = 16M

#
# * IMPORTANT: Additional settings that can override those from this file!
# The files must end with '.cnf', otherwise they'll be ignored.
#
!includedir /etc/mysql/conf.d/
Cita messaggio
#6
Modifica

/var/run/mysqld/mysqld.sock

in

/tmp/mysql.sock
Ogni fallimento avvicina sempre più alla meta... Arrendersi subito equivale a non provare affatto.

Il bisogno di conoscere e scoprire, è la fiamma che alimenta la fornace che è il cervello umano.
Cita messaggio
#7
(10-05-2012, 22:02 )francater Ha scritto: Modifica

/var/run/mysqld/mysqld.sock

in

/tmp/mysql.sock


Fatto, modificato in 3 righe, ma il risultato non cambia.
Cita messaggio
#8
Modificalo solo nella sezione client.
Ogni fallimento avvicina sempre più alla meta... Arrendersi subito equivale a non provare affatto.

Il bisogno di conoscere e scoprire, è la fiamma che alimenta la fornace che è il cervello umano.
Cita messaggio
#9
(12-05-2012, 14:23 )francater Ha scritto: Modificalo solo nella sezione client.

Non so perché, ma stamattina funziona tutto, senza ulteriori modifiche.
quindi metto il risolto.
grazioe.
Cita messaggio
#10
Forse mancava un riavvio?
Comunque meglio così.Exclamation
Ogni fallimento avvicina sempre più alla meta... Arrendersi subito equivale a non provare affatto.

Il bisogno di conoscere e scoprire, è la fiamma che alimenta la fornace che è il cervello umano.
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)