Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] NVIDIA 310.32 su Ubuntu 12.10 x64
#1
Buonasera a tutti.
Propongo, qui di seguito, una guida per installare i driver Nvidia 310.32 su Ubuntu 12.10. Ci tengo a dire che ho provato altre guide che si trovano sul web, ma senza risultato tranne che per un piccolo dettaglio che mostrerò in seguito.
1) Disinstallare eventuali driver Nvidia. Da terminale:
sudo apt-get remove nvidia*
2) uname -r (per vedere la versione del vostro kernel attuale. Il mio è
il 3.5.0-22, userò questo nella guida. Sostituitelo, nel comando, con la vostra versione.)
3) sudo apt-get install linux-source && sudo apt-get install linux-headers-3.5.0-22-generic (se sono già installati, il terminale ve lo dice).
Ora, ecco il dettaglio di cui parlavo sopra. Entrate nel terminale come root:
sudo -s
aprite nautilus e vi portate in etc/modprobe.d/blacklist.conf. Aprite il file e aggiungete le seguenti righe:
blacklist nouveau
options nouveau modeset=0
Salvate il file, chiudete tutto e riavviate. Avrete la schermata in bassa risoluzione. Da tastiera: CTRL+ALT+F3. Fate il login e inserite la password. Poi:
sudo service lightdm stop (Invio)
Quindi vi spostate nella cartella dove avete scaricato i driver di Nvidia col comando cd (ES. cd Scaricati). Quindi digitate
chmod +x NVIDIA-* (INVIO)
sudo sh NVIDIA-* (INVIO)
Rispondete "yes" a tutte le domande e alla fine riavviate con:
sudo reboot
Il dettaglio del file etc/modprobe.d/blacklist.conf è stato risolutore per me. L'ho trovato, pensate un pò!!!, su Wikipedia!!!. Nessun sito che ho visitato, ne parla. Spero che questo dettaglio possa servire a qualcuno.
Ciao a tutti!


Allegati Anteprime
   
Cita messaggio
#2
Grazie mille ha funzionato alla perfezione !
Cita messaggio
#3
(30-01-2013, 02:27 )carlo Ha scritto: Grazie mille ha funzionato alla perfezione !
Perfetto!, sono contento che ha funzionato!.
Ciaohttp://www.istitutomajorana.it/forum/images/smilies/lightbulb.gif
Cita messaggio
#4
Ho seguito la tua guida molto chiara, complimenti!

Ho Ubuntu 12.10 e ho l'esigenza di installare i driver Nvidia proprietari, al posto dei Nouveau (Gallium 0.4 on NV92), per far funzionare il simulatore di volo X-plane...
Tuttavia il mio PC non ne vuol sapere di funzionare con i driver proprietari; nemmeno dopo aver seguito la tua guida. In pratica, dopo aver eseguito la procedura, dopo il log-in (che sia Unity, Lxde, Gnome... ) l'interfaccia grafica non si avvia... si vede solo l'immagine di sfondo, e dopo un po' si blocca il PC. Al riavvio successivo, se, dopo il log-in, entro nell'interfaccia testuale/terminale (avviando comunque in background la GUI), al momento del blocco del PC mi viene segnalato un errore che riguarda il blocco del processore.. una roba del genere (vado a memoria):

Citazione:BUG: soft lockup - CPU#1 stuck for ***s! [xorg:***]

Non so cosa fare. Big Grin

Nelle versioni precedenti di Ubuntu (tipo 11.10), quando mi capitava di usare i driver Nvidia, cercavo di scegliere versioni vecchie (tipo la 173) e mi funzionavano... ora però non so come fare a mettere la 173 anche solo per provare... spero tu possa aiutarmi.

Grazie! Exclamation
Cita messaggio
#5
(04-02-2013, 20:06 )a.fantino Ha scritto: Ho seguito la tua guida molto chiara, complimenti!

Ho Ubuntu 12.10 e ho l'esigenza di installare i driver Nvidia proprietari, al posto dei Nouveau (Gallium 0.4 on NV92), per far funzionare il simulatore di volo X-plane...
Tuttavia il mio PC non ne vuol sapere di funzionare con i driver proprietari; nemmeno dopo aver seguito la tua guida. In pratica, dopo aver eseguito la procedura, dopo il log-in (che sia Unity, Lxde, Gnome... ) l'interfaccia grafica non si avvia... si vede solo l'immagine di sfondo, e dopo un po' si blocca il PC. Al riavvio successivo, se, dopo il log-in, entro nell'interfaccia testuale/terminale (avviando comunque in background la GUI), al momento del blocco del PC mi viene segnalato un errore che riguarda il blocco del processore.. una roba del genere (vado a memoria):

Citazione:BUG: soft lockup - CPU#1 stuck for ***s! [xorg:***]

Non so cosa fare. Big Grin

Nelle versioni precedenti di Ubuntu (tipo 11.10), quando mi capitava di usare i driver Nvidia, cercavo di scegliere versioni vecchie (tipo la 173) e mi funzionavano... ora però non so come fare a mettere la 173 anche solo per provare... spero tu possa aiutarmi.

Grazie! Exclamation


Aggiornamento: sono riuscito a installare i driver 173!!! Funzionano, ma Firefox, quando carica alcuni siti, si blocca momentaneamente (di continuo) ed è fastidiosissimo. Prima con i driver Nouveau non lo faceva, inoltre Chromium non ha questo problema nemmeno con i driver 'Proprietari.

C'è qualche soluzione per favore?

Ribadisco il fatto di dover usare la versione 173 per forza...
Cita messaggio
#6
(04-02-2013, 20:06 )a.fantino Ha scritto: Ho seguito la tua guida molto chiara, complimenti!

Ho Ubuntu 12.10 e ho l'esigenza di installare i driver Nvidia proprietari, al posto dei Nouveau (Gallium 0.4 on NV92), per far funzionare il simulatore di volo X-plane...
Tuttavia il mio PC non ne vuol sapere di funzionare con i driver proprietari; nemmeno dopo aver seguito la tua guida. In pratica, dopo aver eseguito la procedura, dopo il log-in (che sia Unity, Lxde, Gnome... ) l'interfaccia grafica non si avvia... si vede solo l'immagine di sfondo, e dopo un po' si blocca il PC. Al riavvio successivo, se, dopo il log-in, entro nell'interfaccia testuale/terminale (avviando comunque in background la GUI), al momento del blocco del PC mi viene segnalato un errore che riguarda il blocco del processore.. una roba del genere (vado a memoria):

Citazione:BUG: soft lockup - CPU#1 stuck for ***s! [xorg:***]

Non so cosa fare. Big Grin

Nelle versioni precedenti di Ubuntu (tipo 11.10), quando mi capitava di usare i driver Nvidia, cercavo di scegliere versioni vecchie (tipo la 173) e mi funzionavano... ora però non so come fare a mettere la 173 anche solo per provare... spero tu possa aiutarmi.

Grazie! Exclamation
Ciao!
mi spiace per questo tuo inconveniente.
Ho dato un'occhiata al comando che hai postato e ho trovato un forum in inglese http://ubuntuforums.org/showthread.php?t=1757773
Secondo me la procedura è un pò macchinosa e richiede una competenza superiore riguardo ubuntu (il problema riguarda il processore che si blocca). Veniamo al dunque. Sei certo di aver eseguito il tutto alla perfezione?. I driver si sono installati?. Se sei certo di queste cose, il mio suggerimento è quello di far partire il sistema con una LIVE CD di ubuntu. A quel punto apri il terminale (CTRL+ALT+T) ed elimini i driver nvidia (se sono installati) con:
sudo apt-get remove nvidia*
Poi, sempre nel terminale
sudo -s (password e ENTER). Poi digiti:
nautilus (e premi INVIO)
e vai in etc/modprobe.d/blacklist.conf. Apri il file e togli le righe che avevi aggiunto in precedenza:
blacklist nouveau
options nouveau modeset=0
Salva il file, chiudi tutto e riavvia.
In pratica ritorni alla condizione precedente all'installazione dei driver. A quel punto puoi scegliere se provare a reinstallare il tutto, oppure usare "software source" nella scheda "driver aggiuntivi", oppure ancora, usare i ppa dedicati di nvidia
(ppa:ubuntu-x-swat/x-updates). Se ti trovi in un vicolo cieco, allora, non impazzire, salva i tuoi dati e reinstalla il sistema. Non conosco l'hardware del tuo pc, però mi sembra di capire che hai diversi ambienti desktop. La mia esperienza in questi "multi-desktop", è negativa e ho optato per avere un solo desktop. Se voglio unity, installo ubuntu, se voglio Cinnamon, installo Mint e se voglio KDE-Plasma installo Kubuntu. Vedi tu, così ad intuito non mi sento di dirti altro. Fammi sapere
ciao Smile
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)