Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Permesso negato partizione secondaria dati
#1
Ciao a tutti. Ora vi espongo il mio problema. Ho installato ubuntu 11.10 creando 2 partizioni sciegliendo per entrambi il file system ext4. La prima è dedicata al sistema op. e la seconda ai dat.
Mi sono accorto però che la seconda partizione dove si trova una certa cartella denominata lost+found è inutilizzabile e non posso fare alcun tipo operazione (copia, spostamento file ecc...) e quando vado ad effettuarne una di queste mi dice permesso negato. Come posso dare tale permesso per sbloccare la seconda partizione che appare montata, ma è inutilizzabile? e Che cosa ho sbagliato in fase di installazione in riferimento alla seconda partizione dati che ho formattata con fyle system ext4? Spero che possiate risolvere questo problema.
Cita messaggio
#2
posta
Codice:
cat /etc/fstab
sudo fdisk -l
non è uno, ma elle
Un titolo ben azzeccato attira l'attenzione degli esperti in quel campo, fa risparmiare tempo a voi, aumenta la probabilità di successo.
Cita messaggio
#3
(06-02-2012, 15:44 )patel Ha scritto: posta
Codice:
cat /etc/fstab
sudo fdisk -l
non è uno, ma elle

1° comando
~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc nodev,noexec,nosuid 0 0
# / was on /dev/sda1 during installation
UUID=6fe11c35-3a88-47da-a13a-58bb8b5d2e19 / ext4 errors=remount-ro 0 1
# swap was on /dev/sda5 during installation
UUID=6f388bdf-7624-4a75-b6d7-0405b4b532e8 none swap sw 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0
2° comando
Disk /dev/sda: 250.1 GB, 250059350016 bytes
255 testine, 63 settori/tracce, 30401 cilindri, totale 488397168 settori
Unità = settori di 1 * 512 = 512 byte
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Identificativo disco: 0x00009ba1

Dispositivo Boot Start End Blocks Id System
/dev/sda1 * 2048 68360191 34179072 83 Linux
/dev/sda2 68362238 72321023 1979393 5 Esteso
/dev/sda3 72324630 488392064 208033717+ 83 Linux
/dev/sda5 68362240 72321023 1979392 82 Linux swap / Solaris


Cita messaggio
#4
Codice:
sudo mkdir /media/dati # crea la cartella di mount
sudo gedit /etc/fstab
aggiungi la riga
Codice:
/dev/sda3 /media/dati    ext4    defaults        0       2
salvi, esci e
Codice:
sudo mount -a

leggi anche http://wiki.ubuntu-it.org/Hardware/Dispo...Partizioni
Un titolo ben azzeccato attira l'attenzione degli esperti in quel campo, fa risparmiare tempo a voi, aumenta la probabilità di successo.
Cita messaggio
#5
(06-02-2012, 20:29 )patel Ha scritto:
Codice:
sudo mkdir /media/dati # crea la cartella di mount
sudo gedit /etc/fstab
aggiungi la riga
Codice:
/dev/sda3 /media/dati    ext4    defaults        0       2
salvi, esci e
Codice:
sudo mount -a

leggi anche http://wiki.ubuntu-it.org/Hardware/Dispo...Partizioni

al 2°comando
mi si apre gedit con delle scrite:
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc nodev,noexec,nosuid 0 0
# / was on /dev/sda1 during installation
UUID=6fe11c35-3a88-47da-a13a-58bb8b5d2e19 / ext4 errors=remount-ro 0 1
# swap was on /dev/sda5 during installation
UUID=6f388bdf-7624-4a75-b6d7-0405b4b532e8 none swap sw 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0

mentre nel terminale esce
(gedit:3188): Gtk-WARNING **: Attempting to store changes into `/root/.local/share/recently-used.xbel', but failed: Creazione del file "/root/.local/share/recently-used.xbel.U0HR9V" non riuscita: File o directory non esistente

(gedit:3188): Gtk-WARNING **: Attempting to set the permissions of `/root/.local/share/recently-used.xbel', but failed: File o directory non esistente

che devo fare?
Cita messaggio
#6
(06-02-2012, 20:57 )Franco Garni Ha scritto:
(06-02-2012, 20:29 )patel Ha scritto:
Codice:
sudo mkdir /media/dati # crea la cartella di mount
sudo gedit /etc/fstab
aggiungi la riga
Codice:
/dev/sda3 /media/dati    ext4    defaults        0       2
salvi, esci e
Codice:
sudo mount -a

leggi anche http://wiki.ubuntu-it.org/Hardware/Dispo...Partizioni

al 2°comando
mi si apre gedit con delle scrite:
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc nodev,noexec,nosuid 0 0
# / was on /dev/sda1 during installation
UUID=6fe11c35-3a88-47da-a13a-58bb8b5d2e19 / ext4 errors=remount-ro 0 1
# swap was on /dev/sda5 during installation
UUID=6f388bdf-7624-4a75-b6d7-0405b4b532e8 none swap sw 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0

mentre nel terminale esce
(gedit:3188): Gtk-WARNING **: Attempting to store changes into `/root/.local/share/recently-used.xbel', but failed: Creazione del file "/root/.local/share/recently-used.xbel.U0HR9V" non riuscita: File o directory non esistente

(gedit:3188): Gtk-WARNING **: Attempting to set the permissions of `/root/.local/share/recently-used.xbel', but failed: File o directory non esistente

che devo fare?


fatto permesso ancora negato Sad
Cita messaggio
#7
Credo tu debba impostare il permesso di Lettura e scrittura per il tuo User (ma non uso UBUNTU ornati da tanti anni, per cui non mi azzardo a dirti come fare: so farlo in altre "distro", ma può esser che, per UBUNTU, ti possa far sbagliare). Altri, sicuramente, ti indicheranno come devi fare.
[Immagine: http://www.pic4ever.com/images/2mpe5id.gif]Un poeta può sopravvivere a tutto tranne che ad un errore di stampa.(Andy Wahrol)
Cita messaggio
#8
sudo gedit /etc/fstab ## assicurati che la riga aggiunta sia scritta correttamente , non ammette il minimo errore.

dopodiche per montarla

mount /dev/sda3

I comandi diretti linux con la distribuzione non cambiano , sono sempre e tutti rigorosamente uguali, il problema Ubuntu o PcLinux non si pone proprio , linux è uno solo anche se le distro sono centinaia.
Cita messaggio
#9
hai aggiunto a fstab la riga che ti ho suggerito ?
posta
Codice:
cat /etc/fstab
hai creato la cartella /media/dati ?
Un titolo ben azzeccato attira l'attenzione degli esperti in quel campo, fa risparmiare tempo a voi, aumenta la probabilità di successo.
Cita messaggio
#10
(07-02-2012, 09:05 )patel Ha scritto: hai aggiunto a fstab la riga che ti ho suggerito ?
posta
Codice:
cat /etc/fstab
hai creato la cartella /media/dati ?
come potrai ben notare di seguito la cartella è stata creata e la riga è stata aggiunta

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc nodev,noexec,nosuid 0 0
# / was on /dev/sda1 during installation
UUID=6fe11c35-3a88-47da-a13a-58bb8b5d2e19 / ext4 errors=remount-ro 0 1
# swap was on /dev/sda5 during installation
UUID=6f388bdf-7624-4a75-b6d7-0405b4b532e8 none swap sw 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0
/dev/sda3 /media/dati ext4 defaults 0 2

Niente da fare. Apppena sposto il file mi dice errore durante la copia di.... permesso negato.
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)