Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO]Problema con apt-get autoremove su Debian
#1
Salve a tutti ho un problema su un Pc con Debian.
Ho installato il sistema operativo e poi ho eseguito gli aggiornamenti , adesso quando vado ad installare qualcosa il terminale mi restituisce questo messaggio:
I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
E poi tutta una serie di pacchetti , tra cui anche network-manager e molti file di gnome fondamentali per il sistema.
alla fine di tutto c'è:
Usare "apt-get autoremove" per rimuoverli.
Ora se uso quel comando mi elimina questi file fondamentali tra cui anche Xorg , mi è già successo ecco perchè lo dico e mi ritrovo con una distro praticamente da buttare.
Sapete come posso fare per risolvere per cortesia?
Grazie mille per le risposte
Cita messaggio
#2
salve
dovresti dare maggioi info... sopratutto che versione di debian usi?
comunque questo è un problema che può sorgere sopratutto con la testing
(attualmente "jessie") e può verificarsi anche con la stabile (wheezy) 
se vengono aggiunti repo testing...
se sei in testing ti conviene aggiornare con 



Codice:
aptitude safe-upgrade
con questa opzione sei più tarnquillo,l'aggiornamento avviene in modo sicuro ed eventuali pacchetti
che possono causare "danni" non vengono installati.
naturlamente ti sconsiglio vivamente di usare autoremove (o almeno prima che i pacchetti 
di cui ti viene chiesta la rimozione, non siano importanti.

 
Cita messaggio
#3
ciao Luciano hai ragione scusa , allora la Distro è Debian Testing "Jessie" infatti , si ho letto proprio ieri di usare il comando apt-get safe-upgrade per gli aggiornamenti , per il momento credo di aver risolto con il comando apt-get keep-all che a quanto ho capito mentiene i pacchetti installati senza eliminare nulla , non credo sia una soluzione ortodossa ma almeno non incasino tutto il sistema poi vedrò con i prossimi aggiornamenti se non mi crea problemi.
Io su uno dei miei pc ho installato Debian Wheezy 7.5 che credo sia la stable e non mi ha mai dato problemi di questo tipo.
Starò molto attento d'ora in poi con quel comando , ti ringrazio per l'aiuto vediamo come va nei prossimi giorni.
Cita messaggio
#4
ok... io con il safe upgrade non ho mai avuto problemi con le testing
apt-get keep-all non lo conosco, mi informerò...
con la stable non hai di questi problemi... proprio perchè è stabile Sad
Cita messaggio
#5
infatti userò sempre il safe-upgrade grazie ancora , cmq era aptitude keep-all quel comando
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)