Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Problema con driver ATI
#1
Sembra che tutto sia nato quando oggi sono stato indotto a fare pulizia con UBUNTU TWEAK da un post letto in internet.
Ebbene dopo aver riavviato il notebook mi rendo subito conto che CAIRO-DOCK non funziona più correttamente e non ho più le funzionalità avanzate di Compiz.
Inoltre nella CAIRO-DOCK principale c'è un avviso che recita: "Si è verificato un errore. Per ulteriori informazioni sull'errore avviare il gestore pacchetti tramite il menù richiamabile con un clic del tastro destro del mouse oppure dare il comando apt-get da terminale. Il messaggio di errore è: <<Errore: BrokenCount > 0>>. Di solityo questo significa che i pacchetti installati presentano delle dipendenze irrisolte."
 

 
Cita messaggio
#2
Allora ho cominciato a fare delle verifiche.

glxinfo | grep render
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
OpenGL renderer string: ATI Mobility Radeon HD 4500/5100 Series


Prima invece avevo il rendering. [img]images/smilies/biggrin.gif[/img]
Cita messaggio
#3
Ma soprattutto mi pare cdi capire che stia usando i driver OPEN, mentre non sono in grado nè di installare nè di disinstallare i driver proprietari che erano quelli prima attivi.
Cita messaggio
#4
inizia con :
sudo apt-get update
nel terminale e vedi cosa ti dice.
Cita messaggio
#5
potresti fornire maggiori info sulle caratteristiche del pc?
comunque vedi anche la guida seguente per installare i drivers catalyst, c'è anche spiegato come individuare
la scheda...
http://ubuntufast.blogspot.it/2013/01/ri...t-131.html

 
Cita messaggio
#6
Con una serie di mosse un po' troppo azzardate per un inesperto come me ho  disinstallato i driver ATI e sono ritornato al driver open generico; in sistema/dettagli/grafica risulta che Driver=Gallium 0.4 on AMD RV710 e Esperienza=Standard. Inoltre non c'è effettivamente traccia di driver ATI e del Catalyst Control Center.
Avevo tempo fa utilizzato questa configurazione grafica perché mi sembrava più stabile, ma purtroppo aveva il vizio di scaldare eccessivamente. Poi con qualche aggiornamento mi sono "ritrovato" con i driver ATI che erano diventati anch'essi stabili e li ho usati fino a questa mattina, prima del patatrac.


 
Cita messaggio
#7
(23-03-2014, 20:09 )'luciano' Ha scritto: potresti fornire maggiori info sulle caratteristiche del pc?
comunque vedi anche la guida seguente per installare i drivers catalyst, c'è anche spiegato come individuare
la scheda...
http://ubuntufast.blogspot.it/2013/01/ri...t-131.html

 
La mia scheda grafica è una HD finta serie 5xxx. Ho scoperto che in realtà è un modello della serie HD 4xxx che viene però indicato come HD 52xx. Sono andato avanti mesi prima di capirlo e quindi di usare i driver corretti.
La scheda grafica appartenendo alla serie HD 4xxx non viene più supportata da AMD.
Ho seguito le indicazioni del tuo link dando il comando sudo apt-get install fglrx-updates
e questo è il risultato:

Codice:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
I seguenti pacchetti saranno inoltre installati:
  fglrx-amdcccle-updates
I seguenti pacchetti NUOVI saranno installati:
  fglrx-amdcccle-updates fglrx-updates
0 aggiornati, 2 installati, 0 da rimuovere e 0 non aggiornati.
È necessario scaricare 60,2 MB di archivi.
Dopo quest'operazione, verranno occupati 168 MB di spazio su disco.
Continuare [S/n]? S
Scaricamento di:1 http://it.archive.ubuntu.com/ubuntu/ precise-updates/restricted fglrx-updates i386 2:13.125-0ubuntu0.0.1 [53,6 MB]
Scaricamento di:2 http://it.archive.ubuntu.com/ubuntu/ precise-updates/restricted fglrx-amdcccle-updates i386 2:13.125-0ubuntu0.0.1 [6605 kB]
Recuperati 60,2 MB in 1min 27s (687 kB/s)                                                                                
Selezionato il pacchetto fglrx-updates non precedentemente selezionato.
(Lettura del database... 365073 file e directory attualmente installati.)
Estrazione di fglrx-updates (da .../fglrx-updates_2%3a13.125-0ubuntu0.0.1_i386.deb)...
Selezionato il pacchetto fglrx-amdcccle-updates non precedentemente selezionato.
Estrazione di fglrx-amdcccle-updates (da .../fglrx-amdcccle-updates_2%3a13.125-0ubuntu0.0.1_i386.deb)...
Elaborazione dei trigger per ureadahead...
ureadahead will be reprofiled on next reboot
Elaborazione dei trigger per bamfdaemon...
Rebuilding /usr/share/applications/bamf.index...
Elaborazione dei trigger per desktop-file-utils...
Elaborazione dei trigger per gnome-menus...
Configurazione di fglrx-updates (2:13.125-0ubuntu0.0.1)...
update-alternatives: viene usato /usr/lib/fglrx/ld.so.conf per fornire /etc/ld.so.conf.d/i386-linux-gnu_GL.conf (i386-linux-gnu_gl_conf) in modalità automatica.
update-alternatives: attenzione: saltata la creazione di /usr/lib32/libaticalcl.so poiché il file /usr/lib32/fglrx/libaticalcl.so associato (del gruppo i386-linux-gnu_gl_conf) non esiste.
update-alternatives: attenzione: saltata la creazione di /usr/lib32/libaticalrt.so poiché il file /usr/lib32/fglrx/libaticalrt.so associato (del gruppo i386-linux-gnu_gl_conf) non esiste.
update-alternatives: attenzione: viene forzata l'installazione dell'alternativa /usr/lib/fglrx/ld.so.conf poiché il gruppo i386-linux-gnu_gl_conf è danneggiato.
update-alternatives: attenzione: saltata la creazione di /usr/lib32/libaticalcl.so poiché il file /usr/lib32/fglrx/libaticalcl.so associato (del gruppo i386-linux-gnu_gl_conf) non esiste.
update-alternatives: attenzione: saltata la creazione di /usr/lib32/libaticalrt.so poiché il file /usr/lib32/fglrx/libaticalrt.so associato (del gruppo i386-linux-gnu_gl_conf) non esiste.
update-alternatives: viene usato /usr/lib/fglrx/alt_ld.so.conf per fornire /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf (x86_64-linux-gnu_gl_conf) in modalità automatica.
update-initramfs: deferring update (trigger activated)
Loading new fglrx-updates-13.125 DKMS files...
First Installation: checking all kernels...
Building only for 3.2.0-60-generic-pae
Building for architecture i686
Building initial module for 3.2.0-60-generic-pae
Done.

fglrx_updates:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.2.0-60-generic-pae/updates/dkms/

depmod........

DKMS: install completed.
update-initramfs: deferring update (trigger activated)
Elaborazione dei trigger per bamfdaemon...
Rebuilding /usr/share/applications/bamf.index...
Configurazione di fglrx-amdcccle-updates (2:13.125-0ubuntu0.0.1)...
Elaborazione dei trigger per initramfs-tools...
update-initramfs: Generating /boot/initrd.img-3.2.0-60-generic-pae
Elaborazione dei trigger per libc-bin...
ldconfig deferred processing now taking place
Cita messaggio
#8
Citazione:
Ho seguito le indicazioni del tuo link dando il comando sudo apt-get install fglrx-updates
veramente il mio link punta all'installazione dei drivers proprietari [img]images/smilies/huh.gif[/img][img]images/smilies/huh.gif[/img]
Cita messaggio
#9
(28-03-2014, 09:32 )'luciano' Ha scritto:
Citazione:Ho seguito le indicazioni del tuo link dando il comando sudo apt-get install fglrx-updates
veramente il mio link punta all'installazione dei drivers proprietari [img]images/smilies/huh.gif[/img][img]images/smilies/huh.gif[/img]
 
Va bene ... il pacchetto fglrx-update installa i driver proprietari ATI patchati da Canonical ed inseriti nei repo di ubuntu ... in estrema ratio vanno scaricati dal sito AMD ed installati i binari.
Io da qualche tempo a questa parte trovo molto migliorati (in temini di temperature) i driver open ... non faccio un uso intensivo della GPU non essendo appassionato di videogame o videoedting.
 
Cita messaggio
#10
Dopo una serie infinita di tribolazioni, durante le quali mi sono ritrovato ad un certo punto anche un driver anonimo che graficamente era assai penalizzante, ho deciso di installare manualmente il file scaricato dal sito AMD nella versione per schede non più supportate.
Et voilà tutto è andato per il meglio. Ora sono ritornato ad avere un'interfaccia grafica 3D pienamente funzionante e un consumo ridotto (la ventola fa molto meno rumore) rispetto al driver open.
Quindi risolto!

Francamente non ho capito cosa sia successo. Certo è che non riuscivo più ad installare i driver tramite il gestore pacchetti perché sembra che mancasse una qualche libreria. Insomma c'era stato sicuramente dello scompiglio tra i file che è stato messo a posto con una installazione completa del CCC di ATI. Ho trovato utile questo riferimento esterno nella mia situazione.
Saluti
Marco
 
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)