Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Problemi audio acer aspire e driver realtek
#1
Ciao a tutti su una partizione del HHD ho installato 12.04 LTS remix9
il problema è il seguente:
sento l'audio dalle cuffie ma appena le tolgo non lo sento dalle casse

con 10.04 lts che ho nell'altra partizione nessun problema

ho smanettato con i vari volumi ma niente

qualcuno mi può aiutare?

ovviamente non è un problema di codec non sento neanche i suoni di prova quando faccio il test
dopo aver consultato vari forum ho trovato questa guida

http://www.supernerd.it/2012/05/29/ubun ... e-realtek/

l'ho seguita fino in fondo ma non ho ottenuto risultati
potreste darmi una mano a capire se ho eseguito le procedure esatte

o eventualmente a tornare ai settaggi iniziali

il modello del pc è acer aspire 5935 g

grazie a tutti
Cita messaggio
#2
Prova a cambiare con opzione

options snd_hda_intel model=acer-aspire-4930g

Come specificato in questa discussione

http://forum.ubuntu-it.org/viewtopic.php?f=47&t=531763

Cita messaggio
#3
(22-08-2012, 18:24 )brunik Ha scritto: Prova a cambiare con opzione

options snd_hda_intel model=acer-aspire-4930g

Come specificato in questa discussione

http://forum.ubuntu-it.org/viewtopic.php?f=47&t=531763


grazie brunik
purtoppo non cambia nulla
Cita messaggio
#4
entra con la 10.04, apri il terminale e dai il comando: sudo lshw -c multimedia
posta il risultato.

entra con la 12.04 e fai la stessa cosa.
 Trasferito sul Nuovo Forum [img]images/smilies/blush.gif[/img]
Cita messaggio
#5
con lts 10.04

Codice:
ct: 82801I (ICH9 Family) HD Audio Controller
       vendor: Intel Corporation
       physical id: 1b
       bus info: pci@0000:00:1b.0
       version: 03
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=HDA Intel latency=0
       resources: irq:22 memory:eb700000-eb703fff

con lts 12.04

Codice:
*-multimedia            
       description: Audio device
       product: 82801I (ICH9 Family) HD Audio Controller
       vendor: Intel Corporation
       physical id: 1b
       bus info: pci@0000:00:1b.0
       version: 03
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=snd_hda_intel latency=0
       resources: irq:49 memory:eb700000-eb703fff
Cita messaggio
#6
(27-08-2012, 19:35 )Muttley Ha scritto: con lts 10.04
configuration: driver=HDA Intel latency=0


con lts 12.04
configuration: driver=snd_hda_intel latency=0

sembrebbe che usino due tipologie di driver diverse; gli snd_hda_intel sono i più recenti, forse non è detto che funzionino col tuo hardware. in questo momento sono logato con fedora, dovresti controllare in synaptic (dalla 12.04) se è disponibile il driver hda intel. fammi sapere. ciao
 Trasferito sul Nuovo Forum [img]images/smilies/blush.gif[/img]
Cita messaggio
#7
(29-08-2012, 17:05 )giuscassr Ha scritto: sembrebbe che usino due tipologie di driver diverse; gli snd_hda_intel sono i più recenti, forse non è detto che funzionino col tuo hardware. in questo momento sono logato con fedora, dovresti controllare in synaptic (dalla 12.04) se è disponibile il driver hda intel. fammi sapere. ciao

scusa ma mi sono un po perso...
i pacchetti che mi servivano non li avevo scaricati con i driver dal sito realtek?
http://www.supernerd.it/2012/05/29/ubun ... e-realtek/


comunque da gestore pacchetti


Allegati Anteprime
   
Cita messaggio
#8
hai ragione tu, ho controllato e il pacchetto è unico e già inglobato nel kernel.

da quanto vedo dal comando lista hardware limitata a multimedia (lshw -c multimedia) hai una componente audio della intel. i driver quindi mi sembrano giusti.

riprendendo il suggerimento di brunik, avendo tu un 5935 avresti dovuto correggere in snd_hda_intel model=acer-aspire-5935g
hai inserito così?
 Trasferito sul Nuovo Forum [img]images/smilies/blush.gif[/img]
Cita messaggio
#9
purtroppo non cambia nulla
puoi controllare che non abbia sbagliato qualcosa?

Codice:
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2
snd_hda_intel model=acer-aspire-5935g

e salvo nella cartella modprobe.d


Allegati Anteprime
   
Cita messaggio
#10
prova ad anteporre la parola options così:
options snd_hda_intel model=acer-aspire-5935g

il file dovrebbe chiamarsi alsa-base.conf ed essere dentro la cartella modprobe.d
 Trasferito sul Nuovo Forum [img]images/smilies/blush.gif[/img]
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)