Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] RE.: SWAP DISATTIVATA
#1
Recentemente ho modificato le partizioni del mio HD.
La situazione iniziale era data da una partizione  primaria con Ubuntu 12.04 e una partizione estesa con all'interno una logica con Ubuntu 13.10 e la partizione di SWAP (penso e spero di ricordarmi correttamente questa situazione...).
Ho formattato estesa creandone due primarie, una con filesystem NTFS per l'archiviazione dei dati ed una di SWAP.
Mi accorgo adesso che la partizione di SWAP all'avvio del sistema non è attiva.
Pulsante destro => attiva SWAP e la partizione viene attivata, ma quando riavvio il sistema la partizione di SWAP è nuovamente disattivata.
Del resto il mio sistema è diventato instabile e molto lento....
L'instabilità e la lentezza penso possano essere dovute alla partizione di SWAP ma francamente non saprei come porre rimedio...
Navigano ho trovato che la partizione di SWAP viene attivata all'avvio attraverso il file /etc/fstab. Il mio file /etc/fstab attualmente si presenta cosi:



Codice:
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc nodev,noexec,nosuid 0 0
# / was on /dev/sda1 during installation
UUID=547caf9a-b67b-4a59-8913-8e52c56465cf / ext4 errors=remount-ro 0 1
# swap was on /dev/sda5 during installation
UUID=4769c9f2-0fac-403d-a9c6-4844cd846e5d none swap sw 0 0

si direbbe che è ancora settato sulla partizione vecchia.
Allego anche la schermata di Gparted
grazie
matteo

 

 

 

 


Allegati Anteprime
   
Cita messaggio
#2
Digita in un terminale
sudo blkid
copi l'indirizzo UUID della swap
e lo incolli nel file
gksudo gedit /etc/fstab
Giuseppe
Cita messaggio
#3
perfetta l'indicazione di giuseppe, correggi la stringa uuid presente nel fstab, salva prima di uscire.
Cita messaggio
#4
Grazie.... puntuali e precisi come al solito....
ho eseguito i comandi che mi avete indicato.
Ho riavviato il sistema e la partizione si SWAP è attiva.
grazie ancora
matteo
 
Cita messaggio
#5
Bene,
ora, per cortesia, modifica il titolo del primo post anteponendo [RISOLTO], grazie.
Giuseppe
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)