Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Scheda video
#1
Buonasera dopo essere riusito ad installare ubuntu puls ho avuto da subito, dei problemi
con la scheda video. Nulla di disastroso però il puntatore del muse lascia delle scie, lo
scorrimento delle pagine su firefo non è lineare e avvolte si formano dei rettanglini neri,
nelle interfacce grafiche dei programmi prima di vedere i pusanti devo passarci sopra
con il muse ho provato sia i drivers proprietari che non ma non cambia nulla. Come scheda grafica ho
una ati radeon HD 7870, ho scaricato i drivers dal sito AMD per linux ma olre a metterci
un'eternità ad esegire lo script mi da erroe e si blocca.
Potete darmi qualche aiuto?
 

 

 

 

 
Cita messaggio
#2
Sposto nella sezione:

Personalizzazioni, Aspetto, Driver
Cita messaggio
#3
prima di tutto bisogna vedere quali driver ha caricato il kernel; posta il risultato del seguente comando:
sudo lshw -c display

ciao
 Trasferito sul Nuovo Forum [img]images/smilies/blush.gif[/img]
Cita messaggio
#4
Buongiorno ecco il risultato del comando

 physical id: 0
       bus info: pci@0000:01:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
       configuration: driver=radeon latency=0
       resources: irq:46 memory:c0000000-cfffffff memory:d0000000-d003ffff ioport:e000(size=256) memory:d0040000-d005ffff
  *-display
       description: VGA compatible controller
       product: Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 06
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:47 memory:d0400000-d07fffff memory:b0000000-bfffffff ioport:f000(size=64)
lucas@lucas-Z87X-D3H:~$


 

 
Cita messaggio
#5
Nessuna idea?

 
Cita messaggio
#6
allora, l'esito del comando è incompleto, mancano le prime righe, tuttavia dalla parte che hai messo vedo che ancora sono usati i driver radeon che sono quelli open (configuration: driver=radeon), quindi non sono installati/utilizzati i driver proprietari.

premesso che non ho ati nel mio portatile e che sarebbe opportuno l'intervento di qualche altro membro con esperienza personale diretta sulla materia, posso portarti alcuni esempi/guide trovate in rete che mi sembrano complete e pertinenti:
per 14.04: http://www.chimerarevo.com/linux/guida-u...6/#/driver
dal wiki di ubuntu: https://help.ubuntu.com/community/BinaryDriverHowto/AMD
amd catalyst install: http://www.thefanclub.co.za/how-to/ubunt...st-install
smanettando sulla configurazione della scheda grafica si corrono diversi rischi, fra cui quello della schermata nera all'avvio; salva i dati che ti interessano altrove, tieni a portata di mano una chiavetta live per avviare il pc e poter trovare soluzioni in rete.

ciao
 Trasferito sul Nuovo Forum [img]images/smilies/blush.gif[/img]
Cita messaggio
#7
Buongiorno ho seguito le guide che mi ai dato ma non sono riuscito a risolvere
il problema, ho scaricato i driver da sito di amd ma durante l'installazione mi
da errore e al riavvio del computer ubuntu non si avvia più.
Riposto il risultato del comando che mi hai dato questa volta completo
forse può essere importante.
P.S. Ho appena reinstallato ubuntu.

*-display               
       description: VGA compatible controller
       product: Pitcairn XT [Radeon HD 7870 GHz Edition]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
       configuration: driver=radeon latency=0
       resources: irq:46 memory:c0000000-cfffffff memory:d0000000-d003ffff ioport:e000(size=256) memory:d0040000-d005ffff
  *-display
       description: VGA compatible controller
       product: Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 06
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:47 memory:d0400000-d07fffff memory:b0000000-bfffffff ioport:f000(size=64)
Lucas@Lucas:~$

 

 
Cita messaggio
#8
ma in driver aggiuntivi non ti fa vedere gli amd proprietari installabili? così: http://i2.wp.com/www.chimerarevo.com/wp-...er-AMD.png
 
 Trasferito sul Nuovo Forum [img]images/smilies/blush.gif[/img]
Cita messaggio
#9
Sì ma non funziona, con una delle due scelte (la seconda opzione ) se non sbaglio
Al successivo avio si blocca durante il caricamento del sistema operativo
Con La terza invece non cambia nulla presenta gli stessi difetti

 
Cita messaggio
#10
ascolta, metti la terzi scelta (solo fglrx) e riavvia,
se continua a fare il problema ridai da terminale il comando sudo lshw -c display, se vedi che i radeon sono ancora caricati, proviamo a metterli in blacklist:
sudo gedit /etc/modprobe.d/blacklist.conf
e alla fine del file aggiungi:
blacklist radeon
salva, chiudi e riavvia.
se continua a fare il problema, ridai il comando sudo lshw -c display e controlla quali sono i driver caricati per la scheda amd, dopodichè riposta che vediamo cosa fare....
 Trasferito sul Nuovo Forum [img]images/smilies/blush.gif[/img]
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)