Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Scheda wifi
#1
Salve a tutti,
ho da poco installato sul mio portatile,un HP Pavilion zv6000, Ubuntu 11.04 ma ho riscontrato problemi con la scheda wifi interna e con la connessione Lan, le quali non funzionano. Però riesco a connettermi con una chiavetta wifi usb. Digitando da terminale il comando iwconfig mi restituisce il seguente output:

lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11bg ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=0 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:off

wlan1 IEEE 802.11bg ESSID:"linksys"
Mode:Managed Frequency:2.462 GHz Access Point: 00:18:F8:42:15:E9
Bit Rate=48 Mb/s Tx-Power=20 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:off
Link Quality=67/70 Signal level=-43 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:144 Invalid misc:3127 Missed beacon:0


Potrebbe essere un problema di drivers?
Grazie in anticipo Rolleyes
Cita messaggio
#2
Ti sposto la questione in una Sezione più appropriata del Forum. Così, potrai ricever più risposte adeguate e competenti.
[Immagine: http://www.pic4ever.com/images/2mpe5id.gif]Un poeta può sopravvivere a tutto tranne che ad un errore di stampa.(Andy Wahrol)
Cita messaggio
#3
11.04 è oramai tristemente famoso per le conflittualità con schede video e wi-fi; probabilmente è un problema di driver.
posta il risultato di sudo lshw -c network
ciao
 Trasferito sul Nuovo Forum [img]images/smilies/blush.gif[/img]
Cita messaggio
#4
(10-10-2011, 20:37 )giuscassr Ha scritto: 11.04 è oramai tristemente famoso per le conflittualità con schede video e wi-fi; probabilmente è un problema di driver.
posta il risultato di sudo lshw -c network
ciao
ecco il risultato del comando sudo lshw -c network
*-network:0
description: Network controller
product: BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller
vendor: Broadcom Corporation
physical id: 2
bus info: pci@0000:03:02.0
version: 02
width: 32 bits
clock: 33MHz
capabilities: bus_master
configuration: driver=b43-pci-bridge latency=64
resources: irq:9 memory:b0204000-b0205fff
*-network:1
description: Ethernet interface
product: RTL-8139/8139C/8139C+
vendor: Realtek Semiconductor Co., Ltd.
physical id: 6
bus info: pci@0000:03:06.0
logical name: eth0
version: 10
serial: 00:0f:b0:b9:44:57
size: 10Mbit/s
capacity: 100Mbit/s
width: 32 bits
clock: 33MHz
capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=8139too driverversion=0.9.28 duplex=half latency=128 link=no maxlatency=64 mingnt=32 multicast=yes port=MII speed=10Mbit/s
resources: irq:22 ioport:a000(size=256) memory:b020a400-b020a4ff
*-network:0 DISABLED
description: Wireless interface
physical id: 3
logical name: wlan0
serial: 00:14:a5:27:f9:db
capabilities: ethernet physical wireless
configuration: broadcast=yes driver=b43 driverversion=2.6.38-12-generic firmware=N/A link=no multicast=yes wireless=IEEE 802.11bg
*-network:1
description: Wireless interface
physical id: 4
bus info: usb@1:5
logical name: wlan1
serial: 00:02:72:74:26:e1
capabilities: ethernet physical wireless
configuration: broadcast=yes driver=rtl8187 driverversion=2.6.38-12-generic firmware=N/A ip=192.168.1.102 link=yes multicast=yes wireless=IEEE 802.11bg
GRAZIE MILLE.
Cita messaggio
#5
(11-10-2011, 09:22 )mapacoorato Ha scritto: ecco il risultato del comando sudo lshw -c network
*-network:0
description: Network controller
product: BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller
vendor: Broadcom Corporation
physical id: 2
bus info: pci@0000:03:02.0
version: 02
width: 32 bits
clock: 33MHz
capabilities: bus_master
configuration: driver=b43-pci-bridge latency=64
resources: irq:9 memory:b0204000-b0205fff

*-network:0 DISABLED
description: Wireless interface
physical id: 3
logical name: wlan0
serial: 00:14:a5:27:f9: db
capabilities: ethernet physical wireless
configuration: broadcast=yes driver=b43 driverversion=2.6.38-12-generic firmware=N/A link=no multicast=yes wireless=IEEE 802.11bg

GRAZIE MILLE.
Prima di tutto controlla se hai un tasto sul pc per attivare la scheda wi-fi. Se non ce l'hai o non funziona, apri il terminale e digita (dopo il $) sudo ifconfig wlan0 up, dai invio, digita la password completa anche se sembra che non la scrive, dai invio.
Se la scheda wifi interna ancora non funziona, digita sudo rfkill unblock all.
Fammi sapere. Ciao
 Trasferito sul Nuovo Forum [img]images/smilies/blush.gif[/img]
Cita messaggio
#6
@giuscassr,ma natty ha problemi pure con le broadcom???quelle schede vanno benissimo su linux,una delle poche che non danno problemi!!!comunque,vai su sistema amministrazione e driver aggiuntivi hardware,ti dovrebbe trovare il driver b43,lo installi e vai!....di solito o.O
ps ho appena notato che il driver è installato...a questo punto bisogna abilitarla,segui le indicazioni di giucassrs e ignora le mie.anzi,installa ubuntu lucid 10.04 e vai tranquillo.
saluti.
Cita messaggio
#7
(11-10-2011, 19:34 )Marcool Ha scritto: @giuscassr,ma natty ha problemi pure con le broadcom???quelle schede vanno benissimo su linux,una delle poche che non danno problemi!!!comunque,vai su sistema amministrazione e driver aggiuntivi hardware,ti dovrebbe trovare il driver b43,lo installi e vai!....di solito o.O
ps ho appena notato che il driver è installato...a questo punto bisogna abilitarla,segui le indicazioni di giucassrs e ignora le mie.anzi,installa ubuntu lucid 10.04 e vai tranquillo.
saluti.
Marcool, pensavo ad un problema di driver (molto frequente con 11.04 - Natty), poi l'output di lshw mi ha fatto eliminare il pensiero, come hai visto anche tu, infatti ho evidenziato in blu il tipo di scheda e i driver installati. Invece ho segnato in rosso il fatto che era disabilitata la scheda. Ciao Smile

 Trasferito sul Nuovo Forum [img]images/smilies/blush.gif[/img]
Cita messaggio
#8
(11-10-2011, 18:40 )giuscassr Ha scritto:
(11-10-2011, 09:22 )mapacoorato Ha scritto: ecco il risultato del comando sudo lshw -c network
*-network:0
description: Network controller
product: BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller
vendor: Broadcom Corporation
physical id: 2
bus info: pci@0000:03:02.0
version: 02
width: 32 bits
clock: 33MHz
capabilities: bus_master
configuration: driver=b43-pci-bridge latency=64
resources: irq:9 memory:b0204000-b0205fff

*-network:0 DISABLED
description: Wireless interface
physical id: 3
logical name: wlan0
serial: 00:14:a5:27:f9: db
capabilities: ethernet physical wireless
configuration: broadcast=yes driver=b43 driverversion=2.6.38-12-generic firmware=N/A link=no multicast=yes wireless=IEEE 802.11bg

GRAZIE MILLE.
Prima di tutto controlla se hai un tasto sul pc per attivare la scheda wi-fi. Se non ce l'hai o non funziona, apri il terminale e digita (dopo il $) sudo ifconfig wlan0 up, dai invio, digita la password completa anche se sembra che non la scrive, dai invio.
Se la scheda wifi interna ancora non funziona, digita sudo rfkill unblock all.
Fammi sapere. Ciao
Ciao giuscassr
ho digitato da terminale il comando sudo ifconfig wlan0 up ed ecco cosa mi ha restituito:
SIOCSIFFLAGS: File o directory non esistente
ho provato anche con sudo rfkill unblock all non restituisce nessun messaggio di errore ma comunque non succede nulla.
ho ridigitato sudo lshw -c network
*-network:0
description: Network controller
product: BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller
vendor: Broadcom Corporation
physical id: 2
bus info: pci@0000:03:02.0
version: 02
width: 32 bits
clock: 33MHz
capabilities: bus_master
configuration: driver=b43-pci-bridge latency=64
resources: irq:9 memory:b0204000-b0205fff
*-network:1
description: Ethernet interface
product: RTL-8139/8139C/8139C+
vendor: Realtek Semiconductor Co., Ltd.
physical id: 6
bus info: pci@0000:03:06.0
logical name: eth0
version: 10
serial: 00:0f:b0:b9:44:57
size: 10Mbit/s
capacity: 100Mbit/s
width: 32 bits
clock: 33MHz
capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=8139too driverversion=0.9.28 duplex=half latency=128 link=no maxlatency=64 mingnt=32 multicast=yes port=MII speed=10Mbit/s
resources: irq:22 ioport:a000(size=256) memory:b020a400-b020a4ff
*-network:0 DISABLED
description: Wireless interface
physical id: 3
logical name: wlan0
serial: 00:14:a5:27:f9:db
capabilities: ethernet physical wireless
configuration: broadcast=yes driver=b43 driverversion=2.6.38-12-generic firmware=N/A link=no multicast=yes wireless=IEEE 802.11bg
*-network:1
description: Wireless interface
physical id: 4
bus info: usb@1:5
logical name: wlan1
serial: 00:02:72:74:26:e1
capabilities: ethernet physical wireless
configuration: broadcast=yes driver=rtl8187 driverversion=2.6.38-12-generic firmware=N/A ip=192.168.1.102 link=yes multicast=yes wireless=IEEE 802.11bg.

In merito al tasto sul pc esite ed è attivo ho provato a spegnerlo e mi disattiva sia il bluetooth sia la connessione wifi USB (wlan1).
Esiste qualche altro comando? grazie ancora
Cita messaggio
#9
Ciao a tutti dopo aver digitato da terminale i seguenti comandi per installazione driver (anche se risultavano già istallati) il wifi interno ha cominciato a funzionare:
sudo apt-get install b43-fwcutter
sudo apt-get install firmware-b43legacy-installer
.
Ringrazio comunque tutti voi per la disponibilità, spero che questo post possa essere di aiuto a qualcuno.
Grazie Rolleyes
Cita messaggio
#10
Strano, non l'avrei detto, visto che i driver erano installati. Comunque meglio così.
Grazie a te.
Ciao
 Trasferito sul Nuovo Forum [img]images/smilies/blush.gif[/img]
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)