Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Schermo nero dopo installazione driver Nvidia 331
#1
Sad 
Salve a tutti, come da titolo dopo aver installato i driver Nvidia
ora dopo il grub lo schermo rimane nero...

Laptop Dell XPS, Ubuntu 13.10 Plus, scheda video Nvidia GT550.
Ho installato da terminale, seguendo un altro post del forum, così:
sudo add-apt-repository ppa: xorg-edgers/ppa
sudo apt-get update
sudo apt-get install nvidia-331
dopo, con dkms status, mi dava tutto regolarmente installato.
Al reboot schermo nero.

Come posso risolvere?
Grazie per l'aiuto
 

 

 
Cita messaggio
#2
Visto che la 13.10 tra poco non sarà più supportata ti consiglio di installare la nuova 14.04 plus lts supportata per cinque anni, per mantenere le tue impostazioni, posta ecc ecc è sufficiente, quando sei in live, copiare e incollare l'utente dalla home vecchia in quella nuova, queste operazioni vanno fatte in live, se vuoi anche sistemare il partizionamento questa è un'ottima guida:
http://www.istitutomajorana.it/index.php...&Itemid=33
Non sono riuscito a capire se hai una sola scheda video o intel+nvidia, dopo l'installazione se hai solo la nvidia ti conviene installare i driver proprietari consigliati mentre se sono due allora serve bumblebee:
http://www.linuxmind-italia.org/index.php?topic=12042.0
Giuseppe

 
Cita messaggio
#3
La scheda video è abbastanza recente da utilizzare Optimus credo.
Come suggerito da Giuseppemos installa la versione 14.04, dopodiché o installi bumblebee oppure installi i driver ufficiali da Software e Aggiornamenti, dalla sezione Driver Aggiuntivi.
M1rr0r92 Idea

Se i tempi non chiedono la tua parte migliore, inventa altri tempi.
Cita messaggio
#4
Grazie delle risposte.

Ho installato da apt-get perché in amministrazione>software e aggiornamenti>
driver aggiuntivi la finestra midiceva che non era disponibile nessun driver
aggiuntivo, decisamente strano.
Altrettanto strano che durante l'installazione dei driver nvidia si è
installato pure Bumblebee, e comunque tutto nero...
Ora sono sulla live 14.04 plus, penso che farò l'installazione come mi avet
suggerito.
Il pc ha due schede, sia l'Intel che la Nvidia.
Vedrò se utilizzare Optimus, devo ancora leggere tutta la documentazione.
 
Cita messaggio
#5
Optimus dovrai utilizzarlo per forza, altrimenti gli artefatti grafici saranno dietro l'angolo, e in generale il sistema sarà molto instabile.
Nella 13.10 credo che il kernel non riuscisse ancora a gestire bene la doppia scheda, sulla 14.04 invece tutto liscio.
M1rr0r92 Idea

Se i tempi non chiedono la tua parte migliore, inventa altri tempi.
Cita messaggio
#6
Infatti non va. Ho installato Bumblebee seguendo la guida
del forum per grafiche ibride Intel-Nvidia. Sembrava tutto a posto, ho
provato a lanciare vlc con optirun ed ecco il risultato:



Codice:
carlo@carlohost:~$ optirun glxgears [ 167.473619] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) NVIDIA(0): Failed to initialize the NVIDIA GPU at PCI:1:0:0. Please [ 167.473741] [ERROR]Aborting because fallback start is disabled. carlo@carlohost:~$ optirun 64glxgears [ 175.803471] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) NVIDIA(0): Failed to initialize the NVIDIA GPU at PCI:1:0:0. Please [ 175.803635] [ERROR]Aborting because fallback start is disabled.
Adesso provo a utilizzare Optimus.
Per me è arabo, sto cercando di capirci qualcosa ma mi sembra molto complicato.

 

 
Cita messaggio
#7
glxgears, non vlc...sorry
 
Cita messaggio
#8
Disintalla prima Bubmlebee e i driver precedentemente installati, riavvia e tramite Driver Aggiuntivi installa i driver 331 testati, i primi in alto. Dopodiché dovrai solo riavviare.
M1rr0r92 Idea

Se i tempi non chiedono la tua parte migliore, inventa altri tempi.
Cita messaggio
#9
Ok grazie, lo faccio subito.
Scusa l'ignoranza, ma quando disinstallo Bumblebee disinstallo
anche i driver (che si è portato dietro Bumblebee durante l'installazione)?
Se no, come faccio per vedere quali pacchetti del driver disinstallare,
vado in gestore pacchetti e cerco Nvidia?
Thx
 

 
Cita messaggio
#10
Se hai seguito la guida di Giuseppemos che rimanda al forum di linux mind, fai così:
Apri il terminale e digita:

sudo apt-get purge bumblebee bumblebee-nvidia nvidia-331

una volta finito, dai ancora:

sudo apt-get install ppa-purge

sudo ppa-purge ppa:bumblebee/stable

una volta finito riavvia. Dopodiché apri Driver Aggiuntivi e installa i driver nvidia 331 testati, i primi praticamente, Una volta installati, riavvia, troverai installato anche Nvidia Xserver Setting e, tramite la sezione Prime Profiles potrai scegliere quale scheda utilizzare, una volta scelto chiudi la sessione e rientra per rendere attie le modifiche.
M1rr0r92 Idea

Se i tempi non chiedono la tua parte migliore, inventa altri tempi.
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)