Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Si avvia tty1 invece che Ubuntu
#1
Oggi,25/12/2012,mi sta capitando questo: invece di partire Ubuntu 12.04 apre tty1 e devo scrivere da terminale, cosa che non mi garba, non essendo così abile nell'uso.Con Redo mi dice che devo cercare la versione a 64 bit.Provato con Rescatux,nulla.Dando fdisk -l scrive che le partizioni che si vedono ma per qualche motivo il grub -asterisco- sta su un diverso HD che fa di magazzino.Bho!
Nemmeno Rescatux da risultati,anzi riavviando Win ha dovuto fare un controllo disco.Riavviando in Ubuntu carica schermata presentazione Plus 9, quella blu con le stelle e a metà parte ttyy1.Che faccio, reinstallo?
Leggendo le risposte di Brunik e del prof mi sono ricordato che come ultima cosa avevo cambiato il driver di nvidia.Riavviando ora non trova o meglio non avvia Ubuntu,per quanto riguarda Win tutto regolare.Win si trova su hd 0,1 mentre Pangolin su hd 0,2.Con fdisk vedo che il grub non segna asterisco su Pangolin ma su un altra partizione dove sono dati o backup e quindi non può partire
Bene. Ora aggiorno:tentato di accedere in mod provvisoria ma non va.Con live come faccio ad accedere al terminale e agire sul sistema operativo così da scrivere purge nvidia? Con tty1 dava errore- non possibile.
Premetto che volevo fare il bravo evitando di fare disastri.Ho solo scelto un altro driver nvidia sperando di togliere l'effetto memoria quando chiudevo una pagina - diventando multipla sembrava un libro.Big Grin
Ubuntu Trusty Thar * Plus Remix 32 bit * -DE Gnome Fallback-NVIDIA GT240-512 Mb
Majonix 1 / Windows XP
Alle volte ci assalgono...pazienza...si stancheranno?
Cita messaggio
#2
quando sei in tty1 prova ad avviare la X con il comando startx - se parte fai il purge dei driver video che ha installato e potrebbero essee la causa dei problemi.

Ah piccola nota a corredo ... ieri era Natale oggi è Santo Stefano Wink
Cita messaggio
#3
L'asterisco sulla partizione di boot è ininfluente, tanto è vero che il sistema ti parte.
Ti resta su tty1 perché non ce la fa a caricare la x e quindi a trasferirsi su tty7 o tty8.

Certamente è successo qualche casino con xorg.
Potresti vedere se il nuovo driver ha creato un nuovo /etc/X11/xorg.conf sperando che prima ce ne fosse stato già un altro e che sia stato backuppato.

Ti do i comandi di root, vedi tu se occorre usarli con sudo

cd /etc/X11 vai nella directory
ls -l xorg* ti dà la lista dei file xorg presenti

Se vedi che c'è una versione precedente backuppata
cp xorg.conf xorg.conf.nonfunzia copi la versione attuale
cp xorg.conf.precedente xorg.conf riattivi la versione precedente

Se non c'è un xorg da recuperare
cp xorg.conf xorg.conf.nonfunzia
nano xorg.conf editi il file, cerchi il driver nella sezione display e cerchi di ricordarti il nome di quello vecchio.
Puoi provare a scrivere 'vesa' che è un driver generico in modo da riavviare l'interfaccia grafica e poi poter fare altre modifiche.

Se non c'è nessun xorg.conf
echo cazzarola non serve a nulla però lì per lì conforta.

EDIT
Non credo che questo comando ci sia in ubuntu, ma provare non fa male
do-vesa
Poi ti logghi da utente
startx in altre distro parte la x con vesa
[Immagine: http://pclinuxos.com/forum/avatars/Pengu...guitux.png] Parole !
Mai che se ne trovino due uguali !
Cita messaggio
#4
1.Lo so che oggi è il 26 ma avevo copiato il tread da un altro precedentemente scritto
2.startx non mi va, o meglio, mi scrive un sacco di cose che però io non so -anche cosa sta scritto nel nvidia.conf che però non riesco ad accedere.
3.Zafran sto provando ma dando il numero che compare dopo l'elenco dei permessi - cito:-rw-r--r-- 1 root root 83 dic 24 18:24 xorg.conf
-rw-r--r-- 1 root root 269 26 dic 11:33 xorg.failsafe
Bene suppongo debba scrivere 83 xorg.conf
risposta : cp: impossibile eseguire stst di "xorg.conf.83": file o directory non esistente
E ora...tento il resto intanto posto questo.
Ubuntu Trusty Thar * Plus Remix 32 bit * -DE Gnome Fallback-NVIDIA GT240-512 Mb
Majonix 1 / Windows XP
Alle volte ci assalgono...pazienza...si stancheranno?
Cita messaggio
#5
ciao, se posso intromettermi: partire con modalità di repristino e provare ad entrare in modalità grafica di emergenza non aiuta?
Cita messaggio
#6
(26-12-2012, 12:52 )dxgiusti Ha scritto: ciao, se posso intromettermi: partire con modalità di repristino e provare ad entrare in modalità grafica di emergenza non aiuta?

tutto uguale.Poi mi ritrovo tty1
Ubuntu Trusty Thar * Plus Remix 32 bit * -DE Gnome Fallback-NVIDIA GT240-512 Mb
Majonix 1 / Windows XP
Alle volte ci assalgono...pazienza...si stancheranno?
Cita messaggio
#7
altro tentativo:
sudo dpkg-reconfigure xserver-xorg
Cita messaggio
#8
(26-12-2012, 14:20 )dxgiusti Ha scritto: altro tentativo:
sudo dpkg-reconfigure xserver-xorg

questo da tty1?
Ubuntu Trusty Thar * Plus Remix 32 bit * -DE Gnome Fallback-NVIDIA GT240-512 Mb
Majonix 1 / Windows XP
Alle volte ci assalgono...pazienza...si stancheranno?
Cita messaggio
#9
si, poi sono andato in giro per il web ed ho visto:
http://wiki.ubuntu-it.org/Hardware/Video...eFrequenti
guarda :Come si riconfigura il server grafico?
sperando possa esserti ti aiuto
Cita messaggio
#10
Vi ringrazio ognuno di voi, di cuoreHeart
Purtroppo non sono riuscito nemmeno con i tuoi consigli, dxgiusti.Ho tentato e nonostante sembrava ci fosse una ripresa, alla fine mi torna tty1. A questo punto, opero col taglio finale:come dice il prof. "reinstalla e in 10 minuti hai finito".Se va a buon fine, farò sapere.
Ubuntu Trusty Thar * Plus Remix 32 bit * -DE Gnome Fallback-NVIDIA GT240-512 Mb
Majonix 1 / Windows XP
Alle volte ci assalgono...pazienza...si stancheranno?
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)