Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] TELECAMERA NON FUNZIONANTE CON SKYPE
#1
Buona sera,(sono uno che sfrutta il forum,si può fare una donazione?),su xp con skype classico la telecamera funziona,con Ubuntu 11.10 skype beta non funziona cosa posso fare?Grazia a chi mi risponde. Ho provato a mettere sotto wine il programma (cd) della telec. (trust) ma nessun risultato,premetto che con cabina Cheese funziona.


Allegati Anteprime
   

.odt   Senza nome 1.odt (Dimensione: 969,95 KB / Download: 2)
Cita messaggio
#2
Forse mancano alcuni plugin video di cui flash player, prova ad iinstallareo aggiornare il plugin e ritenta.
Cita messaggio
#3
Una volta stabilito che la cam ti funzioni con cheese, con i codec video e plugin dovresti essere a posto.

Io ho risolto con questo script, vedi se è anche il tuo caso, dal terminale dare:
gedit ~/.Skype/ScriptWebcam

incollarci in gedit :
#!/bin/bash
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype


per architettura a 32 bit il codice è:
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype

per architettura a 64 bit il codice è
LD_PRELOAD=/usr/lib32/libv4l/v4l1compat.so skype

salvare e chiudere

dare il comando:

chmod +x ~/.Skype/ScriptWebcam

Quindi infine tasto dx del muose su applicazioni-modifica menu,andare alla voce di skype cliccare su proprietà ,e riscriverci:
/home/utente/.Skype/ScriptWebcam
Mettere il proprio nome utente al posto di utente.

Questa ultima parte è riferità al menu di gnome2, tu dovrai adeguarti al desktop che usi, unity o gnome3 o gnome classic.

Però prima di fare il tutto controlla se la cam funziona avviando skipe dal terminale i comandi( copia e incolla)
per architettura a 32 bit il codice è:
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype

per architettura a 64 bit il codice è
LD_PRELOAD=/usr/lib32/libv4l/v4l1compat.so skype

se non funziona è inutile che applichi lo script,vuol dire che non è questa la causa del problema.




Bilodiego
Cita messaggio
#4
Question 
Però prima di fare il tutto controlla se la cam funziona avviando skipe dal terminale i comandi( copia e incolla)
per architettura a 32 bit il codice è:
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype
Così non funziona vedi all. Ho provato ugualmente a fare la procedura da Te suggerita "script" e non funziona nemmeno quella.


Allegati
.odt   Senza nome 1.odt (Dimensione: 786,46 KB / Download: 5)
Cita messaggio
#5
L'allegato è illeggibile meglio postare direttamente l'immagine della schermata, era un tentativo se non ti funziona il comando ovviamente non funziona nemmeno lo script.
Bilodiego
Cita messaggio
#6
Ma con cheese la cam funziona? E con Preferenze Pulseaudio?
Cita messaggio
#7
(16-03-2012, 13:59 )Alex57 Ha scritto: Ma con cheese la cam funziona? E con Preferenze Pulseaudio?

,premetto che con cabina Cheese funziona. (vedi parte iniziale dell'argomento),con pulseaudio non so quale è la procedura per verificare.In skype, opzioni, prova audio, si sente;i dispositivi microfono ecc. sono su "pulseaudio"

Cita messaggio
#8
    Il punto è che devo avere ora smanettato troppo nel terminale per cui pur avendo disinstallato e reinstallato skype tramite il centro ubuntu non si apre + il programma. QUESTO SONO RIUSCITO A RIMETTERLO COME PRIMA "LANCIO DI SKYPE DALL'ICONA, MA LA TELECAMERA NON SI AVVIA. Il terminale dà questa risposta: roberto@roberto-HP-Compaq:~$ LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype
ERROR: ld.so: object '/usr/lib/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded: ignored.




Allegati Anteprime
   
Cita messaggio
#9
CON QUESTO SCRIPT ho risolto il problema, che i suggerimenti di cui sopra non avevano portato a conclusione (la procedura l'ho copiata da altro sito),e la scrivo per coloro che si trovino nelle mie stesse condizioni:

Da terminale digitare

gedit ~/.Skype/ScriptWebcam

incollare

#!/bin/bash
LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so skype

salvare e chiudere

dare il comando:

chmod +x ~/.Skype/ScriptWebcam

trasformare in ubuntu classico con il comando da terminale

sudo apt-get install gnome-panel

Quindi infine tasto dx del muose su applicazioni-modifica menu,andare alla voce di skype cliccare su proprietà ,e riscriverci:
/home/utente/.Skype/ScriptWebcam

Mettere il proprio nome utente al posto di utente.
Cita messaggio
#10
un saluto a tutti, ed un grazie per le vostre preziose istruzioni.
seguendo le istruzioni sopra riportate, su ubuntu 11.10 64 bit, interfaccia ubuntu, la webcam logitech c 510 con skype continua a non funzionare, come pure con cheese. mentre con Camorama funziona correttamente.
qualcuno sa darmi qualche consiglio a riguardo.
p.s. sono un assoluto neofilo di Ubuntu.
grazie
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)