Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Ubuntu minimale, problemi di post installazione
#1
Salve a tutti., in riferimento alla guida
http://www.istitutomajorana.it/forum/Thr...u-Minimale
e al blog di Matteo Bonanomi http://ubuntufast.blogspot.ithttp://ubuntufast.blogspot.ithttp://ubuntufast.blogspot.ithttp://ubuntufast.blogspot.ithttp://ubuntufast.blogspot.it
penso di essermi cimentato in un'impresa troppo ardua date le mie conoscenze.
Ho scaricato la Iso http://archive.ubuntu.com/ubuntu/dists/p...t/mini.iso 64-bit PC (amd64, x86_64)
e l'ho installata secondo le indicazioni della guida.
Tutto OK.
Ho installato i programmi accessori consigliati , il Dispaly Manager SLIM e il Desktop Env MATE . , il gestore di pacchetti Synaptic , il gestore di partizioni Gparted e il browser Chromium.
Fin qui ancora tutto OK. Poi sono arrivati i guai.
Scegliendo menu Risorse vengono mostrate tutte le partizioni esistenti (ne ho 5 su 2 HD) ma non mi è permesso accedere a quelle che non sono di questo sistema: quella di windows, un altro paio di dati NTFS e un'altra dove c'è la versione plus 9 di Ubuntu. Stesso identico problema con chiavetta esterna USB e addirittura con il CD/DVD. Il messaggio che ricevo è sempre “IMPOSSIBILE MONTARE xxxx , NOT AUTHORIZED.
Penso dipenda dalle autorizzazioni anche il fatto che dal menu Sistema->Amministrazione non riesco ad avviare né Synaptic , né Gparted . Appena installati mi ci faceva accedere, ma rientrando dopo uno shut down se clicco sopra la voce del menu non parte niente senza il minimo messaggio di errore.
Posso entrare su Utenti e Gruppi ma mi è permesso solo cambiare la password, gli altri pulsanti nn producono nessun effetto.
Utilizzando il terminale ho creato un altro utente con uid inferiore a 1000 , sono riuscito a farlo amministratore riottenendo l'accesso a Gparted e Synaptic. Ma al rientro dopo uno shut down tutto ritorna come prima. Pistolando con gli utenti adesso non riesco neanche ad arrestare il sistema.
Il pulsante arresta già non c'era nell'applet, né sui menu. Lo shutdown da terminale ritorna il messaggio “userxxxx is not in the sudoers file. this incident will be reported”.
Lasciamo perdere per ora Remastersys che si installa apparentemente bene ma dà poi errori in esecuzione.
Sicuramente dipende dalla mia poca esperienza. Avrò omesso qualche passaggio che è dato per scontato esserne a conoscenza.
Prima di lasciar perdere e dedicarmi al giardinaggio qualcuno mi sa dare qualche consiglio e/o dire se in fase di installazione, al momento di scegliere i metapacchetti di interfaccia grafica, è opportuno selezionarne qualcuno?
Ma non ricordo di aver visto riferimenti a MATE tra quelli.
Concludo con un paio di note positive:
L' avvio del sistema è velocissimo, circa 12sec al login e 4sec dopo il login.
Chromium funziona perfettamente.
Ringrazio vivamente chi ha avuto la pazienza di leggere questo post.
Cita messaggio
#2
Dunque, il tuo problema mi coglie delle tutto impreparato, poichè già altri utenti seguendo la mia guida e facendo un'installazione minimale proprio di MATE riportavano delle ottime impressioni sulla distro in questione. Mai nessuno mi aveva parlato di tali inconvenienti.

Mi sembra di capire che tutto ciò che necessiti i permessi di amministratore non parta (gParted, così come il fatto di montare le altre partizioni, cosa che invece nella mia installazione minimale avviene in automatico...)

Riguardo a Gparted, ma temo non centri col problema, si porterà dietro delle dipendenze di Gnome3, credo, che forse non sono gradite a MATE (fork di Gnome2). Ma anche qui, non ne sono per nulla sicuro. E comunque mi parrebbe strano che sia la causa del tuo problema.

Cosa significa che il pulsante di accensione non funziona? Non appena hai installato MATE e riavviato il pc e visto per la prima volta il desktop, il tuo S.O. era pressochè vuoto, ma l'ambiente MATE doveva funzionare bene. Le poche applicazioni preinstallate dovevano avviarsi, così come gli applet del pannello dovevano funzionare senza problemi. E quindi anche quello per lo spegnimento doveva lavorare bene.

Mi viene il dubbio che in fase di installazione qualcosa sia andato storto, forse è caduta la connessione?
Cita messaggio
#3
@Matteo
Certo, anch'io penso che tutto dipenda dalla mancanza di permessi.
Faccio notare che in fase di installazione al momento di definizione utente (non ricordo la frase esatta) mi si informava che questo sarebbe stato creato senza i privilegi di amministratore. Ma non mi pare di aver avuto la possibilità di fare diversamente. L'unica cosa che ricordo è che avendo scelto una password < 4 caratteri mi è stato chiesto di confermare la scelta e andare avanti. Così ho fatto.
Quando parlo del pulsante “arresta” intendo dire che terminata l'installazione e riavviato il pc il pulsante arresta non c'era sul pannello superiore e neanche sull'applet per aggiungerlo al pannello. Non c'era neanche sul menu sistema , nè su sistema ->amministrazione e né sulle altre scelte di menu. Stesso discorso per “riavvia”.
Invece su sistema->amministrazione è presente la scelta “termina sessione” che però chiude la sessione corrente e mi rimanda al login senza possibilità di spegnere il pc.
Anche questo, secondo me, a rigor di logica, dipende dai permessi. Penso che in sistemi meno casalinghi non sia permesso a chiunque di spegnere la macchina.
Che in forse fase di installazione ci siano stati problemi di linea non lo posso escludere anche se magari distrattamente non mi sono accorto di messaggi di errore.
Data la sua gentilissima e tempestiva risposta sono stimolato a ritentare l'installazione da capo. Il giardinaggio può aspettare.
Forse non sarò altrettanto tempestivo ma le farò comunque sapere.
Ancora grazie per la cortese attenzione.
Cita messaggio
#4
Quel messaggio che ti informava del fatto che l'utente creato non fosse dotato dei permessi di amministratore non è normale, infatti se vedi nella guida non appare alcuna immagine relativa alla schermata che tu devi avere visualizzato.

Prova a ripetere l'operazione, non so se possa dipendere dalla password, comunque assicurati che sia lunga più di 6 caratteri...

Puoi installare MATE, ma potresti anche tentare di installare Gnome Classic. Non sarà scattante come MATE, essendo Gnome Classic basato su Gnome3, tuttavia forse avrà delle dipendenze, e dei software, a te più noti, in caso di bisogno, e non avrà problemi di conflitti con software provenienti da Gnome. L'aspetto estetico sarebbe simile a MATE...
Cita messaggio
#5
Veramente l' informazione era in anteprima alla creazione dell'utente , cioè prima che chiedesse il nome utente e password del tipo “ora passeremo alla creazione di un utente normale per le attività comuni ..” Reinstallando, se si ripresenta il caso, le farò sapere la frase esatta.
Comunque anche l'ordine delle operazioni era diverso da quello presentato in guida , cioè erano quelle ma si sono succedute in un ordine diverso. Non ho dato peso a ciò pensando dipendesse ad un qualche aggiornamento successivo di release.
Voglio ripartire dal download della ISO su cd. Stavolta opto per la versione a 32 bit invece che a 64 bit anche se ho una macchina a 64 bit Così se successivamente vorrò fare un sistema personalizzato su USB avviabile potrò usarlo anche su pc a 32 bit.
Insisto per il momento con MATE mirando a qualcosa di snello. Sull'utilizzo delle applicazioni di uso comune mi ci trovo benissimo: ne ho una versione live su chiavetta usb. Per la parte sistemistica Mate o Gnome3 non fa differenza sono comunque uno “scarso”.
Spero che il problema risieda altrove, tipo sulla versione a 64 bit o sulla qualità del cd dove avevo scaricato la iso.
Le farò sapere. Mille grazie.
Cita messaggio
#6
Dammi del tu innanzitutto. Sì, l'ordine delle fasi può variare con la versione, ma le fasi sono quelle e quelle restano. Ti consiglio di scaricare la versione 12.04 (la più recente ed è anche LTS), la 32bit su una macchina 64bit è consigliabile se e solo se disponi di 4Gb di RAM o meno.

Riguardo al DE, io MATE l'ho utilizzato poco, ma molti altri utenti usano Linux Mint e quindi mate lo conoscono meglio di me. Se dovesse proprio esserci un problema in fase di installazione Linux Mint potrebbe essere una valida alternativa. Attualmente sul mio portatile uso Gnome Classic e Gnome Shell, quindi personalmente potrei darti una mano su queste due interfacce.
Cita messaggio
#7
Per la cronaca, gparted non si avviava neanche nella versione di linux mint 13 mate di Alberto Arpaia, mentre installando la versione ufficiale di mint non ho avuto problemi.
Cita messaggio
#8
(21-09-2012, 23:22 )procton771 Ha scritto: Per la cronaca, gparted non si avviava neanche nella versione di linux mint 13 mate di Alberto Arpaia, mentre installando la versione ufficiale di mint non ho avuto problemi.

Mhmhmhmh questo è un mistero Huh
Cita messaggio
#9
Caro Matteo, ho delle novità : dopo la quarta installazione di ubuntu minimal-slim+mate provando a rimasterizzare il cd, provando la versione a 32 bit, provando password + lunga di 6 senza cavare un ragno dal buco sono entrato a gamba tesa e, senza disinstallare niente, com Slim e Mate già installati, ho installato anche GDM e Gnome shell/Gnome classic . Non essendomi documentato sull'ortodossia della mossa mi aspettavo uno schianto. Invece no. L’installazione di GDM mi ha chiesto se il predefinito era lui o Slim. Ho scelto lui. Dopo l’installazione di Gnome ho fatto il reboot.
E come per incanto tutto funziona .
In avvio tra il grub e il gdm c’è un messaggio di errore ma non si fa in tempo a leggere.
GDM fa scegliere con quale DE partire.
Sia Gnome che Mate funzionano. L’accesso ad altre partizioni è OK , Synaptic è utilizzabile e anche Gparted. La possibilità di arrestare il sistema è come dio comanda: termina sessione, riavvia, arresta.
Una cosa fastidiosa è che chiede la password anche per andare a fare la pipì:
Per accedere con il file manager alle altre partizioni bisogna autenticarsi. Va bè però questo è un altro film.
Come dicevi tu qualche modulo di Gnome a Mate manca.
Ho fatto ancora una prova: ho installato ubuntu minimale+GDM+Mate (senza Gnome) e ancora tutto funziona. Per cui il modulo mancante a MATE su GDM è presente (così la vede un profano come me).
Conclusione: a MATE manca qualche rotella , heem ..modulo. SLIM + MATE non è una buona accoppiata.
Adesso che ci ho preso gusto voglio provare altri Display Manager.
Poi ti voglio chiedere 2 cose:
1 Il tuo consiglio di provare linux Mint vuol dire installare ubuntu minimale+Xdm +Xfce o installare Mint12 plus che mi par aver visto da qualche parte su questo sito?
2 ti dispiace se tengo ancora aperta questa discussione per qualche giorno? Cosi posso far sapere i risultati di altre prove.
Grazie mille per l’attenzione prestatami.
Un cordiale Saluto a tutti.
Cita messaggio
#10
Tranquillo, fai tutti i test che vuoi. MATE è un progetto giovane, deve avere ricevuto qualche aggiornamento sbagliato negli scorsi giorni. In teoria dovrebbe essere totalmente indipendente da Gnome3, anzi installare GDM + MATE dovrebbe essere sconsigliabile, ma è evidente che gdm si porta dietro alcune importanti librerie che MATE evidentemente non ha. Oppure che ha ma non funzionano a dovere.

Il mio consiglio è, avendo scoperto la causa del problema, di non mischiare MATE con Gnome3, quindi di fare un'installazione minimale di GDM con solo ed esclusivamente Gnome Classic e Gnome Shell. Sono fatti apposta per stare assieme. Gnome Classic all'inizio ti può sembrare bruttino ma molto veloce, leggi QUI come personalizzarlo. Per quel che può riguardare la personalizzazione di Gnome Shell, puoi vedere QUESTO mio post qui sul forum.

Infine, per Linux Mint, ti consiglio di scaricarti la versione ufficiale dal sito di Mint. Linux Mint 13 MATE.
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)