Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Wine e driver proprietari Nvidia
#1
Salve a tutti, sto provando ad installare Wine su Ubuntu 14.04 ma avendo una scheda grafica Nvidia 610m ho impostato l'utilizzo dei driver proprietari. Se tento di installare Wine sia da Terminale che da Software Center mi dice che deve rimuovere il pacchetto nvidia-libopencl1-331, come posso ovviare al problema ?  (premetto che avevo installato già precedententemente wine e playonlinux con lo script per la plus ma non partiva nessun programma e li ho rimossi entrambi)
 

 
Arrendersi Totò
Cita messaggio
#2
Ciao, una soluzione al tuo problema e' quella di disinstallare wine,
aggiungere il repository di wine e quindi installare wine nella versione 1.7


 sudo add-apt-repository ppa:ubuntu-wine/ppa

sudo apt-get update

sudo apt-get install wine1.7
Cita messaggio
#3
Installato correttamente (sembra), però non va, se provo ad avviare blocco note (quello di default su wine) o qualche altra applicazione si apre solo l'icona di wine sulla barra a sinistra ma non compare nulla a schermo, nessuna finestra

 
Arrendersi Totò
Cita messaggio
#4
(25-04-2014, 13:37 )'flicten' Ha scritto: Installato correttamente (sembra), però non va, se provo ad avviare blocco note (quello di default su wine) o qualche altra applicazione si apre solo l'icona di wine sulla barra a sinistra ma non compare nulla a schermo, nessuna finestra

 

 


Prova a cancellare la cartella nascosta .wine nella tua home e riprova.
 
Cita messaggio
#5
Fatto, nulla di nuovo, non è cambiato nulla
 
Arrendersi Totò
Cita messaggio
#6
Da terminale cosa ti da quando lanci wine ?
 
Cita messaggio
#7
antonio@antonio-K55VD:~$ wine notepad.exe

p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/p11-kit-trust.so: /usr/lib/i386-linux-gnu/pkcs11/p11-kit-trust.so: impossibile aprire il file oggetto condiviso: File o directory non esistente
p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: impossibile aprire il file oggetto condiviso: File o directory non esistente



 

 
Arrendersi Totò
Cita messaggio
#8
(25-04-2014, 14:32 )'flicten' Ha scritto: antonio@antonio-K55VD:~$ wine notepad.exe

p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/p11-kit-trust.so: /usr/lib/i386-linux-gnu/pkcs11/p11-kit-trust.so: impossibile aprire il file oggetto condiviso: File o directory non esistente
p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: impossibile aprire il file oggetto condiviso: File o directory non esistente



 

 

 

da terminale :

sudo /usr/local/bin/getlibs -p p11-kit:i386
 e
sudo ln -s /usr/lib32/i386-linux-gnu/pkcs11/p11-kit-trust.so /usr/lib/i386-linux-gnu/pkcs11/p11-kit-trust.so
Cita messaggio
#9
Failed

antonio@antonio-K55VD:~$ sudo /usr/local/bin/getlibs -p p11-kit:i386
[sudo] password for antonio:
sudo: /usr/local/bin/getlibs: command not found
antonio@antonio-K55VD:~$ sudo ln -s /usr/lib32/i386-linux-gnu/pkcs11/p11-kit-trust.so /usr/lib/i386-linux-gnu/pkcs11/p11-kit-trust.so
ln: creazione del collegamento simbolico "/usr/lib/i386-linux-gnu/pkcs11/p11-kit-trust.so" non riuscita: File o directory non esistente
antonio@antonio-K55VD:~$

Il mio sistema è a 64 bit
 
Arrendersi Totò
Cita messaggio
#10
Sempre lavorando da terminale digita:

sudo apt-get install p11-kit

wget https://raw.github.com/spaetzlecode/getl...er/getlibs
sudo chown root:root getlibs
sudo chmod +x getlibs
sudo mv -n getlibs /usr/local/bin
sudo /usr/local/bin/getlibs -p p11-kit:i386
sudo ln -s /usr/lib32/i386-linux-gnu/pkcs11/p11-kit-trust.so /usr/lib/i386-linux-gnu/pkcs11/p11-kit-trust.so

 

 
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)