Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] Xubuntu 14.04 L.T.S e driver NVIDIA
#1
Ciao a tutti.

Stò tentando di riportare in vita una vecchia workstation.  HP xw600 per l'esattezza.  In origine aveva windows xp ma l'ho formattato mettendogli Xubuntu 14.04.

Il sistema funziona solo che ho un grosso problema con i driver video della scheda NVIDIA quadro4 XGL 750.

Ho seguito tutte le procedure che ho trovato online.  Ho scaricato il driver compatibile, sono uscito dal server x come richiesto dalla procedura. Inizio l'installazione ma a un certo punto si blocca e non la completa dicendo che manca un file (version.h) che si dovrebbe trovare in una directory.

Il file effettivamente lì non c'è.  Avevo letto che con la versione 14.04 di Xubuntu la directory predefinita dei driver nvidia poteva essere diversa.

Qualcuno mi sa dare una mano? 
 

 

Distribuzione in uso Xubuntu 14.04 
Cita messaggio
#2
I drive per la trua scheda sono i 100.... -> http://www.nvidia.it/download/driverResu...px/1257/it  -sono un pò vecchiotti. Secondo me ti conviene usare i nouveau.

 
Cita messaggio
#3
(21-06-2014, 10:03 )'roberto1155' Ha scritto: I drive per la trua scheda sono i 100.... -> http://www.nvidia.it/download/driverResu...px/1257/it  -sono un pò vecchiotti. Secondo me ti conviene usare i nouveau.

 

 


I driver giusti per me non sono nemmeno quelli.  Sono 96.  etc etc.....  Ma il problema non è il modello del driver.

E' che durante l'installazione a un certo punto si blocca pare perchè nel kernel manca un file...  (version.h) 

Ho guardato un pò in giro e sembra che la 14.04 abbia problemi con parecchi driver video.
 

Distribuzione in uso Xubuntu 14.04 
Cita messaggio
#4
ho formattato di nuovo e stò provando con la 13.10.

Pare che per il momento non ci sia nessuno dei problemi precedenti.

Metto risolto appena sono sicuro che sia quella la soluzione.

Se qualcuno ha altre idee me lo faccia sapere

Distribuzione in uso Xubuntu 14.04 
Cita messaggio
#5
Se sei sicuro che i drive sono i 96.. puoi installarli con il ppa. Così ci pensa il gestore pacchetti a trovare/scaricare tutte le dipendenze. Fai attenzione che i drive "nouveau" e "nvidia" vanno in conflitto. Se vuoi provare da ppa i comandi sono questi:


Codice:
sudo apt-add-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install -f
sudo reboot -h

dopo il riavvio vai in gestore pacchetti nel campo di ricerca metti "nvidia" e installa i 96.
 
Cita messaggio
#6
(21-06-2014, 12:28 )'roberto1155' Ha scritto: Se sei sicuro che i drive sono i 96.. puoi installarli con il ppa. Così ci pensa il gestore pacchetti a trovare/scaricare tutte le dipendenze. Fai attenzione che i drive "nouveau" e "nvidia" vanno in conflitto. Se vuoi provare da ppa i comandi sono questi:



Codice:
sudo apt-add-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install -f
sudo reboot -h

dopo il riavvio vai in gestore pacchetti nel campo di ricerca metti "nvidia" e installa i 96.
 

 


Si è quello che ho fatto.
Però non funziona bene.  

Con la 13.10 invece zero problemi.  Mi sa che fra poco scopriremo che il nuovo kernel della Trusty è una mezza ciofeca e che lo metteranno a posto.
 

Distribuzione in uso Xubuntu 14.04 
Cita messaggio
#7
@Hutch 46
Citazione:Si è quello che ho fatto.
Però non funziona bene.  
Che cosa aveva da non funzionare bene, puoi fare una breve descrizione. Sono parecchio interessato e come me parecchi possessori di vecchie nvidia che ora si trovano col c.lo per terra.

@roberto1155
hai esperienza diretta di quello che affermi o riporti solo notizie trovate in giro.

Mi spiego meglio: ho una nvidia GeForce4 4000MX che richiede i driver 96 che fino alla 12.04 erano OK.
Con la 14.04 ho tentato subito di installarli ma non c'è stato niente da fare, non erano nemmeno presenti nei repo e non c'erano nemmeno nella versione legacy (questa era stata portata avanti fino alla 13.10, ma poi anche lei abbandonata).

Ora sei sicuro che i 96 che si trovano nel ppa indicato siano anche per la 14.04? altrimenti perdo solo tempo.
Quel che so io è che queste schede sono state mollate da tutti (nemmeno gli open nouveau le supportano più) con le ultime distro girano solo con i driver mesa.
Vorrei tanto che tu mi smentissi.

 
Cita messaggio
#8
@andrea11 - è la stessa domanda che mi hai posto in un'altro forum. Si. Faccio presente che utilizzo "mate" come DE. Lui ha installato la 13.10.
La scheda è vecchia è vecchi sono i drive per cui i kernal più nuovi mal li supportano, così è meglio utilizzare quelli open nouveau o vesa.
 
Cita messaggio
#9
(21-06-2014, 12:56 )Hutch 46 Ha scritto: Con la 13.10 invece zero problemi.  Mi sa che fra poco scopriremo che il nuovo kernel della Trusty è una mezza ciofeca e che lo metteranno a posto.
 

Ragazzi, il kernel della 14.04 NON è una " mezza ciofeca". Semplicemente sono stati eliminati dei moduli per il supporto di alcune schede " molto vecchie ". Questo naturalmente è stato necessario per introdurre nuovi moduli per le schede più recenti, oltre a volere alleggerire il kernel che risulta essere infatti molto più performante delle versioni precedenti. Anche se utilizzaste i drivers open nouveau, avreste come riscontro delle pessime performance ed una visualizzazione " a scatti " , rilevabile soprattutto nello scorrimento delle pagine su siti web tramite il web browser utilizzato.
Le soluzioni sono 2, cercare ed installare una scheda video, magari usata, un poco più recente, ad esempio le geforce fx 5200 / 5600, sono ancora supportate dai driver legacy proprietari e funzionano bene, oppure cercare ed installare un' altra distro, che abbia magari un kernel meno recente e comunque LTS. Smile Per usare una metafora, non si può mettere il motore di una Ferrari sul telaio di una vecchia 500 originale, si devono comunque modificare alcune parti meccaniche per cercare di adattarlo. Spero di avervi chiarito un poco le idee..
I Heart GNU\Linux and PC-BSD too !!!
Il fine NON giustifica i mezzi !!
Cita messaggio
#10
(22-06-2014, 05:05 )'Teo' Ha scritto:
(21-06-2014, 12:56 )'Hutch 46' Ha scritto: Con la 13.10 invece zero problemi.  Mi sa che fra poco scopriremo che il nuovo kernel della Trusty è una mezza ciofeca e che lo metteranno a posto.
 

 

Ragazzi, il kernel della 14.04 NON è una " mezza ciofeca". Semplicemente sono stati eliminati dei moduli per il supporto di alcune schede " molto vecchie ". Questo naturalmente è stato necessario per introdurre nuovi moduli per le schede più recenti, oltre a volere alleggerire il kernel che risulta essere infatti molto più performante delle versioni precedenti. Anche se utilizzaste i drivers open nouveau, avreste come riscontro delle pessime performance ed una visualizzazione " a scatti " , rilevabile soprattutto nello scorrimento delle pagine su siti web tramite il web browser utilizzato.
Le soluzioni sono 2, cercare ed installare una scheda video, magari usata, un poco più recente, ad esempio le geforce fx 5200 / 5600, sono ancora supportate dai driver legacy proprietari e funzionano bene, oppure cercare ed installare un' altra distro, che abbia magari un kernel meno recente e comunque LTS. Smile Per usare una metafora, non si può mettere il motore di una Ferrari sul telaio di una vecchia 500 originale, si devono comunque modificare alcune parti meccaniche per cercare di adattarlo. Spero di avervi chiarito un poco le idee..

 



Direi che hai centrato il problema.  Ho montato anche una Radeon al posto della Nvidia per provare.
Non è cambiato nulla.

Poi formattando e mettendo la 13.10 con la Radeon non riscontro nessun problema di visualizzazione. Quindi il problema grosso è il nuovo kernel rispetto al vecchio.
Mi rimane solo una domanda. Con alcuni giochi mi va a scatti. Come faccio a sapere se  la scheda funziona bene?

Ho dato questo comando da terminale:


Codice:
michele@michele-Workstation-xw6000:~$ lspci -nn | grep VGA 01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] RV610 LE [Radeon HD 2400 PRO AGP] [1002:94c4] michele@michele-Workstation-xw6000:~$

Ho letto su qualche wiki di ubuntu che il driver RV610 è l'unico che in teoria supporta la scheda che ho montato adesso. Come faccio a sapere se la scheda rende al massimo di quello che può fare?
Che comando uso?

Grazie.
Enrico
 

Distribuzione in uso Xubuntu 14.04 
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)