Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO]adattatore usb wireless TP link wn721n
#1
ciao a tutti ho riscontrato un problema durante l'installazione di un adattatore USB wireless TP-LINK modello TL-WN721N.Possiedo un ubuntu 10.04 plus 5. Facendo una ricerca sui vari forum non ho ottenutorrisultati, ringrazio anticipatamente
> Saluti,Antonio
Cita messaggio
#2
Spiega meglio il problema ed eventualmente allega qualche immagine con l'eventuale errore.
Cita messaggio
#3
(14-09-2011, 17:53 )Antonio_Cantaro Ha scritto: Spiega meglio il problema ed eventualmente allega qualche immagine con l'eventuale errore.
il problema è che il pc non rileva la penna usb e di conseguenza non da nessun segnale, in windows funziona, ha un cd , anche utilizzando ndiswrapper mi dice che il driver è già installato


unica risposta valida ma i link non funzionano:
This last weekend and I have to play a little bit with Ubuntu 10.4 and my new wireless USB adapter TP-LINK model TL-WN721N. The Ubuntu 10.4 has not recognized the adapter, so I had to ask Google how to make that works. I’ve tried many things, one was using diswrapper with Windows Driver, but did not work. After another attempts I found a solution, and I decide to write here.

The first step is to get the firmware, you can download it from the following link:
http://git.kernel.org/?p=linux/kernel/gi...31c9f479a1

After the download you need to copy it to /dev/firmware directory:

sudo cp -r ~/Downloads/ar9271.fw /lib/firmware

Now we need to get the latest version of compact wireless, you can get it from the link below:

http://wireless.kernel.org/download/comp...eless-2.6/

I got the file compat-wireless-2.6.tar.bz2

After the download you will need to uncompress the file:

tar -xjvf compact-wireless-2.6.tar.bz2

Now, it’s time to compile the driver. Enter in directory:

cd compat-wireless-2010-05-23/

and type the command:

sudo make

After the compilation, you can install the driver using the command:

sudo make install

Now, you need to unload the old driver and load the new one:

sudo make unload

sudo make load ath9k_htc

After loading the new driver you must reboot you system and once the system rebooted you will be able to use your wireless connection.

I hope this tip will be useful for you.

See you!!

Leo

Reference: http://www.theinquirer.net/inquirer/news...nux-04-lts
Cita messaggio
#4
Sei sicuro che la soluzione riguarda il tuo modello di chiavetta? Uno degli ultimi riferimenti (sudo make load ath9k_htc) mi pare che riguardi i driver delle schede atheros classe 9000...
Segui il consiglio del professore, posta un'immagine dell'errore.
Ciao
 Trasferito sul Nuovo Forum [img]images/smilies/blush.gif[/img]
Cita messaggio
#5
Infatti e comunque cambiare il firmware di qualcosa che funziona non è mai una buona idea.
Se il driver risulta installato correttamente, vai su "connessioni di rete", passa al tab "Banda larga mobile", clicca sul pulsante "Aggiungi" e segui le istruzioni.
Ogni fallimento avvicina sempre più alla meta... Arrendersi subito equivale a non provare affatto.

Il bisogno di conoscere e scoprire, è la fiamma che alimenta la fornace che è il cervello umano.
Cita messaggio
#6
Antonio1,
ho fatto una ricerca. In effetti questo tipo di chiavetta usa un chipset Atheros.
https://help.ubuntu.com/community/Hardwa...rdsTP-Link

Esistono due versioni (vedi verso la fine della pagina): una con chipset 5416 (lavora bene con la 10.10) e una con chipset AR9271 (lavora bene con 11.04 64bit). Apparentemente lavorano con lo stesso driver.
Tu usi la 10.04.
In altre parole (anche se non sarebbe male conoscere che versione di chiavetta abbiamo) sembra che il kernel della 10.04 non sia compatibile con la chiavetta, da qui la necessità di intervenire sui firmware. C'è molta documentazione sul Web in proposito.

Si potrebbe prendere in considerazione (piuttosto che intervenire manualmente sulla versione del kernel) di lasciare la 10.04 per una versione successiva di Ubuntu.

Nel caso si voglia invece intervenire sui firmware, attendiamo l'intervento di qualcuno più esperto.

Ciao
 Trasferito sul Nuovo Forum [img]images/smilies/blush.gif[/img]
Cita messaggio
#7
(15-09-2011, 13:59 )Antonio1 Ha scritto:
(15-09-2011, 06:45 )giuscassr Ha scritto: Antonio1,
ho fatto una ricerca. In effetti questo tipo di chiavetta usa un chipset Atheros.
https://help.ubuntu.com/community/Hardwa...rdsTP-Link

Esistono due versioni (vedi verso la fine della pagina): una con chipset 5416 (lavora bene con la 10.10) e una con chipset AR9271 (lavora bene con 11.04 64bit). Apparentemente lavorano con lo stesso driver.
Tu usi la 10.04.
In altre parole (anche se non sarebbe male conoscere che versione di chiavetta abbiamo) sembra che il kernel della 10.04 non sia compatibile con la chiavetta, da qui la necessità di intervenire sui firmware. C'è molta documentazione sul Web in proposito.

Si potrebbe prendere in considerazione (piuttosto che intervenire manualmente sulla versione del kernel) di lasciare la 10.04 per una versione successiva di Ubuntu.

Nel caso si voglia invece intervenire sui firmware, attendiamo l'intervento di qualcuno più esperto.

Ciao
,
installo la ver. 10.10, una domanda, posso aggiornare la ver. 10.04 alla 10.10 plus 6 senza formattare?
ciao Antonio
Cita messaggio
#8
(15-09-2011, 14:31 )Antonio1 Ha scritto:
(15-09-2011, 13:59 )Antonio1 Ha scritto:
(15-09-2011, 06:45 )giuscassr Ha scritto: Antonio1,
ho fatto una ricerca. In effetti questo tipo di chiavetta usa un chipset Atheros.
https://help.ubuntu.com/community/Hardwa...rdsTP-Link

Esistono due versioni (vedi verso la fine della pagina): una con chipset 5416 (lavora bene con la 10.10) e una con chipset AR9271 (lavora bene con 11.04 64bit). Apparentemente lavorano con lo stesso driver.
Tu usi la 10.04.
In altre parole (anche se non sarebbe male conoscere che versione di chiavetta abbiamo) sembra che il kernel della 10.04 non sia compatibile con la chiavetta, da qui la necessità di intervenire sui firmware. C'è molta documentazione sul Web in proposito.

Si potrebbe prendere in considerazione (piuttosto che intervenire manualmente sulla versione del kernel) di lasciare la 10.04 per una versione successiva di Ubuntu.

Nel caso si voglia invece intervenire sui firmware, attendiamo l'intervento di qualcuno più esperto.

Ciao
,
installo la ver. 10.10, una domanda, posso aggiornare la ver. 10.04 alla 10.10 plus 6 senza formattare?
ciao Antonio
ho installato ubuntu 11.04 e in automatico la penna usb tp link wn721n ha funzionato tranquillamente, grazie a tutti
ciao Antonio

Cita messaggio
#9
Bene. Sono contento. Se l'interfaccia Unity non è di tuo gradimento puoi cambiarla con quella di Gnome quando all'apertura di Ubuntu selezioni il tuo user e metti la password (la scelta la trovi sulla barra in basso, devi selezionare "ubuntu classico")

Ciao
 Trasferito sul Nuovo Forum [img]images/smilies/blush.gif[/img]
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)