Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] driver - PRO/Wireless 5100 AGN
#1
Ciao.
Il mio notebook lenovo t400 ha integrata la scheda wireless
"Intel PRO/Wireless 5100 AGN [Shiloh] Network Connection (WiFi Link 5100 AGN)"
Regoralmente funzionante fino a ieri su Ubuntu 10.10.

Ho avuto la cattiva idea di provare l'adattatore usb:
"TP-Link TL-WN821N W-LAN Adattatore di rete USB 300 M"
ho installato i relativi driver e ha funzionato regoralmente.

Quando ho tentato di usare la scheda wireless integrata "Intel PRO/Wireless 5100tel PRO/Wireless 5100"
non l'ho più trovata disponibile, in qualche modo è stata disabilita.

Qualcuno sa come riabilitarla.

il comando
lspci | grep 'Network controller'
03:00.0 Network controller: Intel Corporation PRO/Wireless 5100 AGN [Shiloh]
la vede come hardware disponibile .

Quando provo a ricaricare il relativo modulo con modprobe compare l'errore
sudo modprobe iwlagn
FATAL: Error inserting iwlagn (/lib/modules/2.6.35-32-generic/kernel/drivers/net/wireless/iwlwifi/iwlagn.ko): Invalid argument


Grazie


Rosario Barbera
Cita messaggio
#2
Prova con a vedere se è presente il file /etc/modprobe.d/intel-5300-iwlagn-disable11n.conf
In caso affermativo rinominalo in intel-5300-iwlagn-disable11n.conf.old e riavvia.
Ogni fallimento avvicina sempre più alla meta... Arrendersi subito equivale a non provare affatto.

Il bisogno di conoscere e scoprire, è la fiamma che alimenta la fornace che è il cervello umano.
Cita messaggio
#3
(02-03-2012, 17:20 )francater Ha scritto: Prova con a vedere se è presente il file /etc/modprobe.d/intel-5300-iwlagn-disable11n.conf
In caso affermativo rinominalo in intel-5300-iwlagn-disable11n.conf.old e riavvia.

Il file esisteva e l'avevo spostato da un'altra parte ma la situazione non è cambiata.
Comunque ho risolto rimuovendo e poi reinstallando l'ultima immagine del
kernel (linux-image-2.6.35-32-generic) il modulo della scheda wireless probabilmente
era corrotto.
Grazie
Rosario Barbera
Cita messaggio
#4
Di niente, l'importante è risolvere. Exclamation
Ogni fallimento avvicina sempre più alla meta... Arrendersi subito equivale a non provare affatto.

Il bisogno di conoscere e scoprire, è la fiamma che alimenta la fornace che è il cervello umano.
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)