Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] errore grub dopo aggiornamento a ubuntu 14.04
#1
Ieri ho fatto l'aggiornamento da Ubuntu 13.10 ad Ubuntu 14.04 ma il sistema non parte più. Premetto che sul mio pc ho due hard disk in cui sul dev/sda 1 c'è linux e sul dev/sda2 c'è windows 7 e credo che il sistema sia in dual boot. Penso che si sia rovinato il grub; ho provato a ripristinarlo ma la procedura indicata in altri forum non ha dato i risultati sperati. qual' è la procedura corretta per il ripristino del grub?



 

 
Cita messaggio
#2
accedi ad ubuntu con supergrub disk ... e riscrivi grub nell'mbr del disco che viene visto per primo al boot
Cita messaggio
#3
La soluzione più corretta sarebbe stato reinstallare da zero. Nell'aggiornamento troppe cose possono andar storte.
Comunque prova a dare un'occhiata qui:
http://www.istitutomajorana.it/index.php...&Itemid=33
Se posso permettermi io metterei i sistemi operativi su un unico disco e l'altro lo riserverei come archivio.
mandi...Eugenio
Ubuntu 12.04 Unity, Ubuntu 14.04 Unity, Pclinuxos Mate, Mint17 Cinnamon, PcLinuxOS KDE
Cita messaggio
#4
(19-04-2014, 08:55 )'eu66' Ha scritto: La soluzione più corretta sarebbe stato reinstallare da zero. Nell'aggiornamento troppe cose possono andar storte.
Comunque prova a dare un'occhiata qui:
http://www.istitutomajorana.it/index.php...&Itemid=33
Se posso permettermi io metterei i sistemi operativi su un unico disco e l'altro lo riserverei come archivio.


 
Ho aperto ubuntu 14.04 con il cd super grub, pero adesso per il grub devo attivarlo su sda1 o sdb1
Codice:
stefano@stefano-System-Product-Name:~$ sudo fdisk -l
[sudo] password for stefano:

Disk /dev/sda: 82.3 GB, 82348277760 bytes
255 testine, 63 settori/tracce, 10011 cilindri, totale 160836480 settori
Unità = settori di 1 * 512 = 512 byte
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Identificativo disco: 0x000b9e01

Dispositivo Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048      206847      102400    7  HPFS/NTFS/exFAT
/dev/sda2          206848   160833535    80313344    7  HPFS/NTFS/exFAT

Disk /dev/sdb: 500.1 GB, 500107862016 bytes
255 testine, 63 settori/tracce, 60801 cilindri, totale 976773168 settori
Unità = settori di 1 * 512 = 512 byte
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Identificativo disco: 0x00014484

Dispositivo Boot      Start         End      Blocks   Id  System
/dev/sdb1            2048   968384511   484191232   83  Linux
/dev/sdb2       968386558   976771071     4192257    5  Esteso
Partition 2 does not start on physical sector boundary.
/dev/sdb5       968386560   976771071     4192256   82  Linux swap / Solaris
Cita messaggio
#5
dipende ... devi entrare in bios e capire quele disco è impostato come primario ... oppure (consigliato) farei il discorso inverso ... lo installi nello stesso disco di ubuntu ... se non va a buon fine cambi l'ordine nel boot.
Cita messaggio
#6
guardando su gparted nella stringa ci sono dev/sda1 e dev/sda2, e nella stringa del primo al termine c'è la scritta boot, mentre sotto ci sono dev/sdb1  (linux nel terminale) e dev/sdb2 ( esteso nel terminale)
       
(19-04-2014, 10:49 )'tumbler' Ha scritto: dipende ... devi entrare in bios e capire quele disco è impostato come primario ... oppure (consigliato) farei il discorso inverso ... lo installi nello stesso disco di ubuntu ... se non va a buon fine cambi l'ordine nel boot.

 



 
Cita messaggio
#7
non vuol dir nulla ... se vuoi capire quale dei due dischi è visto per primo devi accedere al bios ... prova ad installarlo in quello di ubuntu
Cita messaggio
#8
(19-04-2014, 11:34 )'tumbler' Ha scritto: non vuol dir nulla ... se vuoi capire quale dei due dischi è visto per primo devi accedere al bios ... prova ad installarlo in quello di ubuntu

 

comunque parte solo con il cd super grub, ho provato sia dev/sda che dev/sdb dove è linux ma non va. Forse devo indicaredev/sda1 oppure dev/sdb1?

 
Cita messaggio
#9
ciao, l'avvio va scritto sul disco che il bios identifica come primario. ovviamente va installato su mbr e non sulla partizione. il comando sarà:
sudo grub-install /dev/sdx
dove al posto della x metterai a oppure b
al termine di questo:
sudo update-grub
tutto questo da ubuntu con il disco di seven montato.
Cita messaggio
#10
(19-04-2014, 13:37 )'dxgiusti' Ha scritto: ciao, l'avvio va scritto sul disco che il bios identifica come primario. ovviamente va installato su mbr e non sulla partizione. il comando sarà:
sudo grub-install /dev/sdx
dove al posto della x metterai a oppure b
al termine di questo:
sudo update-grub
tutto questo da ubuntu con il disco di seven montato.

 
ho fatto entrambi i passaggi sia con dev/sda che con dev/sdb ma non sono riuscito a farlo funzionare. Forse dovrei mettere anche il numero ovvero dev/sda1 oppure dev/sdb1



 
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)