Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


//Removed by EUCookieLaw Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] ip statico su server ubuntu 1204 + lubuntu-desktop
#1
salve,
ho installato un server ubuntu 12.04, a cui ho aggiunto il desktop dci lubuntu.
ho cercato di assegnare un ip stastico usando il network manager del desktop,
ma le modifiche apportate al' IPV4 dell' eth0  non hanno funzionato.
Alllora ho modificato:
 /etc/network/interfaces

in questo modo:

    auto eth0
    #iface eth0 inet dhcp
    iface eth0 inet static
        address 192.168.1.24
        netmask 255.255.255.0
        network 192.168.1.0
        broadcast 192.168.1.255
        gateway 192.168.1.1

quindi ho riavviato :
sudo service network-manager restart
sudo service networking restart
sudo service resolvconf restart

e poi riavviato il server.

l'indirizzo IP è cambiato come volevo, però così non riesce più a collegarsi a interrnet.

come posso fare per avere l'ip statico e il collegamento ad internet?

grazie
danilo

P.S. : IP statico , non pubblico, solo per la mia LAN.

 

 
Cita messaggio
#2
allego configurazione via network manager, dove si vede che anche impostando ip ....24, con ifconfig risulta un ip ....21.


Allegati Anteprime
   
Cita messaggio
#3
se invece modifico il file  /etc/network/interfaces   
l'IP cambia ma non vede più internet, vede solo la lan.

danilo@SERVERubuntu32B1204:~$ cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
#iface eth0 inet dhcp
iface eth0 inet static
      address 192.168.1.24

      netmask 255.255.255.0
      network 192.168.1.0
      broadcast 192.168.1.255
      gateway 192.168.1.1
danilo@SERVERubuntu32B1204:~$


danilo@SERVERubuntu32B1204:~$ ifconfig
eth0      Link encap:Ethernet  IndirizzoHW d0:50:99:1d:0e:6f  
          indirizzo inet:192.168.1.24  Bcast:192.168.1.255  Maschera:255.255.255.0
          indirizzo inet6: fe80::d250:99ff:fe1d:e6f/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:6 errors:0 dropped:2 overruns:0 frame:0
          TX packets:32 errors:0 dropped:0 overruns:0 carrier:0
          collisioni:0 txqueuelen:1000
          Byte RX:444 (444.0 B)  Byte TX:7370 (7.3 KB)

lo        Link encap:Loopback locale  
          indirizzo inet:127.0.0.1  Maschera:255.0.0.0
          indirizzo inet6: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:198 errors:0 dropped:0 overruns:0 frame:0
          TX packets:198 errors:0 dropped:0 overruns:0 carrier:0
          collisioni:0 txqueuelen:0
          Byte RX:15560 (15.5 KB)  Byte TX:15560 (15.5 KB)

danilo@SERVERubuntu32B1204:~$ ping yahoo.com
ping: unknown host yahoo.com

danilo@SERVERubuntu32B1204:~$ ping 192.168.1.18
PING 192.168.1.18 (192.168.1.18) 56(84) bytes of data.
64 bytes from 192.168.1.18: icmp_req=1 ttl=64 time=5.15 ms

64 bytes from 192.168.1.18: icmp_req=2 ttl=64 time=4.23 ms
64 bytes from 192.168.1.18: icmp_req=3 ttl=64 time=4.34 ms
64 bytes from 192.168.1.18: icmp_req=4 ttl=64 time=4.27 ms
^C
--- 192.168.1.18 ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3005ms
rtt min/avg/max/mdev = 4.232/4.502/5.152/0.385 ms


 
Cita messaggio
#4
Forse può esserti utile questo link.

http://www.alfredoparisi.it/11/05/2012/i...ver-12-04/

Il link ad una prima occhiata mi sembra fatto bene, spero ti sia di aiuto.
Cita messaggio
#5
grazie, conoscevo già questo link, comunque, per scrupolo, ho rifatto la procedura indicata,ma senza risultato:
Codice:
danilo@sercer32b1204:~$ sudo vi /etc/network/interfaces
danilo@sercer32b1204:~$ sudo cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
#iface eth0 inet dhcp
iface eth0 inet static
address 192.168.1.24
gateway 192.168.1.1
netmask 255.255.255.0

danilo@sercer32b1204:~$ sudo vi /etc/resolvconf/resolv.conf.d/head
[sudo] password for danilo:
danilo@sercer32b1204:~$ sudo cat /etc/resolvconf/resolv.conf.d/head
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 208.67.222.222
nameserver 208.67.220.220
danilo@sercer32b1204:~$ sudo /etc/init.d/networking restart
 * Running /etc/init.d/networking restart is deprecated because it may not enable again some interfaces
 * Reconfiguring network interfaces...                                          ssh stop/waiting
ssh start/running, process 2814
                                                                         [ OK ]
danilo@sercer32b1204:~$ ifconfig
eth0      Link encap:Ethernet  IndirizzoHW d0:50:99:1d:0e:6f  
          indirizzo inet:192.168.1.24  Bcast:192.168.1.255  Maschera:255.255.255.0
          indirizzo inet6: fe80::d250:99ff:fe1d:e6f/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:890 errors:0 dropped:42 overruns:0 frame:0
          TX packets:913 errors:0 dropped:0 overruns:0 carrier:0
          collisioni:0 txqueuelen:1000
          Byte RX:106419 (106.4 KB)  Byte TX:124822 (124.8 KB)

lo        Link encap:Loopback locale  
          indirizzo inet:127.0.0.1  Maschera:255.0.0.0
          indirizzo inet6: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:6 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
          collisioni:0 txqueuelen:0
          Byte RX:448 (448.0 B)  Byte TX:448 (448.0 B)

danilo@sercer32b1204:~$ ping www.google.it
ping: unknown host www.google.it
danilo@sercer32b1204:~$ cat /etc/resolv.conf
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 208.67.222.222
mameserver 208.67.220.220


danilo@sercer32b1204:~$ sudo vi /etc/resolvconf/resolv.conf.d/head
danilo@sercer32b1204:~$ sudo[b] cat /etc/resolvconf/resolv.conf.d/head[/b]
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
[b]nameserver 208.67.222.222
nameserver 208.67.220.220[/b]
danilo@sercer32b1204:~$ [b]cat /etc/resolv.conf[/b]
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 208.67.222.222
[b]mameserver 208.67.220.220[/b]            perchè [b]mam[/b]... se io ho scritto [b]nam[/b]....?

danilo@sercer32b1204:~$ [b]sudo vi /etc/resolv.conf[/b]      lo correggo qui
danilo@sercer32b1204:~$ sudo [b]cat /etc/resolv.conf[/b]
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 208.67.222.222
[b]nameserver 208.67.220.220[/b]
danilo@sercer32b1204:~$
danilo@sercer32b1204:~$ sudo /etc/init.d/networking restart
 * Running /etc/init.d/networking restart is deprecated because it may not enable again some interfaces
 * Reconfiguring network interfaces...                                          ssh stop/waiting
ssh start/running, process 2991
                                                                         [ OK ]
danilo@sercer32b1204:~$ [b]ping www.google.it
ping: unknown host www.google.it[/b]
danilo@sercer32b1204:~$
 
Cita messaggio
#6
Prova da terminale con:

Codice:
sudo su

ifconfig eth0 192.168.1.24 up

Controlla poi con
Codice:
ifconfig
se ha impostato.

Questo però è temporaneo, quindi nel file: /etc/network/interfaces

Se sei rimasto con la shell di root (#) non hai bisogno di sudo:

Codice:
gedit /etc/network/interfaces

Codice:
# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
iface eth0 inet static
address 192.168.1.24
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
gateway 192.168.1.1
dns-nameserver 8.8.8.8
auto eth0

Prova ad impostare cosi e riavvia il network.
Cita messaggio
#7
grazie, ma le impostazioni che mi suggerisci , sono le stesse che ho già provato e che ho riportato nel mio primo post.
 
Cita messaggio
#8
Non è cosi, ma come vuoi.
Ti ho suggerito un impostazione con un comando da terminale.
Per il file ho messo in diverso ordine le cose e ci sono dei contenuti che tu non avevi usato mettere.
Se vuoi provare entrambe le cose vedi tu.
Ciao
Cita messaggio
#9
Scusa, ho rifatto tutto come suggerisci tu, di seguito il risultato:
Codice:
danilo@sercer32b1204:~$ [b]sudo su[/b]
[sudo] password for danilo:
root@sercer32b1204:/home/danilo# ifconfig
eth0      Link encap:Ethernet  IndirizzoHW d0:50:99:1d:0e:6f  
          indirizzo inet:192.168.1.24  Bcast:192.168.1.255  Maschera:255.255.255.0
          indirizzo inet6: fe80::d250:99ff:fe1d:e6f/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:207 errors:0 dropped:6 overruns:0 frame:0
          TX packets:229 errors:0 dropped:0 overruns:0 carrier:0
          collisioni:0 txqueuelen:1000
          Byte RX:21647 (21.6 KB)  Byte TX:22106 (22.1 KB)

lo        Link encap:Loopback locale  
          indirizzo inet:127.0.0.1  Maschera:255.0.0.0
          indirizzo inet6: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:6 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
          collisioni:0 txqueuelen:0
          Byte RX:448 (448.0 B)  Byte TX:448 (448.0 B)

root@sercer32b1204:/home/danilo# [b]ifconfig eth0 192.168.1.24 up[/b]
root@sercer32b1204:/home/danilo# [b]ifconfig[/b]
eth0      Link encap:Ethernet  IndirizzoHW d0:50:99:1d:0e:6f  
          i[b]ndirizzo inet:192.168.1.24  Bcast:192.168.1.255  Maschera:255.255.255.0[/b]
          indirizzo inet6: fe80::d250:99ff:fe1d:e6f/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:238 errors:0 dropped:7 overruns:0 frame:0
          TX packets:259 errors:0 dropped:0 overruns:0 carrier:0
          collisioni:0 txqueuelen:1000
          Byte RX:24746 (24.7 KB)  Byte TX:24293 (24.2 KB)

lo        Link encap:Loopback locale  
          indirizzo inet:127.0.0.1  Maschera:255.0.0.0
          indirizzo inet6: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:6 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
          collisioni:0 txqueuelen:0
          Byte RX:448 (448.0 B)  Byte TX:448 (448.0 B)

root@sercer32b1204:/home/danilo# gedit /etc/network/interfaces
Il programma "gedit" non è attualmente installato.  È possibile installarlo digitando:
apt-get install gedit
root@sercer32b1204:/home/danilo# [b]vi /etc/network/interfaces[/b]
root@sercer32b1204:/home/danilo# [b]cat /etc/network/interfaces[/b]
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
#iface eth0 inet dhcp
i[b]face eth0 inet static
address 192.168.1.24
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
gateway 192.168.1.1
dns-nameserver 8.8.8.8
auto eth0[/b]

root@sercer32b1204:/home/danilo# [b]/etc/init.d/networking restart[/b]
 * Running /etc/init.d/networking restart is deprecated because it may not enable again some interfaces
 * Reconfiguring network interfaces...                                          ssh stop/waiting
ssh start/running, process 2407
                                                                         [ OK ]
root@sercer32b1204:/home/danilo# [b]ifconfig[/b]
eth0      Link encap:Ethernet  IndirizzoHW d0:50:99:1d:0e:6f  
          [b]indirizzo inet:192.168.1.24  Bcast:192.168.1.255  Maschera:255.255.255.0[/b]
          indirizzo inet6: fe80::d250:99ff:fe1d:e6f/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:370 errors:0 dropped:15 overruns:0 frame:0
          TX packets:403 errors:0 dropped:0 overruns:0 carrier:0
          collisioni:0 txqueuelen:1000
          Byte RX:37686 (37.6 KB)  Byte TX:38974 (38.9 KB)

lo        Link encap:Loopback locale  
          indirizzo inet:127.0.0.1  Maschera:255.0.0.0
          indirizzo inet6: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:6 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
          collisioni:0 txqueuelen:0
          Byte RX:448 (448.0 B)  Byte TX:448 (448.0 B)

root@sercer32b1204:/home/danilo#[b] ping www.google.it
ping: unknown host www.google.it[/b]
root@sercer32b1204:/home/danilo#

Il problema non è assegnare l'ip statitico, ma fare in modo che con l'ip stattico riesca a collegarsi ad internet.

 
Cita messaggio
#10
Infatti secondo me è un problema di dns ma non so da dove (Per quello ho provato ad aggiungerli direttamente a interfaces anche se sono gestiti oggigiorno da resolv).
Sarebbe da azzerare tutte le configurazioni che hai fatto e riprovare da zero in maniera pulita.
Quando si comincia a smanettare si possono fare involontariamente dei problemi ulteriori che dopo è anche difficile individuare.
Cita messaggio


Vai al forum: