Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] manjaro e17
#1
buongiorno a tutti : sulla manjaro versione cinnamon ho installato enlightenment ma , mentre dalla sessione cinnamon funziona tutto bene , quando entro con e17 nessun file manager mi permette di aprire le altre partizioni dell'hard disk
mi dice che non ho i permessi e se avvio pcmanfm o anche thunar da root non le ha prorio nel mel menu , la cartella "media" se aperta risulta vuota

ho provato a chiedere sul forum di arch ma evidentemente manjaro h qualche differenza
Cita messaggio
#2
Scusa non ho capito:
Tu guardi in /media/ con thunar o pcmanfm e la vedi vuota.
Quindi ti dice che non hai i permessi quando provi a attivare delle icone che sono già sul desktop?

/etc/fstab com'è scritto?
[Immagine: http://pclinuxos.com/forum/avatars/Pengu...guitux.png] Parole !
Mai che se ne trovino due uguali !
Cita messaggio
#3
Codice:
#
# /etc/fstab: static file system information
#
# <file system>    <dir>    <type>    <options>    <dump>    <pass>
UUID=78ac1434-b387-44d1-98bf-fa447c675ece swap swap defaults 0 0
UUID=862d51ca-b2d4-420a-bd4e-35a9d1ddf68e / ext4 defaults 0 1

fstab contiene solo questo

praticamente su pcmanfm c'è il menu dei volumi a sinistra dove li clicchi per montarli , ma al momento del montaggio da questo messaggio in una finestra d'errore : Not authorized to perform operation

mentre se esco dalla sessione e rientro con cinnamon va tutto bene
sembra un problema di permessi ma solo se entro con enlightenment
Cita messaggio
#4
ho provato ad installare lxde e va bene
sembra che non abbia i permessi solo in enlightenment
Cita messaggio
#5
Evidentemente è una cattiva integrazione di e17 nel sistema: dispiace ma non fa meraviglia, purtroppo.
C'è da dire che ho provato manjaro recentemente e codesto problema non l'ho trovato.
Io mi farei pochi problemi e metterei il mount direttamente in fstab per le partizioni del disco fisso che mi interessassero.

Le unità removibili hanno lo stesso problema di automount?
Quello dovrebbe essere più facile che funzioni.
Nel caso che non vada neanche l'automount da usb, potresti prevedere dei lanciatori che attivino una stringa di mount.
[Immagine: http://pclinuxos.com/forum/avatars/Pengu...guitux.png] Parole !
Mai che se ne trovino due uguali !
Cita messaggio
#6
i dispositivi esterni li vede bene ma le partizioni nell'hard disk non mi permette di montarle neanche usando gparted
mentre in fstab avevo aggiunto anche le altre cosi'
UUID=xxxxxxxxxxxxxxxxxxxxxxxxxx / ext4 defaults 0 1
dove al posto delle x mettevo l'uuid che mi diceva , ma cosi' facendo sono scomparsi dal file manager
Cita messaggio
#7
Cioè hai montato una partizione direttamente in /?
Non mi sembra una grande idea. Smile
Devi fare una dir che diventi punto di mount (normalmente /mnt/sdaX)
Qiindi:
UUID=xxxxxxxxxxxxxxxxxxxxxxxxxx /mnt/sdaX ext4 defaults 0 1
[Immagine: http://pclinuxos.com/forum/avatars/Pengu...guitux.png] Parole !
Mai che se ne trovino due uguali !
Cita messaggio
#8
ecco perche'
e devo crearne una per ogni partizione immagino , giusto?

mi sono aiutato anche con questa guida per aggiungerli a fstab http://forum.chakra-project.it/index.php?topic=2558.0

grazie mille
Cita messaggio
#9
Sinceramente a leggere ogni cosa non mi ci sono messo.
Do per scontato che ne sappiano più di me e che la guida sia chiara.

Per ogni partizione che vuoi montata fin dall'avvio del sistema devi creare un punto di mount (cioè una dir di solito in mnt o dove ti pare) e una voce in fstab.

Dopo l'avvio, il sistema prenderà nota dell'esistenza di altre partizioni non montate e alcuni filemanager saranno in grado di offrirti delle icone con le quali attivarne un mount semiautomatico.

Se questo con e17 non succede, se hai bisogno di montarne una, niente vieta di fare come si è sempre fatto:
# mkdir /mnt/sdaX
# mount /dev/sdaX /mnt/sdaX

cioè da shell di root e senza riscrivere # che c'è già.
Che resta il modo più veloce di fare le cose.
[Immagine: http://pclinuxos.com/forum/avatars/Pengu...guitux.png] Parole !
Mai che se ne trovino due uguali !
Cita messaggio
#10
A seguito di update di qualche giorno fà, riavviando la macchina ho trovato anche io un problema su Manjaro con DE Mate.
In pratica non riuscivo più a montare le altre partizioni/dischi all'interno del PC, mentre nessun problema su unità esterne.
Se tentavo di montarle mi ritornava anche a me un bel "Not authorized to perform operation".
Ricordando qualche informazione appresa su Chakra mi sono compilato il mio fstab per avere al boot, nel cosiddetto user space, le unità montate di default.
Dopo un tentativo andato a vuoto ho avuto successo, ma ora mi chiedo....che cosa è accaduto?
Prima, al boot, le unità le visualizzava correttamente su caja (l'equivalente di Nautilus) ed al primo mount inserendo la pwd di amministratore, potevo accedervi, poi il problema.....
Ho anche tentato la strada dello script ~/.xinitrc, ma senza successo....
Sarà stato systemd?

bye
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)