Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] ntfs e samba
#1
Forse l'argomento è già stato trattato. Ho provato a controllare in altre discussioni ma non ho trovato nulla di quanto mi è accaduto.
Nel mio PC ho 4 dischi rigidi:
1o) ssd formattato ntfs con installato windows7
20) ssd formattato  ext4 con partizione swap con installato kubuntu 13.10
3o) hdd formattato ntfs per gestione dati, denominato DATI
4o) hdd formattato ntfs per gestione dati, denominato STORAGE
Per gestire le partizioni ntfs ho installato il pacchetto strumento di configurazione NTFS, rendendolo operativo per tutte e 3 le partizione ntfs

Dopo aver installato Samba, volevo rendere visibili a tutti gli utenti alcune cartelle in ambedue gli hhd (3 e 4). Ho dato comando di condivisione alle cartelle con samba a tutti gli utenti. A questo punto è successa una cosa inaspettata: per l'hdd 3 funziona tutto, per 4 non dà accesso agli utenti.
Spero qualcuno possa aiutarmi oppure dovrò arrendermi [img]images/smilies/arrendo.gif[/img]

Allego file smb.conf

[global] 
    workgroup = WORKGROUP
    client lanman auth = Yes
    server string = %h server (Samba, Ubuntu)
    dns proxy = no
    name resolve order = bcast host lmhosts wins
    os level = 33
    log file = /var/log/samba/log.%m
    max log size = 1000
    syslog = 0
    security = share
;    passdb backend = tdbsam
    obey pam restrictions = yes
    unix password sync = yes
    passwd program = /usr/bin/passwd %u
    passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
    pam password change = yes
    map to guest = bad user
    usershare allow guests = yes
;    wins support = no
    usershare owner only = False
    create mask = 0755

[printers] 
    comment = All Printers
    browseable = no
    path = /var/spool/samba
    printable = yes
;    guest ok = no
;    read only = yes
    create mask = 0700


[print$] 
    comment = Printer Drivers
    path = /var/lib/samba/printers
;    browseable = yes
;    read only = yes
;    guest ok = no

 

 
Cita messaggio
#2
credo sia un problema di permessi dell'HDD4.
vedi se nell' /etc/fstab come opzione di mount dell'HDD4 c'è umask=000 che dà tutti i permessi, (tutti i permessi ovviamente se è quello che vuoi impostare)

http://wiki.ubuntu-it.org/Hardware/Dispo...zioni/Ntfs
http://wiki.ubuntu-it.org/AmministrazioneSistema/Fstab
[utente Gnu/Linux dilettante]
Cita messaggio
#3
(02-03-2014, 18:50 )'francesco-tux' Ha scritto: credo sia un problema di permessi dell'HDD4.
vedi se nell' /etc/fstab come opzione di mount dell'HDD4 c'è umask=000 che dà tutti i permessi, (tutti i permessi ovviamente se è quello che vuoi impostare)

http://wiki.ubuntu-it.org/Hardware/Dispo...zioni/Ntfs
http://wiki.ubuntu-it.org/AmministrazioneSistema/Fstab

 

Grazi per l aiuto Francesco.
Allora, ho provato a modificare il file fstab, senza successo. Poi mi sono accorto che il posizionamento di hdd4 era sotto
/media/gabrio/storage gli altri sotto  /media/...
ho spostato tramite fstab la posizione dell hhd sotto media, riavviato, e ora tutto funziona correttamente

 
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)