Consenso all'uso dei cookies

SITO1 -- SITO2 -- Forum2 -- CercaGlobale -- Informativa su Cookie e Privacy

Questo Forum1 è in sola lettura -- Usa il Forum2


Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO] problema grub
#1
Salve,sono a chiedevi un aiuto per un problema che ultimamente mi perseguita[img]images/smilies/biggrin.gif[/img]..
In  pratica da poco ho acquistato un noteboob dell'hp con windows 8,dopo vari tentativi e soprattuto aiutato da un ragazzo molto esperto sono riuscito a risolvere il problema del grub. Infatti prima il grub non mi trovava ubuntu e partiva automaticamente con windows,oggi ho provato ad installare anche mint, che volevo provare, ora è tornato il problem del grub. In pratica posso scegliere tra ubuntu e mint ma non riesco a fare partire windows!!! ho già provato con secure boot,ma niente non funziona, ho anche letto varie discussioni ma non riesco a risolvere, come posso fare? grazie mille.
 

 
Cita messaggio
#2
Se hai windows 8 nativo il tuo disco sarà partizionato in GPT ed avrai una partizione UEFI ... che io sappia il grub devi installarlo in quella partizione e non ad inizio disco.

Esempio:
presupponendo che il tuo disco sia identificato come sda e la partizione UEFI sia la prima ... dovrai installare GRUB in /dev/sda1

P.S. non hai altri dischi collegati vero?
N.B. non ho nè Win8 ne un disco GPT ... quello che so l'ho letto ma mai testato!
Cita messaggio
#3
(08-04-2014, 06:56 )tumbler Ha scritto: Se hai windows 8 nativo il tuo disco sarà partizionato in GPT ed avrai una partizione UEFI ... che io sappia il grub devi installarlo in quella partizione e non ad inizio disco.

Esempio:
presupponendo che il tuo disco sia identificato come sda e la partizione UEFI sia la prima ... dovrai installare GRUB in /dev/sda1

P.S. non hai altri dischi collegati vero?
N.B. non ho nè Win8 ne un disco GPT ... quello che so l'ho letto ma mai testato!



 no ho un solo disco, inoltre ho notato che non riesco a fare partire boot repaire in modalità uefi ma solo in modalità legacy e questo comporta che quando procedo alla riparazione del Grub mi chiede di avviare il cd in uefi, non capisco come mai
Cita messaggio
#4
http://paste.ubuntu.com/7223691/
questo è il file log di boot repaire.
Cita messaggio
#5
Giuseppe ma alla fine dove lo installi sto grub ... in che partizione?
Cita messaggio
#6
 Seguendo le istruzioni di boot repaire ho creato una partizione di boot, che dovrebbe essere in sda 8.
Cita messaggio
#7
Io risolvo con Rescatoux SuperGrub, ti rileva tutti i sistemi operativi e ti crea un grub su misura. Basta farlo girare una volta.
 
Cita messaggio
#8
dal sistema installato oppure in live, apri il terminale:
sudo fdisk -l
copia/incolla tutto il contenuto del risultato. 
Cita messaggio
#9
alla fine ho deciso di formattare tutto e ripartire da windows 8 e poi riprovare a mettere ubuntu in un secondo momento, seguiro la guida suggerita nel forum (http://www.istitutomajorana.it/index.php...&Itemid=33) e poi vi farò sapere se sono riuscito.  Smile

 
Cita messaggio
#10
Ciao ragazzi.
allora ho seguito la guida e il risultato è andato a buon fine, finalmente posso scegliere tra i due sistemi operativi anche se per farlo all'avvio devo schiacciare f9 per fa partire la modalità di scelta boot.
purtoppo ancora non carica il grub in automatico,cosa mi consigliate ? di lasciare le cose come stanno o usare boot repaire?

 

 
Cita messaggio


Vai al forum:


Utenti che stanno guardando questa discussione: 1 Ospite(i)